aboutsummaryrefslogtreecommitdiff
path: root/textproc/aspell/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-02-18 16:10:58 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-02-18 16:10:58 +0000
commit1657b8c95d34d23f2bebc10b754589ef9f0ac3b8 (patch)
treeb34502c5006fb0cab4137055f939e7d3a832ea87 /textproc/aspell/Makefile
parentfd2ab5d1e883f335a652d49740c79bd55cd5ced0 (diff)
Notes
Diffstat (limited to 'textproc/aspell/Makefile')
-rw-r--r--textproc/aspell/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index 6a5c10750000..b2d90c0f6608 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -6,22 +6,24 @@
#
PORTNAME= aspell
-PORTVERSION= 0.32.5
+PORTVERSION= 0.33
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTNAME= ${PORTNAME}-.32.5
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/^0//}
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= pspell.4:${PORTSDIR}/textproc/pspell
USE_NEWGCC= yes
+USE_GMAKE= yes
USE_LIBTOOL= yes
-INSTALLS_SHLIB= yes
-CONFIGURE_ENV+= CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-USE_GMAKE= yes
-MAKE_ARGS+= NOPORTDOCS=${NOPORTDOCS}
+CONFIGURE_ARGS= --enable-dict-dir=${PREFIX}/share/aspell \
+ --enable-doc-dir=${PREFIX}/share/doc/aspell
+MAKE_ARGS= NOPORTDOCS=${NOPORTDOCS}
+INSTALLS_SHLIB= yes
.include <bsd.port.mk>