aboutsummaryrefslogtreecommitdiff
path: root/textproc/aspell
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-03-19 23:05:44 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-03-19 23:05:44 +0000
commit5136c164f1fe5cbf733204392ba7979b61ab2cee (patch)
treebe4b6547adb3d87578f9491e988267a2560281a1 /textproc/aspell
parent73b28d21abb05491fa7bb66c5f76d37d5387ae35 (diff)
downloadports-5136c164f1fe5cbf733204392ba7979b61ab2cee.tar.gz
ports-5136c164f1fe5cbf733204392ba7979b61ab2cee.zip
Notes
Diffstat (limited to 'textproc/aspell')
-rw-r--r--textproc/aspell/Makefile231
-rw-r--r--textproc/aspell/distinfo54
-rw-r--r--textproc/aspell/pkg-plist.af4
-rw-r--r--textproc/aspell/pkg-plist.bg4
-rw-r--r--textproc/aspell/pkg-plist.da1
-rw-r--r--textproc/aspell/pkg-plist.ga6
-rw-r--r--textproc/aspell/pkg-plist.gl4
-rw-r--r--textproc/aspell/pkg-plist.hr4
-rw-r--r--textproc/aspell/pkg-plist.id4
-rw-r--r--textproc/aspell/pkg-plist.is6
-rw-r--r--textproc/aspell/pkg-plist.it1
-rw-r--r--textproc/aspell/pkg-plist.mi4
-rw-r--r--textproc/aspell/pkg-plist.ms4
-rw-r--r--textproc/aspell/pkg-plist.sk3
-rw-r--r--textproc/aspell/pkg-plist.sl4
15 files changed, 180 insertions, 154 deletions
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index 994e67b6970c..9f33b1fba593 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -7,6 +7,7 @@
PORTNAME?= aspell
PORTVERSION= 0.50.5
+PORTREVISION= 1
CATEGORIES+= textproc
MASTER_SITES= http://aspell.net/ \
${MASTER_SITE_GNU}
@@ -42,17 +43,32 @@ DESCR= ${.CURDIR}/pkg-descr
CONF_DICT_ENV= ASPELL="${PREFIX}/bin/aspell" \
WORD_LIST_COMPRESS="${PREFIX}/bin/word-list-compress"
-AVAIL_DICT= br ca cs cy da de el en eo es fo fr it nl no pl pt ro ru sk sv uk
-DICTVERSION= 0.50
-DICTVERSION2= 0.51
-DICTREVISION= 2
-DICTREVISION2= 3
-DICTREVISION3= 0
-UDICT1= cy
-UDICT2= el
-UDICT3= fr
-UDICT4= uk
-UDICT5= en
+AVAIL_DICT= af bg br ca cs cy da de el en eo es fo fr hr id it ga gl is mi ms \
+ nl no pl pt ro ru sk sl sv uk
+SPECDICTS= af bg cs cy da el en fo fr ga gl hr id is it mi ms pl sk sl sv uk
+DICTVERSION= 0.50-2
+DICTVER_AF= 0.50-0
+DICTVER_BG= 0.50-0
+DICTVER_CS= 0.51-0
+DICTVER_CY= 0.50-3
+DICTVER_DA= 0.50.1-0
+DICTVER_EL= 0.50-3
+DICTVER_EN= 0.51-1
+DICTVER_FO= 0.51-0
+DICTVER_FR= 0.50-3
+DICTVER_GA= 0.50-4
+DICTVER_GL= 0.50-0
+DICTVER_HR= 0.50-0
+DICTVER_ID= 0.50-0
+DICTVER_IS= 0.51-0
+DICTVER_IT= 0.52-0
+DICTVER_MI= 0.50-0
+DICTVER_MS= 0.50-0
+DICTVER_PL= 0.51-0
+DICTVER_SK= 0.51-1
+DICTVER_SL= 0.50-0
+DICTVER_SV= 0.51-0
+DICTVER_UK= 0.51-0
DICT_SUFFIX= .tar.bz2
.include <bsd.port.pre.mk>
@@ -67,12 +83,46 @@ DEF_DICT= ${i}
DEF_DICT?= en
pre-everything::
-.if (!defined(ASPELL_BR) && !defined(ASPELL_CA) && !defined(ASPELL_CS) && !defined(ASPELL_CY) && !defined(ASPELL_DA) && !defined(ASPELL_DE) && !defined(ASPELL_EL) && !defined(ASPELL_EN) && !defined(ASPELL_EO) && !defined(ASPELL_ES) && !defined(ASPELL_FO) && !defined(ASPELL_FR) && !defined(ASPELL_IT) && !defined(ASPELL_NL) && !defined(ASPELL_NO) && !defined(ASPELL_PL) && !defined(ASPELL_PT) && !defined(ASPELL_RO) && !defined(ASPELL_RU) && !defined(ASPELL_SK) && !defined(ASPELL_SV) && !defined(ASPELL_UK))
+.if (!defined(ASPELL_AF) \
+ && !defined(ASPELL_BG) \
+ && !defined(ASPELL_BR) \
+ && !defined(ASPELL_CA) \
+ && !defined(ASPELL_CS) \
+ && !defined(ASPELL_CY) \
+ && !defined(ASPELL_DA) \
+ && !defined(ASPELL_DE) \
+ && !defined(ASPELL_EL) \
+ && !defined(ASPELL_EN) \
+ && !defined(ASPELL_EO) \
+ && !defined(ASPELL_ES) \
+ && !defined(ASPELL_FO) \
+ && !defined(ASPELL_FR) \
+ && !defined(ASPELL_GA) \
+ && !defined(ASPELL_GL) \
+ && !defined(ASPELL_HR) \
+ && !defined(ASPELL_ID) \
+ && !defined(ASPELL_IS) \
+ && !defined(ASPELL_IT) \
+ && !defined(ASPELL_MI) \
+ && !defined(ASPELL_MS) \
+ && !defined(ASPELL_NL) \
+ && !defined(ASPELL_NO) \
+ && !defined(ASPELL_PL) \
+ && !defined(ASPELL_PT) \
+ && !defined(ASPELL_RO) \
+ && !defined(ASPELL_RU) \
+ && !defined(ASPELL_SK) \
+ && !defined(ASPELL_SL) \
+ && !defined(ASPELL_SV) \
+ && !defined(ASPELL_UK))
@${ECHO_MSG} '*********************************************************'
@${ECHO_MSG} '* You can add further dictionaries: *'
@${ECHO_MSG} '* Use make-flag: *'
+ @${ECHO_MSG} '* - Afrikaans ASPELL_AF=yes *'
+ @${ECHO_MSG} '* - Bulgarian ASPELL_BG=yes *'
@${ECHO_MSG} '* - Breton ASPELL_BR=yes *'
@${ECHO_MSG} '* - Catalan ASPELL_CA=yes *'
+ @${ECHO_MSG} '* - Croatian ASPELL_HR=yes *'
@${ECHO_MSG} '* - Czech ASPELL_CS=yes *'
@${ECHO_MSG} '* - Danish ASPELL_DA=yes *'
@${ECHO_MSG} '* - Dutch ASPELL_NL=yes *'
@@ -80,15 +130,22 @@ pre-everything::
@${ECHO_MSG} '* - Esperanto ASPELL_EO=yes *'
@${ECHO_MSG} '* - Faroese ASPELL_FO=yes *'
@${ECHO_MSG} '* - French ASPELL_FR=yes *'
+ @${ECHO_MSG} '* - Galician ASPELL_GL=yes *'
@${ECHO_MSG} '* - German ASPELL_DE=yes *'
@${ECHO_MSG} '* - Greek ASPELL_EL=yes *'
+ @${ECHO_MSG} '* - Icelandic ASPELL_IS=yes *'
+ @${ECHO_MSG} '* - Indonesian ASPELL_ID=yes *'
+ @${ECHO_MSG} '* - Irish (Gaelic) ASPELL_GA=yes *'
@${ECHO_MSG} '* - Italian ASPELL_IT=yes *'
+ @${ECHO_MSG} '* - Maori ASPELL_MI=yes *'
+ @${ECHO_MSG} '* - Malay ASPELL_MS=yes *'
@${ECHO_MSG} '* - Norwegian ASPELL_NO=yes *'
@${ECHO_MSG} '* - Polish ASPELL_PL=yes *'
@${ECHO_MSG} '* - Portuguese ASPELL_PT=yes *'
@${ECHO_MSG} '* - Romanian ASPELL_RO=yes *'
@${ECHO_MSG} '* - Russian ASPELL_RU=yes *'
@${ECHO_MSG} '* - Slovak ASPELL_SK=yes *'
+ @${ECHO_MSG} '* - Slovenian ASPELL_SL=yes *'
@${ECHO_MSG} '* - Spanish ASPELL_ES=yes *'
@${ECHO_MSG} '* - Swedish ASPELL_SV=yes *'
@${ECHO_MSG} '* - Ukrainian ASPELL_UK=yes *'
@@ -97,147 +154,51 @@ pre-everything::
@${ECHO_MSG} '* Example: "make ASPELL_FR=yes ASPELL_EN=yes install" *'
@${ECHO_MSG} '*********************************************************'
.else
-.if defined(ASPELL_BR)
-DICTS+= br
-.endif
-.if defined(ASPELL_CA)
-DICTS+= ca
-.endif
-.if defined(ASPELL_CS)
-DICTS+= cs
-.endif
-.if defined(ASPELL_CY)
-DICTS+= cy
-.endif
-.if defined(ASPELL_DA)
-DICTS+= da
-.endif
-.if defined(ASPELL_DE)
-DICTS+= de
-.endif
-.if defined(ASPELL_EL)
-DICTS+= el
-.endif
-.if defined(ASPELL_EN)
-DICTS+= en
-.endif
-.if defined(ASPELL_EO)
-DICTS+= eo
-.endif
-.if defined(ASPELL_ES)
-DICTS+= es
-.endif
-.if defined(ASPELL_FO)
-DICTS+= fo
-.endif
-.if defined(ASPELL_FR)
-DICTS+= fr
-.endif
-.if defined(ASPELL_IT)
-DICTS+= it
-.endif
-.if defined(ASPELL_NL)
-DICTS+= nl
-.endif
-.if defined(ASPELL_NO)
-DICTS+= no
-.endif
-.if defined(ASPELL_PL)
-DICTS+= pl
-.endif
-.if defined(ASPELL_PT)
-DICTS+= pt
-.endif
-.if defined(ASPELL_RO)
-DICTS+= ro
-.endif
-.if defined(ASPELL_RU)
-DICTS+= ru
-.endif
-.if defined(ASPELL_SK)
-DICTS+= sk
-.endif
-.if defined(ASPELL_SV)
-DICTS+= sv
-.endif
-.if defined(ASPELL_UK)
-DICTS+= uk
-.endif
+. for LG in ${AVAIL_DICT}
+. if defined(ASPELL_${LG:U})
+DICTS+= ${LG}
+. endif
+. endfor
.endif
.if !defined(DICTS)
-.for LG in ${AVAIL_DICT}
-.if (${DEF_DICT} == ${LG})
+. for LG in ${AVAIL_DICT}
+. if (${DEF_DICT} == ${LG})
DICTS= ${LG}
-.endif
-.endfor
+. endif
+. endfor
.endif
.for DICO in ${DICTS}
-.if (${UDICT1} == ${DICO})
-DISTFILES+= aspell-${DICO}-${DICTVERSION}-${DICTREVISION2}${DICT_SUFFIX}
-.elif (${UDICT2} == ${DICO})
-DISTFILES+= aspell-${DICO}-${DICTVERSION}-${DICTREVISION2}${DICT_SUFFIX}
-.elif (${UDICT3} == ${DICO})
-DISTFILES+= aspell-${DICO}-${DICTVERSION}-${DICTREVISION2}${DICT_SUFFIX}
-.elif (${UDICT4} == ${DICO})
-DISTFILES+= aspell-${DICO}-${DICTVERSION}-${DICTREVISION2}${DICT_SUFFIX}
-.elif (${UDICT5} == ${DICO})
-DISTFILES+= aspell-${DICO}-${DICTVERSION2}-${DICTREVISION3}${DICT_SUFFIX}
-.else
-DISTFILES+= aspell-${DICO}-${DICTVERSION}-${DICTREVISION}${DICT_SUFFIX}
-.endif
+MASTER_SITES+= ftp://ftp.gnu.org/gnu/aspell/dict/${DICO}/:dict${DICO}
+. if (${SPECDICTS:M${DICO}*} != "")
+DISTFILES+= aspell-${DICO}-${DICTVER_${DICO:U}}${DICT_SUFFIX}:dict${DICO}
+. else
+DISTFILES+= aspell-${DICO}-${DICTVERSION}${DICT_SUFFIX}:dict${DICO}
+. endif
.endfor
post-extract:
.for DICO in ${DICTS}
-.if (${UDICT1} == ${DICO})
- @cd ${WRKDIR} && \
- ${TAR} -xjf ${DISTDIR}/aspell-${DICO}-${DICTVERSION}-${DICTREVISION2}${DICT_SUFFIX}
-.elif (${UDICT2} == ${DICO})
- @cd ${WRKDIR} && \
- ${TAR} -xjf ${DISTDIR}/aspell-${DICO}-${DICTVERSION}-${DICTREVISION2}${DICT_SUFFIX}
-.elif (${UDICT3} == ${DICO})
- @cd ${WRKDIR} && \
- ${TAR} -xjf ${DISTDIR}/aspell-${DICO}-${DICTVERSION}-${DICTREVISION2}${DICT_SUFFIX}
-.elif (${UDICT4} == ${DICO})
+. if (${SPECDICTS:M${DICO}*} != "")
@cd ${WRKDIR} && \
- ${TAR} -xjf ${DISTDIR}/aspell-${DICO}-${DICTVERSION}-${DICTREVISION2}${DICT_SUFFIX}
-.elif (${UDICT5} == ${DICO})
+ ${TAR} -xjf ${DISTDIR}/aspell-${DICO}-${DICTVER_${DICO:U}}${DICT_SUFFIX}
+. else
@cd ${WRKDIR} && \
- ${TAR} -xjf ${DISTDIR}/aspell-${DICO}-${DICTVERSION2}-${DICTREVISION3}${DICT_SUFFIX}
-.else
- @cd ${WRKDIR} && \
- ${TAR} -xjf ${DISTDIR}/aspell-${DICO}-${DICTVERSION}-${DICTREVISION}${DICT_SUFFIX}
-.endif
+ ${TAR} -xjf ${DISTDIR}/aspell-${DICO}-${DICTVERSION}${DICT_SUFFIX}
+. endif
.endfor
post-install:
.for DICO in ${DICTS}
@${ECHO_MSG} "===> Installing for ${DICO} dictionaries"
-.if (${UDICT1} == ${DICO})
- @cd ${WRKDIR}/aspell-${DICO}-${DICTVERSION}-${DICTREVISION2} && \
- ${CONF_DICT_ENV} ./${CONFIGURE_SCRIPT} && \
- ${GMAKE} install
-.elif (${UDICT2} == ${DICO})
- @cd ${WRKDIR}/aspell-${DICO}-${DICTVERSION}-${DICTREVISION2} && \
- ${CONF_DICT_ENV} ./${CONFIGURE_SCRIPT} && \
- ${GMAKE} install
-.elif (${UDICT3} == ${DICO})
- @cd ${WRKDIR}/aspell-${DICO}-${DICTVERSION}-${DICTREVISION2} && \
- ${CONF_DICT_ENV} ./${CONFIGURE_SCRIPT} && \
+. if (${SPECDICTS:M${DICO}*} != "")
+ @cd ${WRKDIR}/aspell-${DICO}-${DICTVER_${DICO:U}} && \
+ ${CONF_DICT_ENV} ./${CONFIGURE_SCRIPT} && \
${GMAKE} install
-.elif (${UDICT4} == ${DICO})
- @cd ${WRKDIR}/aspell-${DICO}-${DICTVERSION}-${DICTREVISION2} && \
- ${CONF_DICT_ENV} ./${CONFIGURE_SCRIPT} && \
+. else
+ @cd ${WRKDIR}/aspell-${DICO}-${DICTVERSION} && \
+ ${CONF_DICT_ENV} ./${CONFIGURE_SCRIPT} && \
${GMAKE} install
-.elif (${UDICT5} == ${DICO})
- @cd ${WRKDIR}/aspell-${DICO}-${DICTVERSION2}-${DICTREVISION3} && \
- ${CONF_DICT_ENV} ./${CONFIGURE_SCRIPT} && \
- ${GMAKE} install
-.else
- @cd ${WRKDIR}/aspell-${DICO}-${DICTVERSION}-${DICTREVISION} && \
- ${CONF_DICT_ENV} ./${CONFIGURE_SCRIPT} && \
- ${GMAKE} install
-.endif
+. endif
@${CAT} ${MASTERDIR}/pkg-plist.${DICO} >> ${TMPPLIST}
.endfor
@${ECHO_CMD} "@dirrm share/aspell" >> ${TMPPLIST}
diff --git a/textproc/aspell/distinfo b/textproc/aspell/distinfo
index e8732d10be06..a03d36732ab6 100644
--- a/textproc/aspell/distinfo
+++ b/textproc/aspell/distinfo
@@ -1,46 +1,64 @@
MD5 (aspell-0.50.5.tar.gz) = 14403d2ea5ded5d3fc9bb259bf65aab5
SIZE (aspell-0.50.5.tar.gz) = 1016586
+MD5 (aspell-af-0.50-0.tar.bz2) = bde617a195e70364f96eea71cf71a333
+SIZE (aspell-af-0.50-0.tar.bz2) = 256111
+MD5 (aspell-bg-0.50-0.tar.bz2) = d4869e4cba11abfac1c58745e1d95e03
+SIZE (aspell-bg-0.50-0.tar.bz2) = 271589
MD5 (aspell-br-0.50-2.tar.bz2) = 800c7a28e09bd7734d1501cb7a91ad8f
SIZE (aspell-br-0.50-2.tar.bz2) = 68055
MD5 (aspell-ca-0.50-2.tar.bz2) = c593ae266d3e48e4d482ff9b9a52acdd
SIZE (aspell-ca-0.50-2.tar.bz2) = 137626
-MD5 (aspell-cs-0.50-2.tar.bz2) = ac4ea210149e6b312b63a862c27df5b4
-SIZE (aspell-cs-0.50-2.tar.bz2) = 457939
+MD5 (aspell-cs-0.51-0.tar.bz2) = 4be28bef4385ef46e80547ce8cdc4535
+SIZE (aspell-cs-0.51-0.tar.bz2) = 626618
MD5 (aspell-cy-0.50-3.tar.bz2) = d59fee193dba87973b38ac2862a090bb
SIZE (aspell-cy-0.50-3.tar.bz2) = 117652
-MD5 (aspell-da-0.50-2.tar.bz2) = c023f246ef448128e6a3b93388ed57e7
-SIZE (aspell-da-0.50-2.tar.bz2) = 284049
+MD5 (aspell-da-0.50.1-0.tar.bz2) = 1bf582a9aa0e0f8007a2ba9d52964e7e
+SIZE (aspell-da-0.50.1-0.tar.bz2) = 304097
MD5 (aspell-de-0.50-2.tar.bz2) = 204a9737ff0110fb8c7d284bd7200f7d
SIZE (aspell-de-0.50-2.tar.bz2) = 304820
MD5 (aspell-el-0.50-3.tar.bz2) = 0ea2c42ceb9b91f7f5de2c017234ad37
SIZE (aspell-el-0.50-3.tar.bz2) = 328225
-MD5 (aspell-en-0.51-0.tar.bz2) = 8f1eab27d02e44b15c833d5a7b24f9cd
-SIZE (aspell-en-0.51-0.tar.bz2) = 172819
+MD5 (aspell-en-0.51-1.tar.bz2) = aabb933daee93be446c71e79babf8da4
+SIZE (aspell-en-0.51-1.tar.bz2) = 172874
MD5 (aspell-eo-0.50-2.tar.bz2) = f84147f5909e1a5f7adb86f27c71eb8c
SIZE (aspell-eo-0.50-2.tar.bz2) = 89703
MD5 (aspell-es-0.50-2.tar.bz2) = 4a8583e9ef9f4aed03f5a7fe09d40060
SIZE (aspell-es-0.50-2.tar.bz2) = 157809
-MD5 (aspell-fo-0.50-2.tar.bz2) = 9a1031062c72ffce7dac284ed0006a02
-SIZE (aspell-fo-0.50-2.tar.bz2) = 73174
+MD5 (aspell-fo-0.51-0.tar.bz2) = 5cc9168ad88ceb1b5531a5452527728b
+SIZE (aspell-fo-0.51-0.tar.bz2) = 161169
MD5 (aspell-fr-0.50-3.tar.bz2) = 53a2d05c4e8f7fabd3cefe24db977be7
SIZE (aspell-fr-0.50-3.tar.bz2) = 283086
-MD5 (aspell-it-0.50-2.tar.bz2) = efa602e47fc49db2cc670f7e5c1628e1
-SIZE (aspell-it-0.50-2.tar.bz2) = 38409
+MD5 (aspell-hr-0.50-0.tar.bz2) = 5b04a3102a58c9bb26b7a71178ad2d84
+SIZE (aspell-hr-0.50-0.tar.bz2) = 425054
+MD5 (aspell-id-0.50-0.tar.bz2) = dc63181fcafa01e735366a70d861c1fb
+SIZE (aspell-id-0.50-0.tar.bz2) = 48715
+MD5 (aspell-it-0.52-0.tar.bz2) = 03e14dab69e0ecb132dda02fe0c220fc
+SIZE (aspell-it-0.52-0.tar.bz2) = 45138
+MD5 (aspell-gl-0.50-0.tar.bz2) = 0cd3c4e3e325e080689657f03eff8e8e
+SIZE (aspell-gl-0.50-0.tar.bz2) = 112313
+MD5 (aspell-is-0.51-0.tar.bz2) = fa61cbe8ec3594ec0190ad3e81c3a7aa
+SIZE (aspell-is-0.51-0.tar.bz2) = 323327
+MD5 (aspell-mi-0.50-0.tar.bz2) = 8b1a07032ee086662bfe44a2e0459db4
+SIZE (aspell-mi-0.50-0.tar.bz2) = 57818
+MD5 (aspell-ms-0.50-0.tar.bz2) = cfdd94bba4781766c5d870202abd60e0
+SIZE (aspell-ms-0.50-0.tar.bz2) = 50368
MD5 (aspell-nl-0.50-2.tar.bz2) = c3ef9fd7dc4c47d816eee9ef5149c76a
SIZE (aspell-nl-0.50-2.tar.bz2) = 428365
MD5 (aspell-no-0.50-2.tar.bz2) = b24b20ad02ce2a569f71f949b48823cc
SIZE (aspell-no-0.50-2.tar.bz2) = 286696
-MD5 (aspell-pl-0.50-2.tar.bz2) = a56f6f7e0ad8eb2dce9e8724b2c7496e
-SIZE (aspell-pl-0.50-2.tar.bz2) = 311840
+MD5 (aspell-pl-0.51-0.tar.bz2) = 5435be1c9c39326a02e2798d8b4d257b
+SIZE (aspell-pl-0.51-0.tar.bz2) = 624458
MD5 (aspell-pt-0.50-2.tar.bz2) = e4e15179f90b76ec0336b687d1293edd
SIZE (aspell-pt-0.50-2.tar.bz2) = 201341
MD5 (aspell-ro-0.50-2.tar.bz2) = 96d97a79a0a0e04c580e0d0671d650c9
SIZE (aspell-ro-0.50-2.tar.bz2) = 64110
MD5 (aspell-ru-0.50-2.tar.bz2) = d7add85adeef2ea36457ea811d52c295
SIZE (aspell-ru-0.50-2.tar.bz2) = 521827
-MD5 (aspell-sk-0.50-2.tar.bz2) = 8f4db7bf8ffe8c49cd16621620a43240
-SIZE (aspell-sk-0.50-2.tar.bz2) = 243884
-MD5 (aspell-sv-0.50-2.tar.bz2) = 8d50ddf72f750d187b0ffc440328db84
-SIZE (aspell-sv-0.50-2.tar.bz2) = 90602
-MD5 (aspell-uk-0.50-3.tar.bz2) = 0b37b59539424a6980814ce5392725a8
-SIZE (aspell-uk-0.50-3.tar.bz2) = 382364
+MD5 (aspell-sk-0.51-1.tar.bz2) = c0216d6d53b8c2e3b5bce435999a782c
+SIZE (aspell-sk-0.51-1.tar.bz2) = 379613
+MD5 (aspell-sl-0.50-0.tar.bz2) = c4c11402bc834d796d1b56e711470480
+SIZE (aspell-sl-0.50-0.tar.bz2) = 215463
+MD5 (aspell-sv-0.51-0.tar.bz2) = d180c781f8986ea0f65b6b18f02a494e
+SIZE (aspell-sv-0.51-0.tar.bz2) = 93942
+MD5 (aspell-uk-0.51-0.tar.bz2) = 767bfca10c64b239b05cb8b68a78f4ad
+SIZE (aspell-uk-0.51-0.tar.bz2) = 382513
diff --git a/textproc/aspell/pkg-plist.af b/textproc/aspell/pkg-plist.af
new file mode 100644
index 000000000000..d28eea688f48
--- /dev/null
+++ b/textproc/aspell/pkg-plist.af
@@ -0,0 +1,4 @@
+share/aspell/af.dat
+share/aspell/af.multi
+share/aspell/af.rws
+share/aspell/afrikaans.alias
diff --git a/textproc/aspell/pkg-plist.bg b/textproc/aspell/pkg-plist.bg
new file mode 100644
index 000000000000..0074228a7330
--- /dev/null
+++ b/textproc/aspell/pkg-plist.bg
@@ -0,0 +1,4 @@
+share/aspell/bg.dat
+share/aspell/bg.multi
+share/aspell/bg.rws
+share/aspell/bulgarian.alias
diff --git a/textproc/aspell/pkg-plist.da b/textproc/aspell/pkg-plist.da
index b7c0537b6790..e7abd954d60f 100644
--- a/textproc/aspell/pkg-plist.da
+++ b/textproc/aspell/pkg-plist.da
@@ -2,5 +2,4 @@ share/aspell/da.dat
share/aspell/da.multi
share/aspell/da.rws
share/aspell/da_phonet.dat
-share/aspell/danish.alias
share/aspell/dansk.alias
diff --git a/textproc/aspell/pkg-plist.ga b/textproc/aspell/pkg-plist.ga
new file mode 100644
index 000000000000..68d154024559
--- /dev/null
+++ b/textproc/aspell/pkg-plist.ga
@@ -0,0 +1,6 @@
+share/aspell/ga.dat
+share/aspell/ga.multi
+share/aspell/ga.rws
+share/aspell/ga_phonet.dat
+share/aspell/gaeilge.alias
+share/aspell/irish.alias
diff --git a/textproc/aspell/pkg-plist.gl b/textproc/aspell/pkg-plist.gl
new file mode 100644
index 000000000000..93a4af370961
--- /dev/null
+++ b/textproc/aspell/pkg-plist.gl
@@ -0,0 +1,4 @@
+share/aspell/gl.dat
+share/aspell/gl.multi
+share/aspell/gl.rws
+share/aspell/gl_phonet.dat
diff --git a/textproc/aspell/pkg-plist.hr b/textproc/aspell/pkg-plist.hr
new file mode 100644
index 000000000000..93619bc4aaa0
--- /dev/null
+++ b/textproc/aspell/pkg-plist.hr
@@ -0,0 +1,4 @@
+share/aspell/hr.dat
+share/aspell/hr.multi
+share/aspell/hr.rws
+share/aspell/croation.alias
diff --git a/textproc/aspell/pkg-plist.id b/textproc/aspell/pkg-plist.id
new file mode 100644
index 000000000000..ad16eef729e2
--- /dev/null
+++ b/textproc/aspell/pkg-plist.id
@@ -0,0 +1,4 @@
+share/aspell/id.dat
+share/aspell/id.multi
+share/aspell/id.rws
+share/aspell/indonesian.alias
diff --git a/textproc/aspell/pkg-plist.is b/textproc/aspell/pkg-plist.is
new file mode 100644
index 000000000000..584de44feb7b
--- /dev/null
+++ b/textproc/aspell/pkg-plist.is
@@ -0,0 +1,6 @@
+share/aspell/icelandic.alias
+share/aspell/is.dat
+share/aspell/is.multi
+share/aspell/is.rws
+share/aspell/is_phonet.dat
+share/aspell/íslenska.alias
diff --git a/textproc/aspell/pkg-plist.it b/textproc/aspell/pkg-plist.it
index 6b9f49f26a48..a962fe5f827f 100644
--- a/textproc/aspell/pkg-plist.it
+++ b/textproc/aspell/pkg-plist.it
@@ -2,3 +2,4 @@ share/aspell/it.dat
share/aspell/it.multi
share/aspell/it.rws
share/aspell/italian.alias
+share/aspell/italiano.alias
diff --git a/textproc/aspell/pkg-plist.mi b/textproc/aspell/pkg-plist.mi
new file mode 100644
index 000000000000..a5ef4362db65
--- /dev/null
+++ b/textproc/aspell/pkg-plist.mi
@@ -0,0 +1,4 @@
+share/aspell/maori.alias
+share/aspell/mi.dat
+share/aspell/mi.multi
+share/aspell/mi.rws
diff --git a/textproc/aspell/pkg-plist.ms b/textproc/aspell/pkg-plist.ms
new file mode 100644
index 000000000000..e8ff9f38362f
--- /dev/null
+++ b/textproc/aspell/pkg-plist.ms
@@ -0,0 +1,4 @@
+share/aspell/malay.alias
+share/aspell/ms.dat
+share/aspell/ms.multi
+share/aspell/ms.rws
diff --git a/textproc/aspell/pkg-plist.sk b/textproc/aspell/pkg-plist.sk
index 066195a4dfea..e76edcb5830d 100644
--- a/textproc/aspell/pkg-plist.sk
+++ b/textproc/aspell/pkg-plist.sk
@@ -1,4 +1,7 @@
share/aspell/sk.dat
share/aspell/sk.multi
share/aspell/sk.rws
+share/aspell/sk-extend.multi
+share/aspell/sk-extend.rws
+share/aspell/slovak-extend.alias
share/aspell/slovak.alias
diff --git a/textproc/aspell/pkg-plist.sl b/textproc/aspell/pkg-plist.sl
new file mode 100644
index 000000000000..cb0c50e4eb53
--- /dev/null
+++ b/textproc/aspell/pkg-plist.sl
@@ -0,0 +1,4 @@
+share/aspell/sl.dat
+share/aspell/sl.multi
+share/aspell/sl.rws
+share/aspell/slovenian.alias