aboutsummaryrefslogtreecommitdiff
path: root/textproc/augeas/files
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-02-12 13:17:44 +0000
committerSteve Wills <swills@FreeBSD.org>2012-02-12 13:17:44 +0000
commit059d9e976d2a230b51eafb3b7e10f2f91a1c147b (patch)
tree294ba1e687895dde63818318fb058da486d90617 /textproc/augeas/files
parentfee6eeef9fcd3d3412d7021123724b77437c1e5f (diff)
Notes
Diffstat (limited to 'textproc/augeas/files')
-rw-r--r--textproc/augeas/files/patch-021ea39f8e13
-rw-r--r--textproc/augeas/files/patch-configure.ac4
-rw-r--r--textproc/augeas/files/patch-src-augrun.c19
-rw-r--r--textproc/augeas/files/patch-tests-cutest.c10
4 files changed, 44 insertions, 2 deletions
diff --git a/textproc/augeas/files/patch-021ea39f8e b/textproc/augeas/files/patch-021ea39f8e
new file mode 100644
index 000000000000..86df8f12c5da
--- /dev/null
+++ b/textproc/augeas/files/patch-021ea39f8e
@@ -0,0 +1,13 @@
+diff --git a/src/regexp.c b/src/regexp.c
+index cf0ea5d..811087d 100644
+--- src/regexp.c
++++ src/regexp.c
+@@ -50,7 +50,7 @@
+ ret = fa_restrict_alphabet(r->pattern->str, strlen(r->pattern->str),
+ &nre, &nre_len, 2, 1);
+ if (ret == 0) {
+- pat = escape(nre, nre_len);
++ pat = escape(nre, nre_len, RX_ESCAPES);
+ free(nre);
+ }
+ #endif
diff --git a/textproc/augeas/files/patch-configure.ac b/textproc/augeas/files/patch-configure.ac
index bdc379d6e405..9c416554c065 100644
--- a/textproc/augeas/files/patch-configure.ac
+++ b/textproc/augeas/files/patch-configure.ac
@@ -1,5 +1,5 @@
---- configure.ac.orig 2010-04-28 13:15:44.000000000 -0700
-+++ configure.ac 2010-04-28 13:16:07.000000000 -0700
+--- ./configure.ac.orig 2011-12-02 14:48:40.000000000 -0500
++++ ./configure.ac 2012-02-11 04:24:40.222339225 -0500
@@ -2,8 +2,7 @@
AC_CONFIG_SRCDIR([src/augeas.c])
AC_CONFIG_AUX_DIR([build/aux])
diff --git a/textproc/augeas/files/patch-src-augrun.c b/textproc/augeas/files/patch-src-augrun.c
new file mode 100644
index 000000000000..26e4193e5927
--- /dev/null
+++ b/textproc/augeas/files/patch-src-augrun.c
@@ -0,0 +1,19 @@
+--- ./src/augrun.c.orig 2012-02-11 04:26:33.948339055 -0500
++++ ./src/augrun.c 2012-02-11 04:29:28.090339060 -0500
+@@ -988,6 +988,16 @@
+ &cmd_def_last
+ };
+
++char *strchrnul(const char *s, int c) {
++ char *i;
++ for (i = (char*)s; *i != '\0'; ++i) {
++ if (*i == c) {
++ return i;
++ }
++ }
++ return i;
++}
++
+ int aug_srun(augeas *aug, FILE *out, const char *text) {
+ char *line = NULL;
+ const char *eol;
diff --git a/textproc/augeas/files/patch-tests-cutest.c b/textproc/augeas/files/patch-tests-cutest.c
new file mode 100644
index 000000000000..f843c25f7b9b
--- /dev/null
+++ b/textproc/augeas/files/patch-tests-cutest.c
@@ -0,0 +1,10 @@
+--- tests/cutest.c.orig 2012-02-11 05:08:50.706340443 -0500
++++ tests/cutest.c 2012-02-11 05:09:03.816423151 -0500
+@@ -34,6 +34,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <math.h>
++#include <sys/wait.h>
+
+ #include "cutest.h"
+ #include "memory.h"