aboutsummaryrefslogtreecommitdiff
path: root/textproc/bbe
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-11-09 01:43:48 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-11-09 01:43:48 +0000
commit6f3b0763961863eba3c08b9575f165cfa90691a3 (patch)
treefdc47cc8012520b17b7127991f1a3d3e7f5b20d1 /textproc/bbe
parent4f0871bce1188cd4fe9cd6209fc6f815479604f8 (diff)
downloadports-6f3b0763961863eba3c08b9575f165cfa90691a3.tar.gz
ports-6f3b0763961863eba3c08b9575f165cfa90691a3.zip
Notes
Diffstat (limited to 'textproc/bbe')
-rw-r--r--textproc/bbe/Makefile35
-rw-r--r--textproc/bbe/distinfo3
-rw-r--r--textproc/bbe/pkg-descr14
3 files changed, 52 insertions, 0 deletions
diff --git a/textproc/bbe/Makefile b/textproc/bbe/Makefile
new file mode 100644
index 000000000000..3d580d3a2faf
--- /dev/null
+++ b/textproc/bbe/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: bbe
+# Date created: 8 November 2006
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bbe
+PORTVERSION= 0.2.2
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=${PORTNAME}-
+
+MAINTAINER= ports@logvinov.com
+COMMENT= A sed-like editor for binary files
+
+HAS_CONFIGURE= yes
+
+MAN1= ${PORTNAME}.1
+PLIST_FILES= bin/${PORTNAME}
+DOCS= AUTHORS ChangeLog README
+PORTDOCS= bbe.html ${DOCS}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doc/${MAN1} ${MAN1PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/bbe.html ${DOCSDIR}
+.for i in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/bbe/distinfo b/textproc/bbe/distinfo
new file mode 100644
index 000000000000..07ba913cdbd1
--- /dev/null
+++ b/textproc/bbe/distinfo
@@ -0,0 +1,3 @@
+MD5 (bbe-0.2.2.tar.gz) = b056d0bfd852384aced73d4533887d4b
+SHA256 (bbe-0.2.2.tar.gz) = baaeaf5775a6d9bceb594ea100c8f45a677a0a7d07529fa573ba0842226edddb
+SIZE (bbe-0.2.2.tar.gz) = 211590
diff --git a/textproc/bbe/pkg-descr b/textproc/bbe/pkg-descr
new file mode 100644
index 000000000000..4018a70dea47
--- /dev/null
+++ b/textproc/bbe/pkg-descr
@@ -0,0 +1,14 @@
+Instead of reading input in lines as sed, bbe reads
+arbitrary blocks from an input stream and performs
+byte-related transformations on found blocks. Blocks
+can be defined using start/stop strings, stream offset
+and block length, or a combination. Basic editing commands
+include delete, replace, search/replace, binary operations
+(and, or, etc.), append, and bcd/ASCII conversion. For
+examining the input stream, it contains some grep-like
+features like printing the input file name, stream offset,
+and block number of found blocks. Block contents can also
+be printed in different formats like hex, octal, ASCII, and
+binary.
+
+WWW: http://sourceforge.net/projects/bbe-/