aboutsummaryrefslogtreecommitdiff
path: root/textproc/bib2html/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-09-11 05:27:00 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-09-11 05:27:00 +0000
commit2464d65d507562b50c16c195fef087bcbb2aa449 (patch)
tree7ec2fd61b8a5b2c89beba8f33f524000daa64ae4 /textproc/bib2html/Makefile
parent007b2d675540953bfd3f5964c954e473d7fbde45 (diff)
downloadports-2464d65d507562b50c16c195fef087bcbb2aa449.tar.gz
ports-2464d65d507562b50c16c195fef087bcbb2aa449.zip
Notes
Diffstat (limited to 'textproc/bib2html/Makefile')
-rw-r--r--textproc/bib2html/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/textproc/bib2html/Makefile b/textproc/bib2html/Makefile
index 9c18c3e4440b..182ae8aa0428 100644
--- a/textproc/bib2html/Makefile
+++ b/textproc/bib2html/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= bib2html
-DISTVERSION= 4.3-1
+DISTVERSION= 5.0-1
CATEGORIES= textproc print
MASTER_SITES= http://www.arakhne.org/IMG/gz/ \
http://fresh.t-systems-sfr.com/fresh/unix/src/privat2/
@@ -16,16 +16,16 @@ DISTNAME= ${PORTNAME}_${DISTVERSION}
MAINTAINER= clsung@FreeBSD.org
COMMENT= The BibTeX to HTML Translator
-WRKSRC= ${WRKDIR}/${PORTNAME}-4.3/src
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/-[0-9]$//}/src
USE_PERL5_RUN= yes
NO_BUILD= yes
post-patch:
- @${REINPLACE_CMD} -e \
+ @${SED} -e \
's:= "$$0";:= "${TARGETDIR}/${SITE_PERL_REL}/Bib2HTML";:g' \
< ${WRKSRC}/bib2html.pl > ${WRKSRC}/bib2html
- @${REINPLACE_CMD} -e \
+ @${SED} -e \
's:= "$$0";:= "${TARGETDIR}/${SITE_PERL_REL}/Bib2HTML";:g' \
< ${WRKSRC}/bib2xml.pl > ${WRKSRC}/bib2xml
@@ -40,5 +40,9 @@ do-install:
${XARGS} ${CHMOD} ${LIBMODE}
${FIND} ${TARGETDIR}/${SITE_PERL_REL}/Bib2HTML -type d | \
${XARGS} ${CHMOD} a+rx
+ @${FIND} ${TARGETDIR}/${SITE_PERL_REL}/Bib2HTML -type f | \
+ ${SED} "s,^${TARGETDIR}/,," >> ${TMPPLIST}
+ @${FIND} ${TARGETDIR}/${SITE_PERL_REL}/Bib2HTML -type d | ${SORT} -r | \
+ ${SED} "s,^${TARGETDIR}/,@dirrm ," >> ${TMPPLIST}
.include <bsd.port.mk>