aboutsummaryrefslogtreecommitdiff
path: root/textproc/bib2html/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-13 01:39:47 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-13 01:39:47 +0000
commit435db006df4a48e3447d13ecabb45198a869edbe (patch)
tree6d4c5c015ed582c38587510e7b7cd7110af53418 /textproc/bib2html/Makefile
parentae1865e2dbf43ffd39f17bfca3ceb74cd90eed72 (diff)
downloadports-435db006df4a48e3447d13ecabb45198a869edbe.tar.gz
ports-435db006df4a48e3447d13ecabb45198a869edbe.zip
Notes
Diffstat (limited to 'textproc/bib2html/Makefile')
-rw-r--r--textproc/bib2html/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/textproc/bib2html/Makefile b/textproc/bib2html/Makefile
new file mode 100644
index 000000000000..db6f4068fb11
--- /dev/null
+++ b/textproc/bib2html/Makefile
@@ -0,0 +1,36 @@
+# ex:ts=8
+# Ports collection makefile for: bib2html
+# Date created: Jan 5, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= bib2html
+PORTVERSION= 0.10
+CATEGORIES= textproc print
+MASTER_SITES= http://www.arakhne.org/mirrors/ \
+ http://fresh.t-systems-sfr.com/unix/src/privat2/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= The BibTeX to HTML Translator
+
+USE_REINPLACE= yes
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+
+PLIST_FILES= bin/bib2html
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%SITE_PERL%%|${SITE_PERL}|" ${WRKSRC}/bib2html.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bib2html.pl ${PREFIX}/bin/bib2html
+ ${CP} -R ${WRKSRC}/Bib2HTML ${SITE_PERL}
+ @${FIND} ${SITE_PERL}/Bib2HTML -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${SITE_PERL}/Bib2HTML -type d | ${SORT} -r | \
+ ${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+
+.include <bsd.port.mk>