aboutsummaryrefslogtreecommitdiff
path: root/textproc/bib2html
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-13 01:39:47 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-13 01:39:47 +0000
commit435db006df4a48e3447d13ecabb45198a869edbe (patch)
tree6d4c5c015ed582c38587510e7b7cd7110af53418 /textproc/bib2html
parentae1865e2dbf43ffd39f17bfca3ceb74cd90eed72 (diff)
downloadports-435db006df4a48e3447d13ecabb45198a869edbe.tar.gz
ports-435db006df4a48e3447d13ecabb45198a869edbe.zip
Notes
Diffstat (limited to 'textproc/bib2html')
-rw-r--r--textproc/bib2html/Makefile36
-rw-r--r--textproc/bib2html/distinfo2
-rw-r--r--textproc/bib2html/files/patch-BibScanner.pm11
-rw-r--r--textproc/bib2html/files/patch-bib2html.pl11
-rw-r--r--textproc/bib2html/pkg-descr4
5 files changed, 64 insertions, 0 deletions
diff --git a/textproc/bib2html/Makefile b/textproc/bib2html/Makefile
new file mode 100644
index 000000000000..db6f4068fb11
--- /dev/null
+++ b/textproc/bib2html/Makefile
@@ -0,0 +1,36 @@
+# ex:ts=8
+# Ports collection makefile for: bib2html
+# Date created: Jan 5, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= bib2html
+PORTVERSION= 0.10
+CATEGORIES= textproc print
+MASTER_SITES= http://www.arakhne.org/mirrors/ \
+ http://fresh.t-systems-sfr.com/unix/src/privat2/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= The BibTeX to HTML Translator
+
+USE_REINPLACE= yes
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+
+PLIST_FILES= bin/bib2html
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%SITE_PERL%%|${SITE_PERL}|" ${WRKSRC}/bib2html.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/bib2html.pl ${PREFIX}/bin/bib2html
+ ${CP} -R ${WRKSRC}/Bib2HTML ${SITE_PERL}
+ @${FIND} ${SITE_PERL}/Bib2HTML -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${SITE_PERL}/Bib2HTML -type d | ${SORT} -r | \
+ ${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/textproc/bib2html/distinfo b/textproc/bib2html/distinfo
new file mode 100644
index 000000000000..fd9d1cca4b5f
--- /dev/null
+++ b/textproc/bib2html/distinfo
@@ -0,0 +1,2 @@
+MD5 (bib2html-0.10.tar.gz) = bd41bee1136d95f346e9297fd9dbb8cb
+SIZE (bib2html-0.10.tar.gz) = 77665
diff --git a/textproc/bib2html/files/patch-BibScanner.pm b/textproc/bib2html/files/patch-BibScanner.pm
new file mode 100644
index 000000000000..54112d4161e9
--- /dev/null
+++ b/textproc/bib2html/files/patch-BibScanner.pm
@@ -0,0 +1,11 @@
+--- Bib2HTML/Parser/BibScanner.pm.orig Fri Feb 13 09:23:42 2004
++++ Bib2HTML/Parser/BibScanner.pm Fri Feb 13 09:23:59 2004
+@@ -327,7 +327,7 @@
+
+ sub transition_callback_entry_fields_main($) {
+ my $self = shift ;
+- $self->addentry $self->{'BUFFER'}{'currententry'}{'key'},
++ $self->addentry( $self->{'BUFFER'}{'currententry'}{'key'},
+ $self->{'BUFFER'}{'currententry'}{'type'},
+ $self->{'BUFFER'}{'currententry'}{'fields'},
+ $self->{'BUFFER'}{'currententry'}{'lineno'} ) ;
diff --git a/textproc/bib2html/files/patch-bib2html.pl b/textproc/bib2html/files/patch-bib2html.pl
new file mode 100644
index 000000000000..6d8bf5aecdbf
--- /dev/null
+++ b/textproc/bib2html/files/patch-bib2html.pl
@@ -0,0 +1,11 @@
+--- bib2html.pl.orig Tue Jan 13 09:00:38 2004
++++ bib2html.pl Tue Jan 13 09:01:05 2004
+@@ -33,7 +33,7 @@
+ my $PERLSCRIPTDIR ;
+ BEGIN{
+ # Where is this script?
+- $PERLSCRIPTDIR = "$0";
++ $PERLSCRIPTDIR = "%%SITE_PERL%%/Bib2HTML";
+ my $scriptdir = dirname( $PERLSCRIPTDIR );
+ while ( -e $PERLSCRIPTDIR && -l $PERLSCRIPTDIR ) {
+ $PERLSCRIPTDIR = readlink($PERLSCRIPTDIR);
diff --git a/textproc/bib2html/pkg-descr b/textproc/bib2html/pkg-descr
new file mode 100644
index 000000000000..ae2cd9517892
--- /dev/null
+++ b/textproc/bib2html/pkg-descr
@@ -0,0 +1,4 @@
+bib2html is a script which permits to generate a set of HTML pages from a
+BibTeX database.
+
+WWW: http://www.arakhne.org/tools/bib2html/