aboutsummaryrefslogtreecommitdiff
path: root/textproc/bibtool/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2005-11-04 05:40:12 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2005-11-04 05:40:12 +0000
commit69ddbe18a48a431d41928e51a3192ba4be1459fb (patch)
tree5e5a7d63abc55341bd76d1e4a878b0df00134e98 /textproc/bibtool/Makefile
parent8441d0fd82e6e61467d28afd805c11207d0820ce (diff)
downloadports-69ddbe18a48a431d41928e51a3192ba4be1459fb.tar.gz
ports-69ddbe18a48a431d41928e51a3192ba4be1459fb.zip
Notes
Diffstat (limited to 'textproc/bibtool/Makefile')
-rw-r--r--textproc/bibtool/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/textproc/bibtool/Makefile b/textproc/bibtool/Makefile
new file mode 100644
index 000000000000..fcb02c141926
--- /dev/null
+++ b/textproc/bibtool/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: bibtool
+# Date created: Oct 10, 2005
+# Whom: Rong-En Fan <rafan@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bibtool
+PORTVERSION= 2.48
+CATEGORIES= textproc print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= biblio/bibtex/utils/${PORTNAME}
+DISTNAME= BibTool-${PORTVERSION}
+
+MAINTAINER= rafan@infor.org
+COMMENT= Command line manipulation of BibTeX files
+
+BUILD_DEPENDS= ${LOCALBASE}/include/kpathsea/tex-file.h:${PORTSDIR}/print/teTeX-base
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-kpathsea
+CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
+
+MAKEFILE= makefile
+INSTALL_TARGET= install install.man
+
+MAN1= bibtool.1
+
+TXT_DOCS= Doc/bibtool.dvi Doc/ref_card.dvi Doc/c_lib.dvi
+.if !defined(NOPORTDOCS)
+PORTDOCS= ${TXT_DOCS:S/^Doc\///}
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${MAKE} doc && ${MAKE} doc
+ ${MKDIR} ${DOCSDIR}
+ for f in ${TXT_DOCS}; do \
+ ${INSTALL_MAN} ${WRKSRC}/$$f ${DOCSDIR}; \
+ done
+.endif
+
+.include <bsd.port.post.mk>