aboutsummaryrefslogtreecommitdiff
path: root/textproc/bibtool
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2005-11-04 05:40:12 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2005-11-04 05:40:12 +0000
commit69ddbe18a48a431d41928e51a3192ba4be1459fb (patch)
tree5e5a7d63abc55341bd76d1e4a878b0df00134e98 /textproc/bibtool
parent8441d0fd82e6e61467d28afd805c11207d0820ce (diff)
downloadports-69ddbe18a48a431d41928e51a3192ba4be1459fb.tar.gz
ports-69ddbe18a48a431d41928e51a3192ba4be1459fb.zip
Notes
Diffstat (limited to 'textproc/bibtool')
-rw-r--r--textproc/bibtool/Makefile45
-rw-r--r--textproc/bibtool/distinfo2
-rw-r--r--textproc/bibtool/files/patch-configure20
-rw-r--r--textproc/bibtool/files/patch-main.c20
-rw-r--r--textproc/bibtool/files/patch-makefile.in29
-rw-r--r--textproc/bibtool/pkg-descr17
-rw-r--r--textproc/bibtool/pkg-plist12
7 files changed, 145 insertions, 0 deletions
diff --git a/textproc/bibtool/Makefile b/textproc/bibtool/Makefile
new file mode 100644
index 000000000000..fcb02c141926
--- /dev/null
+++ b/textproc/bibtool/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: bibtool
+# Date created: Oct 10, 2005
+# Whom: Rong-En Fan <rafan@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bibtool
+PORTVERSION= 2.48
+CATEGORIES= textproc print
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= biblio/bibtex/utils/${PORTNAME}
+DISTNAME= BibTool-${PORTVERSION}
+
+MAINTAINER= rafan@infor.org
+COMMENT= Command line manipulation of BibTeX files
+
+BUILD_DEPENDS= ${LOCALBASE}/include/kpathsea/tex-file.h:${PORTSDIR}/print/teTeX-base
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-kpathsea
+CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
+
+MAKEFILE= makefile
+INSTALL_TARGET= install install.man
+
+MAN1= bibtool.1
+
+TXT_DOCS= Doc/bibtool.dvi Doc/ref_card.dvi Doc/c_lib.dvi
+.if !defined(NOPORTDOCS)
+PORTDOCS= ${TXT_DOCS:S/^Doc\///}
+.endif
+
+.include <bsd.port.pre.mk>
+
+post-install:
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC} && ${MAKE} doc && ${MAKE} doc
+ ${MKDIR} ${DOCSDIR}
+ for f in ${TXT_DOCS}; do \
+ ${INSTALL_MAN} ${WRKSRC}/$$f ${DOCSDIR}; \
+ done
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/bibtool/distinfo b/textproc/bibtool/distinfo
new file mode 100644
index 000000000000..41329b626375
--- /dev/null
+++ b/textproc/bibtool/distinfo
@@ -0,0 +1,2 @@
+MD5 (BibTool-2.48.tar.gz) = 20ebb18ea55e5f64b67f5b8edaa0d6fa
+SIZE (BibTool-2.48.tar.gz) = 634267
diff --git a/textproc/bibtool/files/patch-configure b/textproc/bibtool/files/patch-configure
new file mode 100644
index 000000000000..72ebba9a8fa2
--- /dev/null
+++ b/textproc/bibtool/files/patch-configure
@@ -0,0 +1,20 @@
+--- configure.orig Sun Feb 8 17:35:23 2004
++++ configure Wed Nov 2 16:45:08 2005
+@@ -4566,12 +4566,12 @@
+ kpathsea_dir=
+ kpathsea_lib=
+ kpathsea_def=
+- for cand in .. ../kpse3-2 kpse3-2 .
++ for cand in ${LOCALBASE}
+ do
+- if test -f $cand/kpathsea/tex-file.h ; then
+- kpathsea_dir=$cand
+- kpathsea_lib=$cand/kpathsea/STATIC/libkpathsea.a
+- kpathsea_def="-DHAVE_LIBKPATHSEA -I$cand"
++ if test -f $cand/include/kpathsea/tex-file.h ; then
++ kpathsea_dir=$cand/include
++ kpathsea_lib=$cand/lib/libkpathsea.a
++ kpathsea_def="-DHAVE_LIBKPATHSEA -I$cand/include"
+ fi
+ done
+ if test -z "$kpathsea_dir"; then
diff --git a/textproc/bibtool/files/patch-main.c b/textproc/bibtool/files/patch-main.c
new file mode 100644
index 000000000000..1b974ec34fbc
--- /dev/null
+++ b/textproc/bibtool/files/patch-main.c
@@ -0,0 +1,20 @@
+--- main.c.orig Wed Nov 2 16:45:23 2005
++++ main.c Wed Nov 2 16:47:22 2005
+@@ -331,17 +331,6 @@
+
+
+ /*-----------------------------------------------------------------------------
+-** Function: true()
+-** Type: static int
+-** Purpose:
+-**
+-** Arguments:
+-**
+-** Returns:
+-**___________________________________________________ */
+-static int true() { return TRUE; }
+-
+-/*-----------------------------------------------------------------------------
+ ** Function: keep_selected()
+ ** Type: static int
+ ** Purpose:
diff --git a/textproc/bibtool/files/patch-makefile.in b/textproc/bibtool/files/patch-makefile.in
new file mode 100644
index 000000000000..9e9ac92da829
--- /dev/null
+++ b/textproc/bibtool/files/patch-makefile.in
@@ -0,0 +1,29 @@
+--- AutoConf/makefile.in.orig Sun Feb 8 17:46:11 2004
++++ AutoConf/makefile.in Wed Nov 2 17:05:33 2005
+@@ -67,7 +67,7 @@
+ # Name the C compiler
+ #
+
+-CC = @CC@
++CC ?= @CC@
+
+ # -------------------------------------------------------
+ # CFLAGS are the flags for the C compiler.
+@@ -78,7 +78,7 @@
+ # optimizer is turned on.
+ #
+
+-CFLAGS =
++CFLAGS += -DHAVE_PROTOTYPES
+ # CFLAGS = -O
+ # GNU C
+ # CFLAGS = -g -Wall
+@@ -461,7 +461,7 @@
+ # Targets from the GNU Regular Expression Library.
+
+ regex$(OBJ): $(REGEX_DIR)$(DIR_SEP)regex.c $(MAKEFILE)
+- $(CC) $(C_FLAGS) -I$(REGEX_DIR) -I.. $(NON_ANSI_DEFS) $(REGEX_DIR)$(DIR_SEP)regex.c $(DONT_LINK) -o $@
++ $(CC) $(C_FLAGS) -DSTDC_HEADERS -I$(REGEX_DIR) -I.. $(NON_ANSI_DEFS) $(REGEX_DIR)$(DIR_SEP)regex.c $(DONT_LINK) -o $@
+
+
+ bibtcl:
diff --git a/textproc/bibtool/pkg-descr b/textproc/bibtool/pkg-descr
new file mode 100644
index 000000000000..f2b440ac3b20
--- /dev/null
+++ b/textproc/bibtool/pkg-descr
@@ -0,0 +1,17 @@
+Command line manipulation of BibTeX files:
+
+* Pretty-printing data bases
+* Syntactic checks with error recovery
+* Semantic checks
+* Sorting and merging of data bases
+* Generation of uniform reference keys according to predefined rules or
+ according to user specification
+* Selecting references used in one publication which are found by
+ analyzing an aux file
+* Controlled rewriting of fields utilising regular expressions to specify
+ the rewriting rules
+* Macro (String) expansion to eliminate the need of extra string
+ definitions
+* Collecting statistics about one or more data bases
+
+WWW: http://www.ctan.org/tex-archive/biblio/bibtex/utils/bibtool/
diff --git a/textproc/bibtool/pkg-plist b/textproc/bibtool/pkg-plist
new file mode 100644
index 000000000000..50a19a9a9297
--- /dev/null
+++ b/textproc/bibtool/pkg-plist
@@ -0,0 +1,12 @@
+bin/bibtool
+lib/BibTool/braces.rsc
+lib/BibTool/check_y.rsc
+lib/BibTool/default.rsc
+lib/BibTool/field.rsc
+lib/BibTool/improve.rsc
+lib/BibTool/iso2tex.rsc
+lib/BibTool/month.rsc
+lib/BibTool/opt.rsc
+lib/BibTool/sort_fld.rsc
+lib/BibTool/tex_def.rsc
+@dirrm lib/BibTool