aboutsummaryrefslogtreecommitdiff
path: root/textproc/bibutils
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-05-15 15:24:06 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-05-15 15:24:06 +0000
commit09f4731167d69923f3026827a29fd603242a2aa3 (patch)
tree2a46d7a67f3953795f6699e6de89f286e85c25e6 /textproc/bibutils
parent6d53c3da656609893448aacaa5657330110e9815 (diff)
downloadports-09f4731167d69923f3026827a29fd603242a2aa3.tar.gz
ports-09f4731167d69923f3026827a29fd603242a2aa3.zip
Notes
Diffstat (limited to 'textproc/bibutils')
-rw-r--r--textproc/bibutils/Makefile32
-rw-r--r--textproc/bibutils/distinfo3
-rw-r--r--textproc/bibutils/files/patch-Makefile_start10
-rw-r--r--textproc/bibutils/pkg-descr8
-rw-r--r--textproc/bibutils/pkg-plist19
5 files changed, 72 insertions, 0 deletions
diff --git a/textproc/bibutils/Makefile b/textproc/bibutils/Makefile
new file mode 100644
index 000000000000..754605adc610
--- /dev/null
+++ b/textproc/bibutils/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: bibutils
+# Date created: May 14, 2010
+# Whom: Gabor Pali <pgj@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bibutils
+PORTVERSION= 4.9
+CATEGORIES= textproc
+MASTER_SITES= http://www.scripps.edu/~cdputnam/software/bibutils/
+DISTNAME= ${PORTNAME}_${PORTVERSION}_src
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= pgj@FreeBSD.org
+COMMENT= Program set interconverts between various bibliography formats
+
+USE_GMAKE= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
+
+post-patch:
+ @${REINPLACE_CMD} 's|make |gmake |g' \
+ ${WRKSRC}/Makefile_start
+
+do-configure:
+ @cd ${WRKSRC} && ./configure --install-dir ${PREFIX}/bin
+
+test: all
+ cd ${WRKSRC}/test && ${GMAKE} all test
+
+.include <bsd.port.mk>
diff --git a/textproc/bibutils/distinfo b/textproc/bibutils/distinfo
new file mode 100644
index 000000000000..6ab87ffd149b
--- /dev/null
+++ b/textproc/bibutils/distinfo
@@ -0,0 +1,3 @@
+MD5 (bibutils_4.9_src.tgz) = 1cc0724b821ae9749b91a267207105dc
+SHA256 (bibutils_4.9_src.tgz) = 86914a11330f7b4bf196bc44028b14fddbce8cd0058bd6c1bb1cfce7bb0b8287
+SIZE (bibutils_4.9_src.tgz) = 513810
diff --git a/textproc/bibutils/files/patch-Makefile_start b/textproc/bibutils/files/patch-Makefile_start
new file mode 100644
index 000000000000..b4f57b976a78
--- /dev/null
+++ b/textproc/bibutils/files/patch-Makefile_start
@@ -0,0 +1,10 @@
+--- ./Makefile_start.orig 2010-04-08 18:31:00.000000000 +0200
++++ ./Makefile_start 2010-05-15 00:21:58.000000000 +0200
+@@ -34,6 +34,7 @@
+ @for p in ${PROGRAMS}; \
+ do ( cp bin/$$p ${INSTALLDIR}/$$p ); \
+ done
++ cp lib/libbibutils.a ${INSTALLDIR}/../lib
+
+ package: all FORCE
+ csh -f maketgz.csh ${VERSION} ${POSTFIX}
diff --git a/textproc/bibutils/pkg-descr b/textproc/bibutils/pkg-descr
new file mode 100644
index 000000000000..7aa3e4f84efd
--- /dev/null
+++ b/textproc/bibutils/pkg-descr
@@ -0,0 +1,8 @@
+The bibutils program set interconverts between various bibliography
+formats using a common MODS-format XML intermediate. For example, one
+can convert RIS-format files to Bibtex by doing two transformations:
+RIS->MODS->Bibtex. By using a common intermediate for N formats, only 2N
+programs are required and not N^2-N. These programs operate on the
+command line and are styled after standard UNIX-like filters.
+
+WWW: http://www.scripps.edu/~cdputnam/software/bibutils/
diff --git a/textproc/bibutils/pkg-plist b/textproc/bibutils/pkg-plist
new file mode 100644
index 000000000000..3813820ebbd6
--- /dev/null
+++ b/textproc/bibutils/pkg-plist
@@ -0,0 +1,19 @@
+@comment $FreeBSD$
+bin/bib2xml
+bin/biblatex2xml
+bin/copac2xml
+bin/ebi2xml
+bin/end2xml
+bin/endx2xml
+bin/isi2xml
+bin/med2xml
+bin/modsclean
+bin/ris2xml
+bin/wordbib2xml
+bin/xml2ads
+bin/xml2bib
+bin/xml2end
+bin/xml2isi
+bin/xml2ris
+bin/xml2wordbib
+lib/libbibutils.a