aboutsummaryrefslogtreecommitdiff
path: root/textproc/bomstrip/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2008-06-14 11:06:20 +0000
committerPeter Pentchev <roam@FreeBSD.org>2008-06-14 11:06:20 +0000
commitf05c384708acb6f206f4bc1827b82561f5cb35ad (patch)
treed08e25c5da48f33a1b44af8473558df9fa09f146 /textproc/bomstrip/Makefile
parent51ed9406653b10fab8d645a3faca824e6522c28d (diff)
Notes
Diffstat (limited to 'textproc/bomstrip/Makefile')
-rw-r--r--textproc/bomstrip/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/textproc/bomstrip/Makefile b/textproc/bomstrip/Makefile
new file mode 100644
index 000000000000..559d451fa577
--- /dev/null
+++ b/textproc/bomstrip/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: bomstrip
+# Date created: 14 June 2008
+# Whom: Peter Pentchev <roam@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bomstrip
+PORTVERSION= 8
+CATEGORIES= textproc
+MASTER_SITES= http://www.xs4all.nl/~mechiel/projects/bomstrip/files/:main \
+ http://devel.ringlet.net/textproc/bomstrip/:ringlet
+DISTFILES= ${DISTNAME}.tgz:main,ringlet \
+ ${DISTNAME}-roam-03-extra-files.tar.gz:ringlet
+
+PATCHFILES= ${DISTNAME}-roam-03.patch
+PATCH_SITES= http://devel.ringlet.net/textproc/bomstrip/
+
+MAINTAINER= roam@FreeBSD.org
+COMMENT= Strip Byte-Order Marks (BOM) from UTF-8 text
+
+USE_GMAKE= yes
+MAKE_ENV+= BINGRP="${BINGRP}"
+
+MAN1= bomstrip.1 bomstrip-files.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>