aboutsummaryrefslogtreecommitdiff
path: root/textproc/bomstrip
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2008-06-14 11:06:20 +0000
committerPeter Pentchev <roam@FreeBSD.org>2008-06-14 11:06:20 +0000
commitf05c384708acb6f206f4bc1827b82561f5cb35ad (patch)
treed08e25c5da48f33a1b44af8473558df9fa09f146 /textproc/bomstrip
parent51ed9406653b10fab8d645a3faca824e6522c28d (diff)
downloadports-f05c384708acb6f206f4bc1827b82561f5cb35ad.tar.gz
ports-f05c384708acb6f206f4bc1827b82561f5cb35ad.zip
Notes
Diffstat (limited to 'textproc/bomstrip')
-rw-r--r--textproc/bomstrip/Makefile28
-rw-r--r--textproc/bomstrip/distinfo9
-rw-r--r--textproc/bomstrip/pkg-descr20
-rw-r--r--textproc/bomstrip/pkg-plist49
4 files changed, 106 insertions, 0 deletions
diff --git a/textproc/bomstrip/Makefile b/textproc/bomstrip/Makefile
new file mode 100644
index 000000000000..559d451fa577
--- /dev/null
+++ b/textproc/bomstrip/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: bomstrip
+# Date created: 14 June 2008
+# Whom: Peter Pentchev <roam@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bomstrip
+PORTVERSION= 8
+CATEGORIES= textproc
+MASTER_SITES= http://www.xs4all.nl/~mechiel/projects/bomstrip/files/:main \
+ http://devel.ringlet.net/textproc/bomstrip/:ringlet
+DISTFILES= ${DISTNAME}.tgz:main,ringlet \
+ ${DISTNAME}-roam-03-extra-files.tar.gz:ringlet
+
+PATCHFILES= ${DISTNAME}-roam-03.patch
+PATCH_SITES= http://devel.ringlet.net/textproc/bomstrip/
+
+MAINTAINER= roam@FreeBSD.org
+COMMENT= Strip Byte-Order Marks (BOM) from UTF-8 text
+
+USE_GMAKE= yes
+MAKE_ENV+= BINGRP="${BINGRP}"
+
+MAN1= bomstrip.1 bomstrip-files.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/bomstrip/distinfo b/textproc/bomstrip/distinfo
new file mode 100644
index 000000000000..025250e1cdb6
--- /dev/null
+++ b/textproc/bomstrip/distinfo
@@ -0,0 +1,9 @@
+MD5 (bomstrip-8.tgz) = d70b1cbeab5104b6700be6d1b000ba6d
+SHA256 (bomstrip-8.tgz) = 2810e1602530e9554c33b4ef06d8828c7066ae2e30f469dce377d1c76e1668a8
+SIZE (bomstrip-8.tgz) = 6101
+MD5 (bomstrip-8-roam-03-extra-files.tar.gz) = 05eab1708560a00dea0b3066dac80786
+SHA256 (bomstrip-8-roam-03-extra-files.tar.gz) = 22f0dcdf3bedbbd50ef999e0107eefbb72a4ff26379ba82c868cf0d07baf65a1
+SIZE (bomstrip-8-roam-03-extra-files.tar.gz) = 480
+MD5 (bomstrip-8-roam-03.patch) = da3e21c5225dffd4bd8a74b423524d1e
+SHA256 (bomstrip-8-roam-03.patch) = 2392486b36c6ea9402b27e95c1c87d7ab7723c023b0ce603a43cacdfa37ae987
+SIZE (bomstrip-8-roam-03.patch) = 13141
diff --git a/textproc/bomstrip/pkg-descr b/textproc/bomstrip/pkg-descr
new file mode 100644
index 000000000000..7c5e35aa2ee2
--- /dev/null
+++ b/textproc/bomstrip/pkg-descr
@@ -0,0 +1,20 @@
+Bomstrip is a very simple tool that removes BOM's (byte-order-marks)
+from utf-8 files. Actually, it is a set of tools that all do the same
+thing, but - for added entertainment value - in multiple programming
+languages (python, c, java, brainfuck, ook!, perl, sed, postscript,
+pascal, unlambda, limbo, haskell, ocaml, php, ruby). You want to always
+have this tool within hand-reach, no matter where you are and which
+compilers/interpreters you keep close to you.
+
+Each tool reads from stdin and writes to stdout. It accepts no options
+or arguments. It never writes into files directly. All files are public
+domain. It exists for the purpose of noting how stupid BOM's in utf-8
+files are.
+
+Oh, in case you didn't know yet: utf-8 does not have byte-ordering
+issues, so there is absolutely no need to have three bytes (the
+utf-8-BOM) that do not say anything about the byte-order (since there
+is nothing to say).
+
+Author: Mechiel Lukkien <mechiel@xs4all.nl>
+WWW: http://www.xs4all.nl/~mechiel/projects/bomstrip/
diff --git a/textproc/bomstrip/pkg-plist b/textproc/bomstrip/pkg-plist
new file mode 100644
index 000000000000..958ebad59473
--- /dev/null
+++ b/textproc/bomstrip/pkg-plist
@@ -0,0 +1,49 @@
+bin/bomstrip
+bin/bomstrip-files
+%%DATADIR%%/source/bomstrip.awk
+%%DATADIR%%/source/bomstrip.b
+%%DATADIR%%/source/bomstrip.bf
+%%DATADIR%%/source/bomstrip.c
+%%DATADIR%%/source/bomstrip.cpp
+%%DATADIR%%/source/bomstrip.hs
+%%DATADIR%%/source/bomstrip.ocaml
+%%DATADIR%%/source/bomstrip.ook
+%%DATADIR%%/source/bomstrip.pas
+%%DATADIR%%/source/bomstrip.php
+%%DATADIR%%/source/bomstrip.pl
+%%DATADIR%%/source/bomstrip-2.pl
+%%DATADIR%%/source/bomstrip.ps
+%%DATADIR%%/source/bomstrip.py
+%%DATADIR%%/source/bomstrip.rb
+%%DATADIR%%/source/bomstrip.sed
+%%DATADIR%%/source/bomstrip.unl
+%%DATADIR%%/tests/bom0
+%%DATADIR%%/tests/bom1
+%%DATADIR%%/tests/bom-ml1
+%%DATADIR%%/tests/bom-ml2
+%%DATADIR%%/tests/bom-ml3
+%%DATADIR%%/tests/bom-ml4
+%%DATADIR%%/tests/nobom0
+%%DATADIR%%/tests/nobom1
+%%DATADIR%%/tests/nobom2
+%%DATADIR%%/tests/nobom-ml1
+%%DATADIR%%/tests/nobom-ml2
+%%DATADIR%%/tests/nobom-ml3
+%%DATADIR%%/tests/nobom-ml4
+%%DATADIR%%/tests/correct/rbom0
+%%DATADIR%%/tests/correct/rbom1
+%%DATADIR%%/tests/correct/rbom-ml1
+%%DATADIR%%/tests/correct/rbom-ml2
+%%DATADIR%%/tests/correct/rbom-ml3
+%%DATADIR%%/tests/correct/rbom-ml4
+%%DATADIR%%/tests/correct/rnobom0
+%%DATADIR%%/tests/correct/rnobom1
+%%DATADIR%%/tests/correct/rnobom2
+%%DATADIR%%/tests/correct/rnobom-ml1
+%%DATADIR%%/tests/correct/rnobom-ml2
+%%DATADIR%%/tests/correct/rnobom-ml3
+%%DATADIR%%/tests/correct/rnobom-ml4
+@dirrm %%DATADIR%%/source
+@dirrm %%DATADIR%%/tests/correct
+@dirrm %%DATADIR%%/tests
+@dirrm %%DATADIR%%