aboutsummaryrefslogtreecommitdiff
path: root/textproc/bsdsort/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-11-22 19:24:06 +0000
committerJohn Marino <marino@FreeBSD.org>2014-11-22 19:24:06 +0000
commitaf9e7689c66234a1102b98d104c5899f8e17917e (patch)
tree216e8d70d5fca9b57ab433bbf6def21259fa8db0 /textproc/bsdsort/Makefile
parent7493532a0fc4ff970e2133b4f93c19a014457eaf (diff)
downloadports-af9e7689c66234a1102b98d104c5899f8e17917e.tar.gz
ports-af9e7689c66234a1102b98d104c5899f8e17917e.zip
Notes
Diffstat (limited to 'textproc/bsdsort/Makefile')
-rw-r--r--textproc/bsdsort/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/textproc/bsdsort/Makefile b/textproc/bsdsort/Makefile
index f2a8538d5324..7fbb274a503f 100644
--- a/textproc/bsdsort/Makefile
+++ b/textproc/bsdsort/Makefile
@@ -24,24 +24,21 @@ USES= uidfix
CFLAGS+= -std=c99
-OPTIONS_DEFINE= THREADS NLS OVERWRITE_BASE
-OVERWRITE_BASE_DESC= Replace base GNU sort
+PLIST_FILES= bin/sort \
+ bin/bsdsort \
+ bin/gnusort \
+ man/man1/sort.1.gz
+
+OPTIONS_DEFINE= THREADS NLS
OPTIONS_DEFAULT= THREADS NLS
OPTIONS_SUB= yes
NLS_MAKE_ENV_OFF= WITHOUT_NLS=yes
+NLS_PLIST_FILES= share/nls/hu_HU.ISO8859-2/sort.cat
THREADS_MAKE_ENV= WITH_THREADS=yes
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MOVERWRITE_BASE}
-PREFIX= /usr
-.endif
-
post-install:
- ${LN} -s ${PREFIX}/bin/sort ${STAGEDIR}${PREFIX}/bin/bsdsort
-.if empty(OVERWRITE_BASE)
+ (cd ${STAGEDIR}${PREFIX}/bin && ${LN} -s sort bsdsort)
${LN} -s /usr/bin/sort ${STAGEDIR}${PREFIX}/bin/gnusort
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>