aboutsummaryrefslogtreecommitdiff
path: root/textproc/catdoc/Makefile
diff options
context:
space:
mode:
authorJustin M. Seger <jseger@FreeBSD.org>1998-12-22 03:03:32 +0000
committerJustin M. Seger <jseger@FreeBSD.org>1998-12-22 03:03:32 +0000
commit9c83ac47b4d70f6d733461e49b95a25b7e2e7956 (patch)
treebbcfbae355d6dc749ee0f1517d00b57c8c5cef0e /textproc/catdoc/Makefile
parent2359e7e6b3a47a937067c70c9f9256227804d1c9 (diff)
downloadports-9c83ac47b4d70f6d733461e49b95a25b7e2e7956.tar.gz
ports-9c83ac47b4d70f6d733461e49b95a25b7e2e7956.zip
Notes
Diffstat (limited to 'textproc/catdoc/Makefile')
-rw-r--r--textproc/catdoc/Makefile23
1 files changed, 9 insertions, 14 deletions
diff --git a/textproc/catdoc/Makefile b/textproc/catdoc/Makefile
index a47a74242d16..7892b0bd4fde 100644
--- a/textproc/catdoc/Makefile
+++ b/textproc/catdoc/Makefile
@@ -1,33 +1,28 @@
# New ports collection makefile for: catdoc
-# Version required: 0.3
+# Version required: 0.90.1
# Date created: 11 November 1997
# Whom: Brion Moss <brion@queeg.com>
#
-# $Id: Makefile,v 1.4 1998/06/18 14:53:03 hoek Exp $
+# $Id: Makefile,v 1.5 1998/07/24 11:48:20 ache Exp $
#
-DISTNAME= catdoc-0.35
+DISTNAME= catdoc-0.90.1
CATEGORIES= textproc
-MASTER_SITES= http://www.ice.ru/~vitus/works/
+MASTER_SITES= ftp://ftp.ice.ru/pub/vitus/
MAINTAINER= brion@queeg.com
MAN1= catdoc.1
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-wish=/usr/local/bin/wish8.0
.if !defined(LANG) || ${LANG} != ru_RU.KOI8-R
# Remove the below line to get Cyrillic code page support instead
CFLAGS+= -DLATIN1=1
.endif
-# The wordview tcl/tk script is small and not required. If the user
-# has tk, it will work. It comes preset for tcl/tk-8.0, but works with tcl-76.
-
-do-build:
- (cd ${WRKSRC} && ${CC} ${CFLAGS} -o catdoc catdoc.c)
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/catdoc ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${WRKSRC}/wordview ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/catdoc.1 ${PREFIX}/man/man1/catdoc.1
+# the author seems to have included some .o files for us ;-)
+pre-build:
+ @cd $(WRKSRC); $(MAKE) -k clean
.include <bsd.port.mk>