aboutsummaryrefslogtreecommitdiff
path: root/textproc/cbedic
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2005-02-15 23:17:45 +0000
committerPeter Pentchev <roam@FreeBSD.org>2005-02-15 23:17:45 +0000
commit4238596de365d54743d1c13f4087407d316af0e6 (patch)
tree515bd95445ad79373f62d64cd1e2f37335d2934f /textproc/cbedic
parent691842707491bb6adb851ca646cbc7cfe3355d44 (diff)
downloadports-4238596de365d54743d1c13f4087407d316af0e6.tar.gz
ports-4238596de365d54743d1c13f4087407d316af0e6.zip
Notes
Diffstat (limited to 'textproc/cbedic')
-rw-r--r--textproc/cbedic/Makefile19
-rw-r--r--textproc/cbedic/distinfo2
-rw-r--r--textproc/cbedic/files/patch-database.cpp11
-rw-r--r--textproc/cbedic/files/patch-registry.cpp29
-rw-r--r--textproc/cbedic/files/patch-src::cbedic.cpp16
-rw-r--r--textproc/cbedic/files/patch-translator.cpp38
-rw-r--r--textproc/cbedic/pkg-descr6
-rw-r--r--textproc/cbedic/pkg-plist1
8 files changed, 117 insertions, 5 deletions
diff --git a/textproc/cbedic/Makefile b/textproc/cbedic/Makefile
index e764c578a1af..a3363df36717 100644
--- a/textproc/cbedic/Makefile
+++ b/textproc/cbedic/Makefile
@@ -7,13 +7,22 @@
PORTNAME= cbedic
PORTVERSION= 1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=kbedic
-MAINTAINER= todorov@freebsd-bg.org
+MAINTAINER= roam@FreeBSD.org
+COMMENT= An English-to-Bulgarian and Bulgarian-to-English dictionary
-MASTERDIR= ${.CURDIR}/../kbedic
+RUN_DEPENDS= ${DICT_DIR}/${DICT_CHECK}:${PORTSDIR}/textproc/bedic-data
-CONSOLE_VER= yes
+DICT_CHECK?= buleng.dat
+DICT_DIR?= ${LOCALBASE}/share
-.include "${MASTERDIR}/Makefile"
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+CONFIGURE_ARGS= --datadir=${DICT_DIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/cbedic/distinfo b/textproc/cbedic/distinfo
new file mode 100644
index 000000000000..315c40088965
--- /dev/null
+++ b/textproc/cbedic/distinfo
@@ -0,0 +1,2 @@
+MD5 (cbedic-1.2.tar.gz) = a84055cfa6a1a99831eb2190e6df28d0
+SIZE (cbedic-1.2.tar.gz) = 3006925
diff --git a/textproc/cbedic/files/patch-database.cpp b/textproc/cbedic/files/patch-database.cpp
new file mode 100644
index 000000000000..a42f3b956a3a
--- /dev/null
+++ b/textproc/cbedic/files/patch-database.cpp
@@ -0,0 +1,11 @@
+--- src/database.cpp.orig Sat Aug 9 19:23:43 2003
++++ src/database.cpp Sat Aug 9 19:24:03 2003
+@@ -106,7 +106,7 @@
+ // Open data file and set some variables
+ // Return true if success, false if failed
+ //========================================================================
+-bool Database::createDictionary(const char *fileName, const long fixedLastWordPointer = 0) {
++bool Database::createDictionary(const char *fileName, const long fixedLastWordPointer) {
+ // Ensure against invoking twice
+ if (dataFile != NULL) {
+ return false;
diff --git a/textproc/cbedic/files/patch-registry.cpp b/textproc/cbedic/files/patch-registry.cpp
new file mode 100644
index 000000000000..ea643ccdf73c
--- /dev/null
+++ b/textproc/cbedic/files/patch-registry.cpp
@@ -0,0 +1,29 @@
+--- src/registry.cpp.orig Sat Aug 9 19:21:50 2003
++++ src/registry.cpp Sat Aug 9 19:22:52 2003
+@@ -79,7 +79,7 @@
+ //=== Get String =========================================================
+ // Return the value of key, if missed return default value
+ //========================================================================
+-char *Registry::getString(const char *property, const char *defaultValue = "") {
++char *Registry::getString(const char *property, const char *defaultValue ) {
+ bool found = false;
+ char *ret = NULL;
+ FILE *f;
+@@ -113,7 +113,7 @@
+ //=== Get Int ============================================================
+ // Return the value of key, if missed return default value
+ //========================================================================
+-int Registry::getInt(const char *property, const int defaultValue = 0) {
++int Registry::getInt(const char *property, const int defaultValue) {
+ int ret = defaultValue;
+ char *p;
+ p = getString(property);
+@@ -141,7 +141,7 @@
+ //=== Get Bool ===========================================================
+ // Return the value of key, if missed return default value
+ //========================================================================
+-bool Registry::getBool(const char *property, const bool defaultValue = false) {
++bool Registry::getBool(const char *property, const bool defaultValue) {
+ bool ret = defaultValue;
+ char *p;
+ p = getString(property);
diff --git a/textproc/cbedic/files/patch-src::cbedic.cpp b/textproc/cbedic/files/patch-src::cbedic.cpp
new file mode 100644
index 000000000000..1d7fcab02e72
--- /dev/null
+++ b/textproc/cbedic/files/patch-src::cbedic.cpp
@@ -0,0 +1,16 @@
+--- src/cbedic.cpp.old Fri Dec 12 04:51:13 2003
++++ src/cbedic.cpp Fri Dec 12 04:51:35 2003
+@@ -24,10 +24,12 @@
+ **********************************************************************/
+
+
+-#include <iostream.h>
++#include <iostream>
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <string.h>
++
++using namespace std;
+
+ #include "defaults.h"
+ #include "translator.h"
diff --git a/textproc/cbedic/files/patch-translator.cpp b/textproc/cbedic/files/patch-translator.cpp
new file mode 100644
index 000000000000..4333f9854924
--- /dev/null
+++ b/textproc/cbedic/files/patch-translator.cpp
@@ -0,0 +1,38 @@
+--- src/translator.cpp.orig Sat Aug 9 19:24:42 2003
++++ src/translator.cpp Sat Aug 9 19:26:11 2003
+@@ -119,7 +119,7 @@
+ // Real construcor
+ // Call the same method of Database, and return same result
+ //========================================================================
+-bool Translator::createDictionary(const char *fileName, const int dictionary, const long fixedLastWordPointer = 0) {
++bool Translator::createDictionary(const char *fileName, const int dictionary, const long fixedLastWordPointer) {
+ bool ret = false;
+ switch (dictionary) {
+ case ENG_BUL:
+@@ -275,7 +275,7 @@
+ // Return true if passed word is legal bulgarian word as LATIN_INPUT
+ // Return pointer to new word that is legal dictionary word
+ //========================================================================
+-bool Translator::isLatinInput(const char *word, char *buf, const bool ignoreSpace = false) {
++bool Translator::isLatinInput(const char *word, char *buf, const bool ignoreSpace ) {
+ int i = 0;
+ char *p;
+ while (word[i] != '\0') {
+@@ -304,7 +304,7 @@
+ // to a normal latin output
+ // Change buffer and return pointer to new word
+ //========================================================================
+-char *Translator::toLatin(const char *word, char *buf, const bool legalLatinInput = true) {
++char *Translator::toLatin(const char *word, char *buf, const bool legalLatinInput ) {
+ int i = 0;
+ int j = 0;
+ char *p;
+@@ -348,7 +348,7 @@
+ // Call the same method of Database, and return same result
+ // But perform some operations
+ //========================================================================
+-char *Translator::getWord(const bool lowerCase = true, const bool legalLatinInput = true) {
++char *Translator::getWord(const bool lowerCase, const bool legalLatinInput ) {
+ char *ret = NULL;
+ switch (currentDictionary) {
+ case ENG_BUL:
diff --git a/textproc/cbedic/pkg-descr b/textproc/cbedic/pkg-descr
new file mode 100644
index 000000000000..fd4dd4ef49d6
--- /dev/null
+++ b/textproc/cbedic/pkg-descr
@@ -0,0 +1,6 @@
+cbedic is the console version of KBE dictionary, the KDE Bulgarian-English
+Dictionary.
+WWW: http://kbedic.sourceforge.net
+
+-Angel
+todorov_bg@gmx.net
diff --git a/textproc/cbedic/pkg-plist b/textproc/cbedic/pkg-plist
new file mode 100644
index 000000000000..c6a02ca5ccd5
--- /dev/null
+++ b/textproc/cbedic/pkg-plist
@@ -0,0 +1 @@
+bin/cbedic