aboutsummaryrefslogtreecommitdiff
path: root/textproc/cdif
diff options
context:
space:
mode:
authorMIHIRA Sanpei Yoshiro <sanpei@FreeBSD.org>2000-07-22 13:51:22 +0000
committerMIHIRA Sanpei Yoshiro <sanpei@FreeBSD.org>2000-07-22 13:51:22 +0000
commitac5187ba6efd90d77f7ef1f0f00d89092589f08d (patch)
tree76dd87f60054c9b478ffc2334f53a4cdd1e16114 /textproc/cdif
parenta8a76dfca9523fe7072f5934aea52da35dac796d (diff)
downloadports-ac5187ba6efd90d77f7ef1f0f00d89092589f08d.tar.gz
ports-ac5187ba6efd90d77f7ef1f0f00d89092589f08d.zip
Notes
Diffstat (limited to 'textproc/cdif')
-rw-r--r--textproc/cdif/Makefile34
-rw-r--r--textproc/cdif/distinfo3
-rw-r--r--textproc/cdif/pkg-comment1
-rw-r--r--textproc/cdif/pkg-descr23
-rw-r--r--textproc/cdif/pkg-plist2
5 files changed, 63 insertions, 0 deletions
diff --git a/textproc/cdif/Makefile b/textproc/cdif/Makefile
new file mode 100644
index 000000000000..992b149fe112
--- /dev/null
+++ b/textproc/cdif/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: cdif
+# Date created: July 22, 2000
+# Whom: Yoshiro MIHIRA <sanpei@sanpei.org>
+#
+# $NetBSD: Makefile,v 1.2 2000/03/16 14:08:38 wiz Exp $
+# $FreeBSD$
+#
+
+PORTNAME= cdif
+PORTVERSION= 1.15
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.iij.ad.jp/pub/IIJ/dist/utashiro/perl/
+EXTRACT_SUFX= # empty
+
+MAINTAINER= sanpei@FreeBSD.org
+
+USE_PERL5= yes
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ ${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}/${DISTNAME}.dist
+
+# assumes perl is in ${LOCALBASE}/bin/perl
+do-patch:
+ ${SED} -e '1s@/usr/local/bin/perl@${LOCALBASE}/bin/perl@' \
+ < ${WRKSRC}/${DISTNAME}.dist > ${WRKSRC}/${DISTNAME}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin/cdif
+
+.include <bsd.port.mk>
diff --git a/textproc/cdif/distinfo b/textproc/cdif/distinfo
new file mode 100644
index 000000000000..ad06cad03e74
--- /dev/null
+++ b/textproc/cdif/distinfo
@@ -0,0 +1,3 @@
+$NetBSD: md5,v 1.1.1.1 2000/03/12 09:44:30 itojun Exp $
+
+MD5 (cdif-1.15) = b3d4ebebcea5e1e85264a180178339b4
diff --git a/textproc/cdif/pkg-comment b/textproc/cdif/pkg-comment
new file mode 100644
index 000000000000..aaa2f6366b25
--- /dev/null
+++ b/textproc/cdif/pkg-comment
@@ -0,0 +1 @@
+Display word context diff
diff --git a/textproc/cdif/pkg-descr b/textproc/cdif/pkg-descr
new file mode 100644
index 000000000000..955af33ae7e2
--- /dev/null
+++ b/textproc/cdif/pkg-descr
@@ -0,0 +1,23 @@
+Usage: cdif [-Bvn] [-A #] [-C #] [-D #] [-I #] [-[bwcu]] file1 file2
+ cdif [-rcs] [-q] [-rrev1 [-rrev2]] [cdif options] file
+ cdif [cdif options] [diff-output-file]
+Options:
+ -B byte compare
+ -v use video standout (default for tty)
+ -n use nroff style overstrike (default for non-tty)
+ -b ignore trailing blank
+ -w ignore whitespace
+ -c[#] context diff
+ -u[#] unified diff (if diff has -u option)
+ -e # expression of `word' (default is '\w+')
+ -A, -C, -D (Append, Change, Delete) takes one of
+ vso: video standout vul: video underline
+ vbd: video bold bd: nroff style overstrike
+ ul: nroff style underline
+ or any sequence or sequences separated by comma
+ -I specify string to be shown on insertion point
+ Following strings have special meanings.
+ vbar: print vertical bar at the point
+ caret: print caret under the point
+ -diff=command
+ specify any diff command
diff --git a/textproc/cdif/pkg-plist b/textproc/cdif/pkg-plist
new file mode 100644
index 000000000000..e27d79bec9ba
--- /dev/null
+++ b/textproc/cdif/pkg-plist
@@ -0,0 +1,2 @@
+@comment $NetBSD: PLIST,v 1.2 2000/03/16 14:08:51 wiz Exp $
+bin/cdif