aboutsummaryrefslogtreecommitdiff
path: root/textproc/cdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-12-21 16:10:14 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-12-21 16:10:14 +0000
commit756f89463db697af1f2ae38a01e65a258f13f867 (patch)
tree4d7ef1d9a19edd7b3804ed8c350dfbae4896dc00 /textproc/cdiff
parentb2683a0816c4553a63c035e27dd0583a6db8c9ce (diff)
downloadports-756f89463db697af1f2ae38a01e65a258f13f867.tar.gz
ports-756f89463db697af1f2ae38a01e65a258f13f867.zip
Notes
Diffstat (limited to 'textproc/cdiff')
-rw-r--r--textproc/cdiff/Makefile3
-rw-r--r--textproc/cdiff/src/cdiff.14
-rw-r--r--textproc/cdiff/src/cdiff.sh6
3 files changed, 10 insertions, 3 deletions
diff --git a/textproc/cdiff/Makefile b/textproc/cdiff/Makefile
index c7a262cc5bee..17373bbdf869 100644
--- a/textproc/cdiff/Makefile
+++ b/textproc/cdiff/Makefile
@@ -8,8 +8,7 @@
#
PORTNAME= cdiff
-PORTVERSION= 1.4
-PORTREVISION= 1
+PORTVERSION= 1.5
CATEGORIES= textproc
MASTER_SITES= # none
DISTFILES= # none
diff --git a/textproc/cdiff/src/cdiff.1 b/textproc/cdiff/src/cdiff.1
index 53d167629425..cadff07ed6da 100644
--- a/textproc/cdiff/src/cdiff.1
+++ b/textproc/cdiff/src/cdiff.1
@@ -49,6 +49,10 @@ There is also handling of "cvs annotate" in it.
.It Fl m
Use bold, reverse and underline codes (for monochrome terminals).
.El
+.Bl -tag -width CDIFFCOLORS
+.It Ev CDIFFCOLORS
+The color codes used to add. Default is 1:34:31:35, for lines begin with "@", "-", "+" and "!".
+.El
.Sh AUTHORS
.Nm
was written by
diff --git a/textproc/cdiff/src/cdiff.sh b/textproc/cdiff/src/cdiff.sh
index 47f62d97f5c8..102dc6adcbdc 100644
--- a/textproc/cdiff/src/cdiff.sh
+++ b/textproc/cdiff/src/cdiff.sh
@@ -3,7 +3,11 @@ if [ "$1" = "-m" ]; then
shift;
CODES="4:7:1:1"
else
- CODES="1:34:31:35"
+ if [ "$CDIFFCOLORS" != "" ]; then
+ CODES=$CDIFFCOLORS
+ else
+ CODES="1:34:31:35"
+ fi
fi
(if [ "$1" != "" ]; then
while [ "$1" != "" ]; do