aboutsummaryrefslogtreecommitdiff
path: root/textproc/chpp/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-11-18 08:09:05 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-11-18 08:09:05 +0000
commit6d9889cee533fe75f7ea8259fc6b04d1556e6dc8 (patch)
treefbb5abce1c989df0b883fcd48b389866d5906cfa /textproc/chpp/Makefile
parent16195e50a87f6db7cbb2fa2ef00efceceee4d6a7 (diff)
downloadports-6d9889cee533fe75f7ea8259fc6b04d1556e6dc8.tar.gz
ports-6d9889cee533fe75f7ea8259fc6b04d1556e6dc8.zip
Notes
Diffstat (limited to 'textproc/chpp/Makefile')
-rw-r--r--textproc/chpp/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/textproc/chpp/Makefile b/textproc/chpp/Makefile
index 9403e552dfe7..1153c2567eb3 100644
--- a/textproc/chpp/Makefile
+++ b/textproc/chpp/Makefile
@@ -13,9 +13,9 @@ COMMENT= Non-intrusive full-featured text preprocessor
LICENSE= GPLv2
-LIB_DEPENDS= gc.1:${PORTSDIR}/devel/boehm-gc
+LIB_DEPENDS= libgc.so:${PORTSDIR}/devel/boehm-gc
-USE_GMAKE= yes
+USES= gmake
USE_AUTOTOOLS= autoheader aclocal automake autoconf
AUTOMAKE_ARGS= --add-missing --copy --force-missing
CONFIGURE_ARGS= --libdir=${PREFIX}/share
@@ -25,7 +25,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
INFO= chpp
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386" && ${ARCH} != "amd64"
@@ -49,15 +50,11 @@ post-patch:
.endfor
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in AUTHORS NEWS README
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/test && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
-.endif
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/test && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.post.mk>