aboutsummaryrefslogtreecommitdiff
path: root/textproc/clucene-qt5
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-11-05 09:39:21 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-11-05 09:39:21 +0000
commita9662ed9499601956169af13ac47f255b10f83e1 (patch)
treede667d296e818eb8d5953ab35ea2c695f47825db /textproc/clucene-qt5
parentf7d704569d02ab6d3da84ce41f3b418688b9baf8 (diff)
Notes
Diffstat (limited to 'textproc/clucene-qt5')
-rw-r--r--textproc/clucene-qt5/Makefile5
-rw-r--r--textproc/clucene-qt5/files/patch-3rdparty__clucene__src__CLucene__search__FieldCacheImpl.cpp4
-rw-r--r--textproc/clucene-qt5/files/patch-src__assistant__assistant.pro28
-rw-r--r--textproc/clucene-qt5/files/patch-src__src.pro45
4 files changed, 77 insertions, 5 deletions
diff --git a/textproc/clucene-qt5/Makefile b/textproc/clucene-qt5/Makefile
index a031df31fd7e..eddf37b28222 100644
--- a/textproc/clucene-qt5/Makefile
+++ b/textproc/clucene-qt5/Makefile
@@ -2,7 +2,6 @@
PORTNAME= clucene
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
CATEGORIES= textproc
PKGNAMEPREFIX= qt5-
@@ -14,7 +13,7 @@ QT_DIST= tools
USES= qmake
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
-WRKSRC_SUBDIR= src/assistant/${PORTNAME}
-PATCH_WRKSRC= ${WRKSRC:H}
+BUILD_WRKSRC= ${WRKSRC}/src/assistant/${PORTNAME}
+INSTALL_WRKSRC= ${WRKSRC}/src/assistant/${PORTNAME}
.include <bsd.port.mk>
diff --git a/textproc/clucene-qt5/files/patch-3rdparty__clucene__src__CLucene__search__FieldCacheImpl.cpp b/textproc/clucene-qt5/files/patch-3rdparty__clucene__src__CLucene__search__FieldCacheImpl.cpp
index 239d476488bc..2047d2861f89 100644
--- a/textproc/clucene-qt5/files/patch-3rdparty__clucene__src__CLucene__search__FieldCacheImpl.cpp
+++ b/textproc/clucene-qt5/files/patch-3rdparty__clucene__src__CLucene__search__FieldCacheImpl.cpp
@@ -1,5 +1,5 @@
---- ./3rdparty/clucene/src/CLucene/search/FieldCacheImpl.cpp.orig 2012-12-18 20:04:15.000000000 +0100
-+++ ./3rdparty/clucene/src/CLucene/search/FieldCacheImpl.cpp 2013-01-07 11:29:50.837339980 +0100
+--- src/assistant/3rdparty/clucene/src/CLucene/search/FieldCacheImpl.cpp
++++ src/assistant/3rdparty/clucene/src/CLucene/search/FieldCacheImpl.cpp
@@ -11,6 +11,8 @@
CL_NS_USE(index)
CL_NS_DEF(search)
diff --git a/textproc/clucene-qt5/files/patch-src__assistant__assistant.pro b/textproc/clucene-qt5/files/patch-src__assistant__assistant.pro
new file mode 100644
index 000000000000..5defce3a9904
--- /dev/null
+++ b/textproc/clucene-qt5/files/patch-src__assistant__assistant.pro
@@ -0,0 +1,28 @@
+Only enter the directories we want to build, otherwise we might fail due to
+missing dependencies.
+
+--- src/assistant/assistant.pro
++++ src/assistant/assistant.pro
+@@ -1,21 +1,3 @@
+ TEMPLATE = subdirs
+
+-SUBDIRS += clucene \
+- help \
+- assistant \
+- qhelpgenerator \
+- qcollectiongenerator \
+- qhelpconverter
+-
+-help.depends = clucene
+-assistant.depends = help
+-qhelpgenerator.depends = help
+-qcollectiongenerator.depends = help
+-qhelpconverter.depends = help
+-
+-qtNomakeTools( \
+- assistant \
+- qhelpgenerator \
+- qcollectiongenerator \
+- qhelpconverter \
+-)
++SUBDIRS += clucene
diff --git a/textproc/clucene-qt5/files/patch-src__src.pro b/textproc/clucene-qt5/files/patch-src__src.pro
new file mode 100644
index 000000000000..08d7b209cf61
--- /dev/null
+++ b/textproc/clucene-qt5/files/patch-src__src.pro
@@ -0,0 +1,45 @@
+Only enter the directories we want to build, otherwise we might fail due to
+missing dependencies.
+
+--- src/src.pro
++++ src/src.pro
+@@ -1,38 +1,2 @@
+ TEMPLATE = subdirs
+-
+-qtHaveModule(widgets) {
+- no-png {
+- message("Some graphics-related tools are unavailable without PNG support")
+- } else {
+- SUBDIRS = assistant \
+- pixeltool \
+- qtestlib \
+- designer
+-# unix:!mac:!embedded:!qpa:SUBDIRS += qtconfig
+-
+- linguist.depends = designer
+- }
+-}
+-
+-SUBDIRS += linguist
+-if(!android|android_app):!ios: SUBDIRS += qtpaths
+-
+-mac {
+- SUBDIRS += macdeployqt
+-}
+-
+-android {
+- SUBDIRS += androiddeployqt
+-}
+-
+-qtHaveModule(dbus): SUBDIRS += qdbus
+-
+-win32|winrt:SUBDIRS += windeployqt
+-winrt:SUBDIRS += winrtrunner qtd3dservice
+-qtHaveModule(gui):!android:!ios:!qnx:!wince*:!winrt*:SUBDIRS += qtdiag
+-
+-qtNomakeTools( \
+- pixeltool \
+- qtconfig \
+- macdeployqt \
+-)
++SUBDIRS = assistant