aboutsummaryrefslogtreecommitdiff
path: root/textproc/confget/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-29 16:14:06 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-02-29 16:14:06 +0000
commitf6d5594a704d847d1a9076aa03e9af2fc474deaa (patch)
tree05b14ef8e0964d087353f503b0c13ce79a9a47aa /textproc/confget/Makefile
parent9dc8842dbcacd0f17d9c1631578aeb6f8175a0d6 (diff)
downloadports-f6d5594a704d847d1a9076aa03e9af2fc474deaa.tar.gz
ports-f6d5594a704d847d1a9076aa03e9af2fc474deaa.zip
Notes
Diffstat (limited to 'textproc/confget/Makefile')
-rw-r--r--textproc/confget/Makefile44
1 files changed, 23 insertions, 21 deletions
diff --git a/textproc/confget/Makefile b/textproc/confget/Makefile
index 789023cf5813..ed1d0a672472 100644
--- a/textproc/confget/Makefile
+++ b/textproc/confget/Makefile
@@ -6,40 +6,42 @@
#
PORTNAME= confget
-PORTVERSION= 1.02
-PORTREVISION= 1
+PORTVERSION= 1.03
CATEGORIES= textproc
-MASTER_SITES= http://devel.ringlet.net/textproc/confget/
+MASTER_SITES= http://devel.ringlet.net/textproc/confget/ \
+ LOCAL/sunpoet
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Read variables from INI-style configuration files
OPTIONS= PCRE "Regular expression support" on
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_PCRE)
-LIB_DEPENDS= pcre.1:${PORTSDIR}/devel/pcre
-.else
-MAKE_ENV+= PCRE_CFLAGS= PCRE_LIBS=
-.endif
-
+MAKE_ENV= CFLAGS_CONF=-DHAVE_FGETLN
USE_GMAKE= yes
-MAKE_ENV+= CFLAGS_CONF=-DHAVE_FGETLN
-
MAN1= confget.1
MANCOMPRESSED= yes
+PLIST_FILES= bin/confget
+PORTEXAMPLES= t1.ini t2.ini
-.if defined(NOPORTEXAMPLES)
-post-patch:
- ${REINPLACE_CMD} -E -e 's/([^n])install-examples/\1/' \
- ${WRKSRC}/Makefile
-.else
+.if !defined(NOPORTEXAMPLES)
MAKE_ENV+= EXAMPLESDIR=${EXAMPLESDIR}
.endif
-test: build
- cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
+.include <bsd.port.options.mk>
+
+.if !defined(WITHOUT_PCRE)
+LIB_DEPENDS+= pcre.1:${PORTSDIR}/devel/pcre
+.else
+MAKE_ENV+= PCRE_CFLAGS="" PCRE_LIBS=""
+.endif
+
+post-patch:
+.if defined(NOPORTEXAMPLES)
+ @${REINPLACE_CMD} -e '/^install:/ s| install-examples||' ${WRKSRC}/Makefile
+.endif
+
+regression-test test: build
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>