aboutsummaryrefslogtreecommitdiff
path: root/textproc/csv2latex
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-19 08:32:37 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-05-19 08:32:37 +0000
commit91bfcd9f17ea54c06aeed06baea2dc9a8401405e (patch)
tree7f463e31a94caaf64eec8aff2a5e45ce0e389b27 /textproc/csv2latex
parent398cf34483c98fe7a1ed28c699638fd84a32b75d (diff)
downloadports-91bfcd9f17ea54c06aeed06baea2dc9a8401405e.tar.gz
ports-91bfcd9f17ea54c06aeed06baea2dc9a8401405e.zip
Notes
Diffstat (limited to 'textproc/csv2latex')
-rw-r--r--textproc/csv2latex/Makefile32
-rw-r--r--textproc/csv2latex/distinfo1
-rw-r--r--textproc/csv2latex/pkg-descr4
-rw-r--r--textproc/csv2latex/pkg-plist1
4 files changed, 38 insertions, 0 deletions
diff --git a/textproc/csv2latex/Makefile b/textproc/csv2latex/Makefile
new file mode 100644
index 000000000000..6f0caf9998c2
--- /dev/null
+++ b/textproc/csv2latex/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: csv2latex
+# Date created: May 19, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= csv2latex
+PORTVERSION= 20030501
+CATEGORIES= textproc
+MASTER_SITES= http://brouits.free.fr/share/utils/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .c
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Converts a well formed csv file to a LaTeX document
+
+USE_GETOPT_LONG= yes
+NO_WRKSUBDIR= yes
+EXTRACT_CMD= ${CP}
+EXTRACT_BEFORE_ARGS= #
+EXTRACT_AFTER_ARGS= .
+
+do-build:
+ @cd ${WRKSRC} && \
+ ${CC} ${CPPFLAGS} -o ${PORTNAME} ${PORTNAME}.c ${LDFLAGS}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/textproc/csv2latex/distinfo b/textproc/csv2latex/distinfo
new file mode 100644
index 000000000000..ebf680c913dc
--- /dev/null
+++ b/textproc/csv2latex/distinfo
@@ -0,0 +1 @@
+MD5 (csv2latex.c) = d334bf0c814e1e8c76416b495fbe71eb
diff --git a/textproc/csv2latex/pkg-descr b/textproc/csv2latex/pkg-descr
new file mode 100644
index 000000000000..fc92cebf95fe
--- /dev/null
+++ b/textproc/csv2latex/pkg-descr
@@ -0,0 +1,4 @@
+csv2latex converts a well formed csv file (as done by OpenOffice.org) to
+a LaTeX document.
+
+WWW: http://brouits.free.fr/csv2latex/
diff --git a/textproc/csv2latex/pkg-plist b/textproc/csv2latex/pkg-plist
new file mode 100644
index 000000000000..9c31a41eb805
--- /dev/null
+++ b/textproc/csv2latex/pkg-plist
@@ -0,0 +1 @@
+bin/csv2latex