aboutsummaryrefslogtreecommitdiff
path: root/textproc/ctpp2/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-28 09:38:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-28 09:38:12 +0000
commit0958f9af7028031f10ead9eb987f4b9877b9da4f (patch)
tree144af968d98e2e4bb52ad24590a93730a8473041 /textproc/ctpp2/Makefile
parent36056c6561e315750c8fb40ab8702fcafa1cf4b2 (diff)
downloadports-0958f9af7028031f10ead9eb987f4b9877b9da4f.tar.gz
ports-0958f9af7028031f10ead9eb987f4b9877b9da4f.zip
Notes
Diffstat (limited to 'textproc/ctpp2/Makefile')
-rw-r--r--textproc/ctpp2/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/textproc/ctpp2/Makefile b/textproc/ctpp2/Makefile
new file mode 100644
index 000000000000..98e08921b652
--- /dev/null
+++ b/textproc/ctpp2/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: ctpp2
+# Date created: 25 Jan 2008
+# Whom: reki@reki.ru (Andrei V. Shetuhin)
+#
+# $FreeBSD$
+#
+
+PORTNAME= ctpp2
+PORTVERSION= 2.0.4
+CATEGORIES= textproc devel
+MASTER_SITES= http://ctpp.havoc.ru/download/
+
+MAINTAINER= reki@reki.ru
+COMMENT= C++ library to use templates in C/C++ projects, version 2
+
+BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
+
+USE_LDCONFIG= yes
+
+do-configure:
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/cmake ${WRKSRC}
+
+.include <bsd.port.mk>