aboutsummaryrefslogtreecommitdiff
path: root/textproc/ctpp2
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-28 09:38:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-28 09:38:12 +0000
commit0958f9af7028031f10ead9eb987f4b9877b9da4f (patch)
tree144af968d98e2e4bb52ad24590a93730a8473041 /textproc/ctpp2
parent36056c6561e315750c8fb40ab8702fcafa1cf4b2 (diff)
downloadports-0958f9af7028031f10ead9eb987f4b9877b9da4f.tar.gz
ports-0958f9af7028031f10ead9eb987f4b9877b9da4f.zip
Notes
Diffstat (limited to 'textproc/ctpp2')
-rw-r--r--textproc/ctpp2/Makefile23
-rw-r--r--textproc/ctpp2/distinfo3
-rw-r--r--textproc/ctpp2/pkg-descr6
-rw-r--r--textproc/ctpp2/pkg-plist52
4 files changed, 84 insertions, 0 deletions
diff --git a/textproc/ctpp2/Makefile b/textproc/ctpp2/Makefile
new file mode 100644
index 000000000000..98e08921b652
--- /dev/null
+++ b/textproc/ctpp2/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: ctpp2
+# Date created: 25 Jan 2008
+# Whom: reki@reki.ru (Andrei V. Shetuhin)
+#
+# $FreeBSD$
+#
+
+PORTNAME= ctpp2
+PORTVERSION= 2.0.4
+CATEGORIES= textproc devel
+MASTER_SITES= http://ctpp.havoc.ru/download/
+
+MAINTAINER= reki@reki.ru
+COMMENT= C++ library to use templates in C/C++ projects, version 2
+
+BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
+
+USE_LDCONFIG= yes
+
+do-configure:
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/cmake ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/textproc/ctpp2/distinfo b/textproc/ctpp2/distinfo
new file mode 100644
index 000000000000..01c7cd2fd892
--- /dev/null
+++ b/textproc/ctpp2/distinfo
@@ -0,0 +1,3 @@
+MD5 (ctpp2-2.0.4.tar.gz) = b938d08ca0faf7b246ca04959cea96cb
+SHA256 (ctpp2-2.0.4.tar.gz) = 2a08b1bd07d596447644a5a0d929a9a52310ba5058457bd0bbe43b4d31bffdd3
+SIZE (ctpp2-2.0.4.tar.gz) = 109701
diff --git a/textproc/ctpp2/pkg-descr b/textproc/ctpp2/pkg-descr
new file mode 100644
index 000000000000..776d1d3ca609
--- /dev/null
+++ b/textproc/ctpp2/pkg-descr
@@ -0,0 +1,6 @@
+This is a simple set of C++ classes which allow to use
+templates like perl module HTML::Template
+
+WWW: http://reki.ru/products/ctpp/
+
+- shetuhin@corp.mail.ru
diff --git a/textproc/ctpp2/pkg-plist b/textproc/ctpp2/pkg-plist
new file mode 100644
index 000000000000..c6dd08053ed6
--- /dev/null
+++ b/textproc/ctpp2/pkg-plist
@@ -0,0 +1,52 @@
+include/ctpp2/CDT.hpp
+include/ctpp2/CTPP2.hpp
+include/ctpp2/CTPP2CharIterator.hpp
+include/ctpp2/CTPP2Compiler.hpp
+include/ctpp2/CTPP2FileSourceLoader.hpp
+include/ctpp2/CTPP2GlobalDefines.h
+include/ctpp2/CTPP2JSONParser.hpp
+include/ctpp2/CTPP2JSONFileParser.hpp
+include/ctpp2/CTPP2Parser.hpp
+include/ctpp2/CTPP2Syntax.h
+include/ctpp2/CTPP2SourceLoader.hpp
+include/ctpp2/CTPP2SysHeaders.h
+include/ctpp2/CTPP2Types.h
+include/ctpp2/CTPPException.hpp
+include/ctpp2/CTPPParserException.hpp
+include/ctpp2/FileOutputCollector.hpp
+include/ctpp2/OutputCollector.hpp
+include/ctpp2/StaticData.hpp
+include/ctpp2/StaticText.hpp
+include/ctpp2/SyscallFactory.hpp
+include/ctpp2/StringOutputCollector.hpp
+include/ctpp2/Types.h
+include/ctpp2/VM.hpp
+include/ctpp2/VMArgStack.hpp
+include/ctpp2/VMCodeStack.hpp
+include/ctpp2/VMDumper.hpp
+include/ctpp2/VMException.hpp
+include/ctpp2/VMExecutable.hpp
+include/ctpp2/VMFileLoader.hpp
+include/ctpp2/VMInstruction.hpp
+include/ctpp2/VMLoader.hpp
+include/ctpp2/VMMemoryCore.hpp
+include/ctpp2/VMOpcodeCollector.hpp
+include/ctpp2/VMOpcodes.h
+include/ctpp2/VMSTDLib.hpp
+include/ctpp2/VMStackException.hpp
+include/ctpp2/VMSyscall.hpp
+lib/libctpp2.so
+lib/libctpp2.so.2
+lib/libctpp2.so.2.0.4
+lib/libctpp2-st.a
+bin/ctpp2vm
+bin/ctpp2c
+bin/ctpp2i
+bin/ctpp2json
+share/locale/ru_RU.KOI8-R/LC_MESSAGES/ctpp2.mo
+share/locale/ru_RU.CP1251/LC_MESSAGES/ctpp2.mo
+@dirrmtry share/locale/ru_RU.KOI8-R/LC_MESSAGES
+@dirrmtry share/locale/ru_RU.KOI8-R
+@dirrmtry share/locale/ru_RU.CP1251/LC_MESSAGES
+@dirrmtry share/locale/ru_RU.CP1251
+@dirrm include/ctpp2