aboutsummaryrefslogtreecommitdiff
path: root/textproc/denature
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-13 08:45:54 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-13 08:45:54 +0000
commit7352addb24f8823658bda20a669d47fb13f882c1 (patch)
tree33e041eb6e8a4658f65ae1f367604d691fcffd0c /textproc/denature
parentae88725e1a19a0874666adca6ba0201029deb811 (diff)
downloadports-7352addb24f8823658bda20a669d47fb13f882c1.tar.gz
ports-7352addb24f8823658bda20a669d47fb13f882c1.zip
Notes
Diffstat (limited to 'textproc/denature')
-rw-r--r--textproc/denature/Makefile42
-rw-r--r--textproc/denature/distinfo1
-rw-r--r--textproc/denature/files/patch-denature19
-rw-r--r--textproc/denature/pkg-descr11
-rw-r--r--textproc/denature/pkg-plist1
5 files changed, 74 insertions, 0 deletions
diff --git a/textproc/denature/Makefile b/textproc/denature/Makefile
new file mode 100644
index 000000000000..5a6e83ddcb52
--- /dev/null
+++ b/textproc/denature/Makefile
@@ -0,0 +1,42 @@
+# ex:ts=8
+# Ports collection makefile for: denature
+# Date created: Jan 6, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= denature
+PORTVERSION= 0.6.5
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A HTML to PDF converter
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/HTML/Tagset.pm:${PORTSDIR}/www/p5-HTML-Tagset \
+ ${SITE_PERL}/HTML/Tree.pm:${PORTSDIR}/www/p5-HTML-Tree \
+ ${SITE_PERL}/CSS/Tiny.pm:${PORTSDIR}/textproc/p5-CSS-Tiny \
+ fop:${PORTSDIR}/textproc/fop
+
+USE_PERL5= yes
+USE_JAVA= 1.2+
+POD2MAN?= pod2man
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+MAN1= denature.1
+
+post-patch:
+ @${PERL} -pi -e "s|%%LOCALBASE%%|${LOCALBASE}| ; \
+ s|%%JAVA_HOME%%|${JAVA_HOME}|" ${WRKSRC}/denature
+
+do-build:
+ cd ${WRKSRC} && ${POD2MAN} denature > denature.1
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/denature ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/denature.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/textproc/denature/distinfo b/textproc/denature/distinfo
new file mode 100644
index 000000000000..72bc71e4ab7b
--- /dev/null
+++ b/textproc/denature/distinfo
@@ -0,0 +1 @@
+MD5 (denature-0.6.5.tar.gz) = 4e52614fe1039779b09dc70e5aea3518
diff --git a/textproc/denature/files/patch-denature b/textproc/denature/files/patch-denature
new file mode 100644
index 000000000000..e8f98fe21a9a
--- /dev/null
+++ b/textproc/denature/files/patch-denature
@@ -0,0 +1,19 @@
+--- denature.orig Tue Jan 6 15:06:24 2004
++++ denature Tue Jan 6 15:08:54 2004
+@@ -1,4 +1,4 @@
+-#!/usr/bin/perl -w
++#!/usr/bin/env perl -w
+
+ #
+ # Copyright (C) 2003 dan sinclair
+@@ -15,8 +15,8 @@
+ use Getopt::Std;
+ use CSS::Tiny;
+
+-my $fop_home = "/usr/local/fop-0.20.5rc/";
+-my $java_home = "/opt/blackdown-jdk-1.3.1/";
++my $fop_home = "%%LOCALBASE%%/share/fop/";
++my $java_home = "%%JAVA_HOME%%/";
+
+ ####################################################
+ ##### Probably don't need to edit below here #######
diff --git a/textproc/denature/pkg-descr b/textproc/denature/pkg-descr
new file mode 100644
index 000000000000..319c7cdcf850
--- /dev/null
+++ b/textproc/denature/pkg-descr
@@ -0,0 +1,11 @@
+denature is a perl program that attempts to convert an HTML page into XSL-FO
+which it then passes off to the FOP (Formatted Objects Formatter) to produce a
+PDF document.
+
+denature trys to use any included CSS stylesheets to figure out the properties
+used in the document. The CSS processing in denature is not very mature and
+only handles a limited amount of the available CSS markup. The CSS support
+does not handle the contextual entries in a CSS document, and the CSS::Tiny
+module requires that all the :'s in a document have a space after them.
+
+WWW: http://denature.sourceforge.net/
diff --git a/textproc/denature/pkg-plist b/textproc/denature/pkg-plist
new file mode 100644
index 000000000000..d55470cef74a
--- /dev/null
+++ b/textproc/denature/pkg-plist
@@ -0,0 +1 @@
+bin/denature