aboutsummaryrefslogtreecommitdiff
path: root/textproc/dictfmt/Makefile
diff options
context:
space:
mode:
authorYoichi NAKAYAMA <yoichi@FreeBSD.org>2002-07-19 14:27:20 +0000
committerYoichi NAKAYAMA <yoichi@FreeBSD.org>2002-07-19 14:27:20 +0000
commit2cfec919999236c8194c9944dd71802b2e669b04 (patch)
tree7b21c405b03b6831e4e810bc82fb6733a78b189d /textproc/dictfmt/Makefile
parent32fa489d38a8f274d185967a716c6db98fb1d7ff (diff)
downloadports-2cfec919999236c8194c9944dd71802b2e669b04.tar.gz
ports-2cfec919999236c8194c9944dd71802b2e669b04.zip
Notes
Diffstat (limited to 'textproc/dictfmt/Makefile')
-rw-r--r--textproc/dictfmt/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/textproc/dictfmt/Makefile b/textproc/dictfmt/Makefile
new file mode 100644
index 000000000000..52eb3b448e9d
--- /dev/null
+++ b/textproc/dictfmt/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: dictfmt
+# Date created: 19 July 2002
+# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dictfmt
+PORTVERSION= 1.6.1
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.dict.org/pub/dict/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-source
+
+MAINTAINER= fuyuki@hadaly.org
+
+LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
+
+NO_WRKSUBDIR= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+USE_GMAKE= yes
+
+MAN1= dictfmt.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/dictfmt ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/dictfmt.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>