aboutsummaryrefslogtreecommitdiff
path: root/textproc/dictfmt
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-05-18 23:18:42 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-05-18 23:18:42 +0000
commitd7002343e529722f25ce55c6bcf0ce48fcd5b44b (patch)
tree54aa36c5f1e4ec4ee3d5e6226152300cdc81cfc9 /textproc/dictfmt
parent3f1e14bb32a9ee4d52da0ed167035d82f82de229 (diff)
downloadports-d7002343e529722f25ce55c6bcf0ce48fcd5b44b.tar.gz
ports-d7002343e529722f25ce55c6bcf0ce48fcd5b44b.zip
Notes
Diffstat (limited to 'textproc/dictfmt')
-rw-r--r--textproc/dictfmt/Makefile17
-rw-r--r--textproc/dictfmt/distinfo2
-rw-r--r--textproc/dictfmt/files/patch-configure.in15
-rw-r--r--textproc/dictfmt/files/patch-dictP.h19
4 files changed, 16 insertions, 37 deletions
diff --git a/textproc/dictfmt/Makefile b/textproc/dictfmt/Makefile
index eb2977553389..3e5671e308a2 100644
--- a/textproc/dictfmt/Makefile
+++ b/textproc/dictfmt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dictfmt
-PORTVERSION= 1.9.8
+PORTVERSION= 1.9.9
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= dict
@@ -15,20 +15,19 @@ DISTNAME= dictd-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Formats a DICT protocol dictionary database
-BUILD_DEPENDS= aclocal:${PORTSDIR}/devel/automake
+LIB_DEPENDS= ltdl.1:${PORTSDIR}/devel/libtool
-USE_AUTOCONF= yes
-WANT_AUTOCONF_VER= 253
-USE_LIBTOOL= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
USE_GMAKE= yes
+USE_AUTOCONF_VER= 253
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
+ AUTOHEADER="${TRUE}"
ALL_TARGET= dictfmt
INSTALL_TARGET= install.dictfmt
MAN1= dictfmt.1 dictfmt_index2suffix.1 dictfmt_index2word.1 \
dictunformat.1
-post-patch:
- cd ${WRKSRC}; aclocal; ${AUTOHEADER}
-
.include <bsd.port.mk>
diff --git a/textproc/dictfmt/distinfo b/textproc/dictfmt/distinfo
index b06fb0f4ca1d..0c7e345cb144 100644
--- a/textproc/dictfmt/distinfo
+++ b/textproc/dictfmt/distinfo
@@ -1 +1 @@
-MD5 (dictd-1.9.8.tar.gz) = e8968c93ab3989c24a0f11d80cfea3eb
+MD5 (dictd-1.9.9.tar.gz) = d4ce1c63a619a575e7a6e51d657c2dcf
diff --git a/textproc/dictfmt/files/patch-configure.in b/textproc/dictfmt/files/patch-configure.in
index f27ffa55b128..ef4e073f4b1d 100644
--- a/textproc/dictfmt/files/patch-configure.in
+++ b/textproc/dictfmt/files/patch-configure.in
@@ -1,12 +1,11 @@
---- configure.in.orig
-+++ configure.in
-@@ -311,7 +311,8 @@
+--- configure.in.orig Tue Apr 15 00:15:01 2003
++++ configure.in Sat May 3 06:08:59 2003
+@@ -326,7 +326,7 @@
AC_CHECK_HEADERS(sys/resource.h sys/time.h sys/param.h sys/wait.h)
AC_CHECK_HEADERS(wctype.h wchar.h)
--AC_CHECK_TYPES([wint_t, mbstate_t])
-+AC_CHECK_TYPES([wint_t, mbstate_t], , ,[#include <wchar.h>])
-+AC_CHECK_TYPES([wchar_t], , ,[#include <wchar.h>])
+-AC_CHECK_TYPES(wint_t)
++AC_CHECK_TYPES(wint_t, , , [#include <wchar.h>])
+ AC_CHECK_TYPES(mbstate_t, , , [#include <wchar.h>])
+ AC_CHECK_TYPES(wchar_t, , , [#include <stddef.h>])
- echo .
- echo Checking for system constants
diff --git a/textproc/dictfmt/files/patch-dictP.h b/textproc/dictfmt/files/patch-dictP.h
index 66150be0e39a..e69de29bb2d1 100644
--- a/textproc/dictfmt/files/patch-dictP.h
+++ b/textproc/dictfmt/files/patch-dictP.h
@@ -1,19 +0,0 @@
---- dictP.h.orig
-+++ dictP.h
-@@ -99,13 +99,13 @@
- #if HAVE_WINT_T && HAVE_WCHAR_H
- #include <wchar.h>
- #else
--#typedef unsigned int wint_t;
-+typedef unsigned int wint_t;
- #endif
-
--#if !HAVE_WCHAR_T && HAVE_WCHAR_H
-+#if HAVE_WCHAR_T && HAVE_WCHAR_H
- #include <wchar.h>
- #else
--#typedef unsigned int wchar_t;
-+typedef unsigned int wchar_t;
- #endif
-
- #if !HAVE_MBSTATE_T