aboutsummaryrefslogtreecommitdiff
path: root/textproc/diff-mode.el
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-07-06 19:08:39 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-07-06 19:08:39 +0000
commitfb746cf97997cfe2557950a4f951914b454c6872 (patch)
tree506a7db3622bbfeff167a569a04df2d5f6f5d47f /textproc/diff-mode.el
parent4cc79e55092c568efd44f52271728a28aa843d74 (diff)
downloadports-fb746cf97997cfe2557950a4f951914b454c6872.tar.gz
ports-fb746cf97997cfe2557950a4f951914b454c6872.zip
Notes
Diffstat (limited to 'textproc/diff-mode.el')
-rw-r--r--textproc/diff-mode.el/Makefile33
-rw-r--r--textproc/diff-mode.el/distinfo1
-rw-r--r--textproc/diff-mode.el/pkg-comment1
-rw-r--r--textproc/diff-mode.el/pkg-descr15
-rw-r--r--textproc/diff-mode.el/pkg-message4
-rw-r--r--textproc/diff-mode.el/pkg-plist2
6 files changed, 56 insertions, 0 deletions
diff --git a/textproc/diff-mode.el/Makefile b/textproc/diff-mode.el/Makefile
new file mode 100644
index 000000000000..033ffa64ffdd
--- /dev/null
+++ b/textproc/diff-mode.el/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: diff-mode for Emacsen
+# Date created: 18 Apr 2000
+# Whom: OKAZAKI Tetsurou
+#
+# $FreeBSD$
+#
+
+PORTNAME= diff-mode.el
+PORTVERSION= 1.8
+CATEGORIES= textproc elisp
+MASTER_SITES= ftp://rum.cs.yale.edu/pub/monnier/misc/
+DISTNAME= diff-mode-${PORTVERSION}.el
+EXTRACT_SUFX= # empty
+EXTRACT_ONLY= # empty
+
+MAINTAINER= okazaki@be.to
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+EMACSLISPDIR= ${PREFIX}/share/emacs/site-lisp
+XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp
+
+do-install:
+ ${MKDIR} ${EMACSLISPDIR}
+ ${INSTALL_DATA} ${_DISTDIR}/${DISTNAME} ${EMACSLISPDIR}/diff-mode.el
+ ${MKDIR} ${XEMACSLISPDIR}
+ ${LN} -sf ${EMACSLISPDIR}/diff-mode.el ${XEMACSLISPDIR}
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/textproc/diff-mode.el/distinfo b/textproc/diff-mode.el/distinfo
new file mode 100644
index 000000000000..121e29ad618b
--- /dev/null
+++ b/textproc/diff-mode.el/distinfo
@@ -0,0 +1 @@
+MD5 (diff-mode-1.8.el) = e2d92433850500ab5a8494e22f728833
diff --git a/textproc/diff-mode.el/pkg-comment b/textproc/diff-mode.el/pkg-comment
new file mode 100644
index 000000000000..6c0d530ece58
--- /dev/null
+++ b/textproc/diff-mode.el/pkg-comment
@@ -0,0 +1 @@
+A mode for viewing/editing context diffs in Emacsen
diff --git a/textproc/diff-mode.el/pkg-descr b/textproc/diff-mode.el/pkg-descr
new file mode 100644
index 000000000000..47ac41630cb8
--- /dev/null
+++ b/textproc/diff-mode.el/pkg-descr
@@ -0,0 +1,15 @@
+Diff-mode is a major-mode for viewing/editing context diffs in Emacs.
+Supports unified and context diffs as well as (to a lesser extent)
+normal diffs.
+
+The diff-mode provides features such as:
+
+ - Unified diff <-> Context diff conversion.
+ - Reverse the direction of the diffs.
+ - Jump to the corresponding source line.
+ - Move to the next/previous hunk/file header.
+ - Restrict the view to the current hunk/file.
+
+
+- Tetsurou
+okazaki@be.to
diff --git a/textproc/diff-mode.el/pkg-message b/textproc/diff-mode.el/pkg-message
new file mode 100644
index 000000000000..349d4531f18c
--- /dev/null
+++ b/textproc/diff-mode.el/pkg-message
@@ -0,0 +1,4 @@
+To use diff-mode, simply add to your .emacs the following lines:
+
+(autoload 'diff-mode "diff-mode" "Diff major mode" t)
+(add-to-list 'auto-mode-alist '("\\.\\(diffs?\\|patch\\|rej\\)\\'" . diff-mode))
diff --git a/textproc/diff-mode.el/pkg-plist b/textproc/diff-mode.el/pkg-plist
new file mode 100644
index 000000000000..039a5d3f7ac4
--- /dev/null
+++ b/textproc/diff-mode.el/pkg-plist
@@ -0,0 +1,2 @@
+share/emacs/site-lisp/diff-mode.el
+lib/xemacs/site-lisp/diff-mode.el