aboutsummaryrefslogtreecommitdiff
path: root/textproc/diffutils/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-09-17 06:27:56 +0000
committerWill Andrews <will@FreeBSD.org>2001-09-17 06:27:56 +0000
commitcd256ccdc9723e26ea2ee61341a8e4c442ffe6b3 (patch)
tree877bcdbe8655d3a81c4ea8ff9d3921f4cc12541a /textproc/diffutils/Makefile
parent0792cf5b9941662f9e4e1ac3a5d81f7dddf4a781 (diff)
Notes
Diffstat (limited to 'textproc/diffutils/Makefile')
-rw-r--r--textproc/diffutils/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/diffutils/Makefile b/textproc/diffutils/Makefile
new file mode 100644
index 000000000000..feb830ec0999
--- /dev/null
+++ b/textproc/diffutils/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: diffutils
+# Date created: 5 September 2001
+# Whom: Garrett Rooney <rooneg@electricjellyfish.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= diffutils
+PORTVERSION= 2.7
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= diffutils
+
+MAINTAINER= rooneg@electricjellyfish.net
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-prefix=g
+
+INSTALL_INFO?= install-info
+
+post-extract: remove-info-files
+
+remove-info-files:
+ @${RM} -f ${WRKSRC}/${PORTNAME:S/utils//}.info*
+
+post-patch: patch-makeinfo
+
+patch-makeinfo:
+ @${PERL} -pi.fbsd -e 's|makeinfo|makeinfo --no-split|g' \
+ ${WRKSRC}/Makefile.in
+
+post-install: install-info
+
+install-info:
+ @${INSTALL_INFO} ${PREFIX}/info/${PORTNAME:S/utils//}.info ${PREFIX}/info/dir
+
+.include <bsd.port.mk>