aboutsummaryrefslogtreecommitdiff
path: root/textproc/diffutils
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-09-17 06:27:56 +0000
committerWill Andrews <will@FreeBSD.org>2001-09-17 06:27:56 +0000
commitcd256ccdc9723e26ea2ee61341a8e4c442ffe6b3 (patch)
tree877bcdbe8655d3a81c4ea8ff9d3921f4cc12541a /textproc/diffutils
parent0792cf5b9941662f9e4e1ac3a5d81f7dddf4a781 (diff)
downloadports-cd256ccdc9723e26ea2ee61341a8e4c442ffe6b3.tar.gz
ports-cd256ccdc9723e26ea2ee61341a8e4c442ffe6b3.zip
Add diffutils 2.7, the GNU diff utilities.
PR: 30362 Submitted by: Garrett Rooney <rooneg@electricjellyfish.net>
Notes
Notes: svn path=/head/; revision=47904
Diffstat (limited to 'textproc/diffutils')
-rw-r--r--textproc/diffutils/Makefile37
-rw-r--r--textproc/diffutils/distinfo1
-rw-r--r--textproc/diffutils/files/patch-diff.texi21
-rw-r--r--textproc/diffutils/pkg-comment1
-rw-r--r--textproc/diffutils/pkg-descr11
-rw-r--r--textproc/diffutils/pkg-plist8
6 files changed, 79 insertions, 0 deletions
diff --git a/textproc/diffutils/Makefile b/textproc/diffutils/Makefile
new file mode 100644
index 000000000000..feb830ec0999
--- /dev/null
+++ b/textproc/diffutils/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: diffutils
+# Date created: 5 September 2001
+# Whom: Garrett Rooney <rooneg@electricjellyfish.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= diffutils
+PORTVERSION= 2.7
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= diffutils
+
+MAINTAINER= rooneg@electricjellyfish.net
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-prefix=g
+
+INSTALL_INFO?= install-info
+
+post-extract: remove-info-files
+
+remove-info-files:
+ @${RM} -f ${WRKSRC}/${PORTNAME:S/utils//}.info*
+
+post-patch: patch-makeinfo
+
+patch-makeinfo:
+ @${PERL} -pi.fbsd -e 's|makeinfo|makeinfo --no-split|g' \
+ ${WRKSRC}/Makefile.in
+
+post-install: install-info
+
+install-info:
+ @${INSTALL_INFO} ${PREFIX}/info/${PORTNAME:S/utils//}.info ${PREFIX}/info/dir
+
+.include <bsd.port.mk>
diff --git a/textproc/diffutils/distinfo b/textproc/diffutils/distinfo
new file mode 100644
index 000000000000..b600335a67f1
--- /dev/null
+++ b/textproc/diffutils/distinfo
@@ -0,0 +1 @@
+MD5 (diffutils-2.7.tar.gz) = 300d86a0566afee1c3756828f6c9538a
diff --git a/textproc/diffutils/files/patch-diff.texi b/textproc/diffutils/files/patch-diff.texi
new file mode 100644
index 000000000000..50a0e45ee30a
--- /dev/null
+++ b/textproc/diffutils/files/patch-diff.texi
@@ -0,0 +1,21 @@
+--- diff.texi.orig Fri Sep 30 21:54:40 1994
++++ diff.texi Sat Sep 8 16:56:14 2001
+@@ -6,6 +6,18 @@
+ @c %**end of header
+
+ @ifinfo
++@format
++INFO-DIR-SECTION Comparing and Merging Files
++START-INFO-DIR-ENTRY
++* Comparing files: (diff). Comparing and Merging Files.
++* cmp: (diff)cmp invocation. Compares two files.
++* diff: (diff)diff invocation. Pretty compares two files.
++* diff3: (diff)diff3 invocation. Compares and Merges three files.
++* patch: (diff)patch invocation. Apply a diff file to an original
++* sdiff: (diff)sdiff invocation. Interactively compares two files
++END-INFO-DIR-ENTRY
++@end format
++
+ This file documents the the GNU @code{diff}, @code{diff3}, @code{sdiff},
+ and @code{cmp} commands for showing the differences between text files
+ and the @code{patch} command for using their output to update files.
diff --git a/textproc/diffutils/pkg-comment b/textproc/diffutils/pkg-comment
new file mode 100644
index 000000000000..128be741d300
--- /dev/null
+++ b/textproc/diffutils/pkg-comment
@@ -0,0 +1 @@
+The GNU diff utilities
diff --git a/textproc/diffutils/pkg-descr b/textproc/diffutils/pkg-descr
new file mode 100644
index 000000000000..69c37cadb231
--- /dev/null
+++ b/textproc/diffutils/pkg-descr
@@ -0,0 +1,11 @@
+The Free Software Foundation's "diff" utilities, including "diff",
+"diff3", "sdiff", and "cmp".
+
+These utilities exist in the FreeBSD base collection, but the GNU
+versions have added functionality that is sometimes useful.
+
+Note that this port will install these utilities with a `g' prefix,
+for example gdiff, gdiff3, ggcmp, but the texinfo documentation
+will refer to these utilities without the `g' prefix.
+
+WWW: http://www.gnu.org/software/diffutils/diffutils.html
diff --git a/textproc/diffutils/pkg-plist b/textproc/diffutils/pkg-plist
new file mode 100644
index 000000000000..f1014b5e7f98
--- /dev/null
+++ b/textproc/diffutils/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+bin/gcmp
+bin/gdiff
+bin/gdiff3
+bin/gsdiff
+@unexec install-info --quiet --delete %D/info/diff.info %D/info/dir
+info/diff.info
+@exec install-info %D/info/diff.info %D/info/dir