aboutsummaryrefslogtreecommitdiff
path: root/textproc/dikt/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-05-06 22:57:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-05-06 22:57:10 +0000
commit7df2f9013f418098fd89490be88af8297ca1f0ba (patch)
treebe0ea402293c35b607a86fe9d8923d517812aa12 /textproc/dikt/Makefile
parent00e194c613053e195c6394f5a92a173d0f95c650 (diff)
Notes
Diffstat (limited to 'textproc/dikt/Makefile')
-rw-r--r--textproc/dikt/Makefile29
1 files changed, 17 insertions, 12 deletions
diff --git a/textproc/dikt/Makefile b/textproc/dikt/Makefile
index 0eb65e6e742b..512393785f00 100644
--- a/textproc/dikt/Makefile
+++ b/textproc/dikt/Makefile
@@ -2,25 +2,30 @@
# $FreeBSD$
PORTNAME= dikt
-PORTVERSION= 2l3
-PORTREVISION= 2
+PORTVERSION= 0.20161228
+PORTEPOCH= 1
CATEGORIES= textproc net kde
MASTER_SITES= https://bitbucket.org/dikt/code/downloads/
+DISTNAME= ${PORTNAME}-2s1
MAINTAINER= goran.tal@gmail.com
-COMMENT= Dictionary for KDE4
+COMMENT= Dictionary for KDE
-USES= cmake kde:4 tar:txz
-USE_KDE= kdelibs automoc4
-USE_QT4= corelib gui network svg xml \
- qmake_build moc_build rcc_build uic_build
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake:outsource kde:5 tar:txz
+USE_KDE= auth bookmarks codecs completion config configwidgets coreaddons dbusaddons guiaddons i18n \
+ iconthemes itemviews jobwidgets kio service solid widgetsaddons xmlgui
+USE_QT5= concurrent core dbus gui network printsupport svg widgets xml \
+ buildtools_build qmake_build
PLIST_FILES= bin/dikt \
- share/applications/kde4/dikt.desktop \
- share/apps/dikt/diktui.rc \
- share/apps/dikt/dikt.css \
- share/apps/dikt/format.conf \
+ share/applications/dikt.desktop \
+ share/dikt/dikt.css \
+ share/dikt/format.conf \
share/icons/hicolor/128x128/apps/dikt.png \
- share/kde4/services/dict.protocol
+ share/kservices5/dict.protocol \
+ share/kxmlgui5/dikt/diktui.rc
.include <bsd.port.mk>