aboutsummaryrefslogtreecommitdiff
path: root/textproc/docbook-430
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-03 21:23:22 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-03 21:23:22 +0000
commitad9651ef99099c464eb09bb08226f750b443ac93 (patch)
tree161b8da5366ce877fcb40fb811594994eb2cee41 /textproc/docbook-430
parentd8f51f769f48323ef7ba703bae3123f9158f42bf (diff)
downloadports-ad9651ef99099c464eb09bb08226f750b443ac93.tar.gz
ports-ad9651ef99099c464eb09bb08226f750b443ac93.zip
Notes
Diffstat (limited to 'textproc/docbook-430')
-rw-r--r--textproc/docbook-430/Makefile74
-rw-r--r--textproc/docbook-430/distinfo2
-rw-r--r--textproc/docbook-430/files/patch-catalog68
-rw-r--r--textproc/docbook-430/pkg-descr15
4 files changed, 159 insertions, 0 deletions
diff --git a/textproc/docbook-430/Makefile b/textproc/docbook-430/Makefile
new file mode 100644
index 000000000000..a3a9277a1a08
--- /dev/null
+++ b/textproc/docbook-430/Makefile
@@ -0,0 +1,74 @@
+# New ports collection makefile for: docbook-430
+# Date created: 02 Apr 2004
+# Whom: hrs
+#
+# $FreeBSD$
+
+PORTNAME= docbook
+PORTVERSION= 4.3
+CATEGORIES= textproc
+MASTER_SITES= http://docbook.org/sgml/${PORTVERSION}/
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= DocBook/SGML DTD V4.3, designed for technical documentation
+
+RUN_DEPENDS= ${LOCALBASE}/${ISOCAT}:${PORTSDIR}/textproc/iso8879 \
+ ${XMLCATMGR}:${PORTSDIR}/textproc/xmlcatmgr
+
+USE_ZIP= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+LATEST_LINK= ${PORTNAME}-430
+PLIST= ${WRKSRC}/pkg-plist
+
+SGMLCATBASE= share/sgml
+DTD_NAME= ${PORTNAME}
+DTD_VERSION= ${PORTVERSION}
+ISOCAT= ${SGMLCATBASE}/iso8879/catalog
+
+XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
+CATALOG_PORTS_SGML= ${PREFIX}/${SGMLCATBASE}/catalog.ports
+REGIST_CAT_FLAGS_SGML= -sc ${CATALOG_PORTS_SGML} \
+ add CATALOG ${DTD_NAME}/${DTD_VERSION}/catalog
+UNREGIST_CAT_FLAGS_SGML= -sc ${CATALOG_PORTS_SGML} \
+ remove CATALOG ${DTD_NAME}/${DTD_VERSION}/catalog
+
+DOC_FILES= ChangeLog README
+DTDDIR= ${SGMLCATBASE}/${DTD_NAME}/${DTD_VERSION}
+DTD_FILES= calstblx.dtd catalog.xml dbcentx.mod dbgenent.mod \
+ dbhierx.mod dbnotnx.mod dbpoolx.mod docbook.cat docbook.dcl \
+ docbook.dtd docbookx.dtd htmltblx.mod soextblx.dtd catalog
+
+post-extract:
+ ${CP} ${WRKSRC}/docbook.cat ${WRKSRC}/catalog
+
+post-patch:
+ ${ECHO_CMD} 'CATALOG "${LOCALBASE}/${ISOCAT}"' >> ${WRKSRC}/catalog
+
+pre-install:
+ (for F in ${DTD_FILES}; do \
+ ${ECHO_CMD} "${DTDDIR}/$${F}"; \
+ done;\
+ ${ECHO_CMD} "@dirrm ${DTDDIR}";\
+ ${ECHO_CMD} "@unexec rmdir %D/${SGMLCATBASE}/${DTD_NAME} 2> /dev/null || true"; ) > ${PLIST}
+.if !defined(NOPORTDOCS)
+ (for F in ${DOC_FILES}; do \
+ ${ECHO_CMD} "${DOCSDIR:S,^${PREFIX}/,,}/$${F}"; \
+ done;\
+ ${ECHO_CMD} "@dirrm ${DOCSDIR:S,^${PREFIX}/,,}" ) >> ${PLIST}
+.endif
+ ${ECHO_CMD} "@exec ${XMLCATMGR} ${REGIST_CAT_FLAGS_SGML}" >> ${PLIST}
+ ${ECHO_CMD} "@unexec ${XMLCATMGR} ${UNREGIST_CAT_FLAGS_SGML}" >> ${PLIST}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${DTDDIR}
+ ${INSTALL_DATA} ${DTD_FILES:S,^,${WRKSRC}/,} ${PREFIX}/${DTDDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DOC_FILES:S,^,${WRKSRC}/,} ${DOCSDIR}
+.endif
+
+post-install:
+ -${XMLCATMGR} ${REGIST_CAT_FLAGS_SGML}
+
+.include <bsd.port.mk>
diff --git a/textproc/docbook-430/distinfo b/textproc/docbook-430/distinfo
new file mode 100644
index 000000000000..c27224acb625
--- /dev/null
+++ b/textproc/docbook-430/distinfo
@@ -0,0 +1,2 @@
+MD5 (docbook-4.3.zip) = e3beb1b0b2923c24fa55a68e88654b01
+SIZE (docbook-4.3.zip) = 66117
diff --git a/textproc/docbook-430/files/patch-catalog b/textproc/docbook-430/files/patch-catalog
new file mode 100644
index 000000000000..65fff5bd2eb7
--- /dev/null
+++ b/textproc/docbook-430/files/patch-catalog
@@ -0,0 +1,68 @@
+--- catalog.orig Sat Apr 3 19:51:36 2004
++++ catalog Sat Apr 3 19:52:15 2004
+@@ -49,65 +49,5 @@
+ PUBLIC "-//OASIS//ENTITIES DocBook Character Entities V4.3//EN"
+ "dbcentx.mod"
+
+- -- ...................................................................... --
+- -- ISO entity sets ...................................................... --
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Diacritical Marks//EN"
+- "iso-dia.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Numeric and Special Graphic//EN"
+- "iso-num.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Publishing//EN"
+- "iso-pub.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES General Technical//EN"
+- "iso-tech.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Latin 1//EN"
+- "iso-lat1.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Latin 2//EN"
+- "iso-lat2.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Greek Letters//EN"
+- "iso-grk1.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Monotoniko Greek//EN"
+- "iso-grk2.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Greek Symbols//EN"
+- "iso-grk3.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Alternative Greek Symbols//EN"
+- "iso-grk4.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Arrow Relations//EN"
+- "iso-amsa.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Binary Operators//EN"
+- "iso-amsb.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Delimiters//EN"
+- "iso-amsc.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Negated Relations//EN"
+- "iso-amsn.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Ordinary//EN"
+- "iso-amso.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Added Math Symbols: Relations//EN"
+- "iso-amsr.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Box and Line Drawing//EN"
+- "iso-box.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Russian Cyrillic//EN"
+- "iso-cyr1.gml"
+-
+-PUBLIC "ISO 8879:1986//ENTITIES Non-Russian Cyrillic//EN"
+- "iso-cyr2.gml"
+-
+ -- End of catalog data for DocBook V4.3 ................................. --
+ -- ...................................................................... --
diff --git a/textproc/docbook-430/pkg-descr b/textproc/docbook-430/pkg-descr
new file mode 100644
index 000000000000..a02fa1c9099a
--- /dev/null
+++ b/textproc/docbook-430/pkg-descr
@@ -0,0 +1,15 @@
+The DocBook DTD defines structural and content-based SGML markup
+for computer documentation, with a primary emphasis on software
+documentation and related classes of technical documents. Its
+main high-level hierarchical structures are for books, reference
+entries (for example, ``man pages''), and articles. It is
+maintained by the DocBook Technical Committee of OASIS.
+
+This port contains DocBook 4.3. Note that DocBook 4.3 includes
+the XML DocBook DTD as part of the SGML DTD distribution. If
+you do not need SGML DTD you should install:
+ textproc/docbook-xml-430
+instead. There are no conflicts if both ports are installed
+but you will have duplicates of most of the files.
+
+WWW: http://www.docbook.org/sgml/4.3/index.html