aboutsummaryrefslogtreecommitdiff
path: root/textproc/docbook-to-man/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-07 16:33:04 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-10-07 16:33:04 +0000
commitb054015461968443cd97fe23ac07a7c3853bf6b9 (patch)
treee0f995e2205d5710eade5728be2891378a366c6a /textproc/docbook-to-man/Makefile
parent6ecd568c10c195f3963bb0579ab8957593c24406 (diff)
downloadports-b054015461968443cd97fe23ac07a7c3853bf6b9.tar.gz
ports-b054015461968443cd97fe23ac07a7c3853bf6b9.zip
Notes
Diffstat (limited to 'textproc/docbook-to-man/Makefile')
-rw-r--r--textproc/docbook-to-man/Makefile70
1 files changed, 70 insertions, 0 deletions
diff --git a/textproc/docbook-to-man/Makefile b/textproc/docbook-to-man/Makefile
new file mode 100644
index 000000000000..21700879af87
--- /dev/null
+++ b/textproc/docbook-to-man/Makefile
@@ -0,0 +1,70 @@
+# New ports collection makefile for: gnupg-devel
+# Date created: 5 Oct 2001
+# Whom: Cyrille Lefevre <clefevre@citeweb.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= docbook-to-man
+PORTVERSION= 1.0
+CATEGORIES= textproc
+MASTER_SITES= http://www.oasis-open.org/docbook/tools/dtm/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= clefevre@citeweb.net
+
+.include <bsd.port.pre.mk>
+
+# Global variables
+#
+
+# There are two ports that satisfy the nsgmls requirement.
+# Jade is preferred, but it currently doesn't compile on 2.1.x
+# system, so use sp in that case.
+
+.if ${MACHINE_ARCH} == "alpha"
+WITH_OPENJADE= yes
+.endif
+
+.if ${OSVERSION} < 220000
+RUN_DEPENDS= nsgmls:${PORTSDIR}/textproc/sp
+.elif defined(WITH_OPENJADE)
+RUN_DEPENDS= onsgmls:${PORTSDIR}/textproc/openjade
+.else
+RUN_DEPENDS= nsgmls:${PORTSDIR}/textproc/jade
+.endif
+RUN_DEPENDS+= ${LOCALBASE}/share/sgml/docbook:${PORTSDIR}/textproc/docbook
+
+USE_IMAKE= yes
+USE_X_PREFIX= no
+XFREE86_HTML_MAN= no
+
+MAN1= oinstant.1
+
+# Local variables
+#
+
+.if defined(WITH_OPENJADE)
+NSGMLS= onsgmls
+.else
+NSGMLS= nsgmls
+.endif
+
+# Post extract
+#
+
+post-extract: move-instant.1
+
+move-instant.1:
+ @${MV} ${WRKSRC}/Doc/instant.1 ${WRKSRC}/Instant/oinstant.man
+
+# Post patch
+#
+
+post-patch: patch-docbook-to-man
+
+patch-docbook-to-man:
+ @${PERL} -pi.fbsd -e 's|%%PREFIX%%|${PREFIX}|;s|%%NSGMLS%%|${NSGMLS}|' \
+ ${WRKSRC}/cmd/docbook-to-man.sh
+
+.include <bsd.port.post.mk>