aboutsummaryrefslogtreecommitdiff
path: root/textproc/docbook-utils
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-11-10 02:57:36 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-11-10 02:57:36 +0000
commit3aa51278a5cb780aa2d33d0ff4e7586d481fad27 (patch)
tree611a5903207d346f58144cebb7dabbf3e6c22f81 /textproc/docbook-utils
parentae45b6d23784c5439ff666355f6c6327aa110922 (diff)
downloadports-3aa51278a5cb780aa2d33d0ff4e7586d481fad27.tar.gz
ports-3aa51278a5cb780aa2d33d0ff4e7586d481fad27.zip
Notes
Diffstat (limited to 'textproc/docbook-utils')
-rw-r--r--textproc/docbook-utils/Makefile45
-rw-r--r--textproc/docbook-utils/distinfo3
-rw-r--r--textproc/docbook-utils/files/patch-backends_txt26
-rw-r--r--textproc/docbook-utils/files/patch-bin_jw.in21
-rw-r--r--textproc/docbook-utils/files/patch-configure11
-rw-r--r--textproc/docbook-utils/files/patch-configure.in11
-rw-r--r--textproc/docbook-utils/files/patch-doc_HTML_Makefile.am12
-rw-r--r--textproc/docbook-utils/files/patch-doc_HTML_Makefile.in12
-rw-r--r--textproc/docbook-utils/files/patch-doc_man_Makefile.am12
-rw-r--r--textproc/docbook-utils/files/patch-doc_man_Makefile.in12
-rw-r--r--textproc/docbook-utils/files/patch-doc_refentry_frontend-spec.sgml21
-rw-r--r--textproc/docbook-utils/files/patch-doc_refentry_jw.sgml24
-rw-r--r--textproc/docbook-utils/pkg-descr5
-rw-r--r--textproc/docbook-utils/pkg-plist28
14 files changed, 243 insertions, 0 deletions
diff --git a/textproc/docbook-utils/Makefile b/textproc/docbook-utils/Makefile
new file mode 100644
index 000000000000..9e2452d4c245
--- /dev/null
+++ b/textproc/docbook-utils/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: docbook-utils
+# Date created: 3 May 2004
+# Whom: Brian Candler <B.Candler@pobox.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= docbook-utils
+PORTVERSION= 0.6.14
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
+MASTER_SITE_SUBDIR= docbook-tools/new-trials/SOURCES
+
+MAINTAINER= B.Candler@pobox.com
+COMMENT= Generates various output formats from DocBook SGML documents
+
+BUILD_DEPENDS+= nsgmls:${PORTSDIR}/textproc/jade \
+ ${LOCALBASE}/share/sgml/docbook/3.1/docbook.dtd:${PORTSDIR}/textproc/docbook-310 \
+ ${LOCALBASE}/share/sgml/docbook/dsssl:${PORTSDIR}/textproc/dsssl-docbook-modular
+RUN_DEPENDS+= ${LOCALBASE}/share/texmf/tex/jadetex/dsssl.def:${PORTSDIR}/print/jadetex \
+ sgmlspl:${PORTSDIR}/textproc/p5-SGMLSpm
+
+USE_PERL5_RUN= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+MAN1= jw.1 sgmldiff.1 docbook2man-spec.pl.1 docbook2texi-spec.pl.1
+MAN7= backend-spec.7 frontend-spec.7
+MLINKS= jw.1 docbook2dvi.1 \
+ jw.1 docbook2html.1 \
+ jw.1 docbook2man.1 \
+ jw.1 docbook2pdf.1 \
+ jw.1 docbook2ps.1 \
+ jw.1 docbook2rtf.1 \
+ jw.1 docbook2tex.1 \
+ jw.1 docbook2texi.1 \
+ jw.1 docbook2txt.1
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+pre-configure:
+ ${RM} -f ${WRKSRC}/config.cache
+
+.include <bsd.port.mk>
diff --git a/textproc/docbook-utils/distinfo b/textproc/docbook-utils/distinfo
new file mode 100644
index 000000000000..25ce05ca8afb
--- /dev/null
+++ b/textproc/docbook-utils/distinfo
@@ -0,0 +1,3 @@
+MD5 (docbook-utils-0.6.14.tar.gz) = 6b41b18c365c01f225bc417cf632d81c
+SHA256 (docbook-utils-0.6.14.tar.gz) = 48faab8ee8a7605c9342fb7b906e0815e3cee84a489182af38e8f7c0df2e92e9
+SIZE (docbook-utils-0.6.14.tar.gz) = 124998
diff --git a/textproc/docbook-utils/files/patch-backends_txt b/textproc/docbook-utils/files/patch-backends_txt
new file mode 100644
index 000000000000..ec07201c1747
--- /dev/null
+++ b/textproc/docbook-utils/files/patch-backends_txt
@@ -0,0 +1,26 @@
+--- ../docbook-utils-0.6.14.orig/backends/txt Wed Feb 11 13:58:03 2004
++++ backends/txt Tue May 4 09:29:54 2004
+@@ -2,17 +2,17 @@
+ # Send any comments to Eric Bischoff <eric@caldera.de>
+ # This program is under GPL license. See LICENSE file for details.
+
+-if [ -x /usr/bin/lynx ]
++if [ -x /usr/local/bin/lynx ]
+ then
+- CONVERT=/usr/bin/lynx
++ CONVERT=/usr/local/bin/lynx
+ ARGS="-force_html -dump -nolist -width=72"
+-elif [ -x /usr/bin/links ]
++elif [ -x /usr/local/bin/links ]
+ then
+- CONVERT=/usr/bin/links
++ CONVERT=/usr/local/bin/links
+ ARGS="-dump"
+-elif [ -x /usr/bin/w3m ]
++elif [ -x /usr/local/bin/w3m ]
+ then
+- CONVERT=/usr/bin/w3m
++ CONVERT=/usr/local/bin/w3m
+ ARGS="-dump"
+ else
+ echo >&2 "No way to convert HTML to text found."
diff --git a/textproc/docbook-utils/files/patch-bin_jw.in b/textproc/docbook-utils/files/patch-bin_jw.in
new file mode 100644
index 000000000000..a650062e6646
--- /dev/null
+++ b/textproc/docbook-utils/files/patch-bin_jw.in
@@ -0,0 +1,21 @@
+--- ../docbook-utils-0.6.14.orig/bin/jw.in Wed Apr 30 17:21:49 2003
++++ bin/jw.in Mon May 3 20:11:56 2004
+@@ -63,7 +63,7 @@
+ then
+ SGML_CONF=`sgmlwhich`
+ else
+- SGML_CONF="/etc/sgml/sgml.conf"
++ SGML_CONF="@prefix@/etc/sgml.conf"
+ fi
+
+ # Set version message
+@@ -77,7 +77,7 @@
+
+ # Set SGML base directory and centralized catalogs directory
+ SGML_BASE_DIR="@prefix@/share/sgml"
+-SGML_CATALOGS_DIR="/etc/sgml"
++SGML_CATALOGS_DIR="@prefix@/share/sgml"
+ if [ -f "$SGML_CONF" ]
+ then
+ RE='^[:space:]*SGML_BASE_DIR[:space:]*=[:space:]*'
+diff -uNr ../docbook-utils-0.6.14.orig/doc/HTML/Makefile.am ./doc/HTML/Makefile.am
diff --git a/textproc/docbook-utils/files/patch-configure b/textproc/docbook-utils/files/patch-configure
new file mode 100644
index 000000000000..acc436148dd4
--- /dev/null
+++ b/textproc/docbook-utils/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure Wed Feb 11 14:16:10 2004
++++ configure Tue May 4 08:53:49 2004
+@@ -1649,7 +1649,7 @@
+
+
+
+-docdir='$(prefix)/doc'
++docdir='$(prefix)/share/doc'
+
+
+ jade_bindirs="/usr/bin /usr/local/bin"
diff --git a/textproc/docbook-utils/files/patch-configure.in b/textproc/docbook-utils/files/patch-configure.in
new file mode 100644
index 000000000000..3192e4b17a11
--- /dev/null
+++ b/textproc/docbook-utils/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in Wed Feb 11 14:14:15 2004
++++ configure.in Tue May 4 08:53:58 2004
+@@ -16,7 +16,7 @@
+
+ AM_INIT_AUTOMAKE(docbook-utils, 0.6.14)
+
+-docdir='$(prefix)/doc'
++docdir='$(prefix)/share/doc'
+ AC_SUBST(docdir)
+
+ dnl Checks for programs.
diff --git a/textproc/docbook-utils/files/patch-doc_HTML_Makefile.am b/textproc/docbook-utils/files/patch-doc_HTML_Makefile.am
new file mode 100644
index 000000000000..023ca1594acd
--- /dev/null
+++ b/textproc/docbook-utils/files/patch-doc_HTML_Makefile.am
@@ -0,0 +1,12 @@
+--- ../docbook-utils-0.6.14.orig/doc/HTML/Makefile.am Mon Apr 22 12:48:20 2002
++++ doc/HTML/Makefile.am Mon May 3 20:12:44 2004
+@@ -23,7 +23,7 @@
+ $(top_srcdir)/doc/refentry/docbook2texi-spec.pl.sgml \
+ $(top_srcdir)/doc/refentry/frontend-spec.sgml \
+ $(top_srcdir)/doc/refentry/sgmldiff.sgml
+- SGML_CATALOG_FILES=/etc/sgml/catalog \
++ SGML_CATALOG_FILES=$(prefix)/share/sgml/catalog \
+ SGML_SEARCH_PATH=$(top_srcdir):$(top_srcdir)/doc:.. \
+ jade -t sgml -i html -d $(top_srcdir)/docbook-utils.dsl\#html \
+ -V '%use-id-as-filename%' $<
+diff -uNr ../docbook-utils-0.6.14.orig/doc/HTML/Makefile.in ./doc/HTML/Makefile.in
diff --git a/textproc/docbook-utils/files/patch-doc_HTML_Makefile.in b/textproc/docbook-utils/files/patch-doc_HTML_Makefile.in
new file mode 100644
index 000000000000..008a005b0391
--- /dev/null
+++ b/textproc/docbook-utils/files/patch-doc_HTML_Makefile.in
@@ -0,0 +1,12 @@
+--- ../docbook-utils-0.6.14.orig/doc/HTML/Makefile.in Wed Feb 11 14:16:07 2004
++++ doc/HTML/Makefile.in Mon May 3 20:12:37 2004
+@@ -297,7 +297,7 @@
+ $(top_srcdir)/doc/refentry/docbook2texi-spec.pl.sgml \
+ $(top_srcdir)/doc/refentry/frontend-spec.sgml \
+ $(top_srcdir)/doc/refentry/sgmldiff.sgml
+- SGML_CATALOG_FILES=/etc/sgml/catalog \
++ SGML_CATALOG_FILES=$(prefix)/share/sgml/catalog \
+ SGML_SEARCH_PATH=$(top_srcdir):$(top_srcdir)/doc:.. \
+ jade -t sgml -i html -d $(top_srcdir)/docbook-utils.dsl\#html \
+ -V '%use-id-as-filename%' $<
+diff -uNr ../docbook-utils-0.6.14.orig/doc/man/Makefile.am ./doc/man/Makefile.am
diff --git a/textproc/docbook-utils/files/patch-doc_man_Makefile.am b/textproc/docbook-utils/files/patch-doc_man_Makefile.am
new file mode 100644
index 000000000000..c6d42f661658
--- /dev/null
+++ b/textproc/docbook-utils/files/patch-doc_man_Makefile.am
@@ -0,0 +1,12 @@
+--- ../docbook-utils-0.6.14.orig/doc/man/Makefile.am Thu Jun 27 12:37:07 2002
++++ doc/man/Makefile.am Mon May 3 20:13:23 2004
+@@ -10,7 +10,7 @@
+
+ $(man1_MANS) $(man7_MANS): $(top_srcdir)/doc/docbook-utils.sgml \
+ $(top_srcdir)/helpers/docbook2man-spec.pl
+- SGML_CATALOG_FILES=/etc/sgml/catalog \
++ SGML_CATALOG_FILES=$(prefix)/share/sgml/catalog \
+ SGML_SEARCH_PATH=$(top_srcdir)/doc:.. \
+ nsgmls $< | \
+ sgmlspl $(top_srcdir)/helpers/docbook2man-spec.pl
+diff -uNr ../docbook-utils-0.6.14.orig/doc/man/Makefile.in ./doc/man/Makefile.in
diff --git a/textproc/docbook-utils/files/patch-doc_man_Makefile.in b/textproc/docbook-utils/files/patch-doc_man_Makefile.in
new file mode 100644
index 000000000000..273d0e2aea48
--- /dev/null
+++ b/textproc/docbook-utils/files/patch-doc_man_Makefile.in
@@ -0,0 +1,12 @@
+--- ../docbook-utils-0.6.14.orig/doc/man/Makefile.in Wed Feb 11 14:16:08 2004
++++ doc/man/Makefile.in Mon May 3 20:13:13 2004
+@@ -356,7 +356,7 @@
+
+ $(man1_MANS) $(man7_MANS): $(top_srcdir)/doc/docbook-utils.sgml \
+ $(top_srcdir)/helpers/docbook2man-spec.pl
+- SGML_CATALOG_FILES=/etc/sgml/catalog \
++ SGML_CATALOG_FILES=$(prefix)/share/sgml/catalog \
+ SGML_SEARCH_PATH=$(top_srcdir)/doc:.. \
+ nsgmls $< | \
+ sgmlspl $(top_srcdir)/helpers/docbook2man-spec.pl
+diff -uNr ../docbook-utils-0.6.14.orig/doc/refentry/frontend-spec.sgml ./doc/refentry/frontend-spec.sgml
diff --git a/textproc/docbook-utils/files/patch-doc_refentry_frontend-spec.sgml b/textproc/docbook-utils/files/patch-doc_refentry_frontend-spec.sgml
new file mode 100644
index 000000000000..4506ad515d6f
--- /dev/null
+++ b/textproc/docbook-utils/files/patch-doc_refentry_frontend-spec.sgml
@@ -0,0 +1,21 @@
+--- ../docbook-utils-0.6.14.orig/doc/refentry/frontend-spec.sgml Thu Nov 9 22:06:23 2000
++++ doc/refentry/frontend-spec.sgml Mon May 3 20:14:10 2004
+@@ -51,7 +51,7 @@
+ <term>centralized-catalog</term>
+ <listitem><para>The frontend must return the DTD-specific
+ centralized catalog name. Centralized catalogs normally
+- reside in <filename>/etc/sgml</filename> and provide the
++ reside in <filename>/usr/local/share/sgml</filename> and provide the
+ location of all the catalog files useful for handling
+ this input type (the catalog for the DTD, the catalog
+ for the stylesheets, the catalog for the entities,
+@@ -78,7 +78,7 @@
+ </glossterm>
+ <glossdef>
+ <para>The directory where the centralized catalogs reside. It is normally
+- <filename>/etc/sgml</filename>.</para>
++ <filename>/usr/local/share/sgml</filename>.</para>
+ <para>(This variable is valid only while determining
+ the centralized catalog to use.)</para>
+ </glossdef>
+diff -uNr ../docbook-utils-0.6.14.orig/doc/refentry/jw.sgml ./doc/refentry/jw.sgml
diff --git a/textproc/docbook-utils/files/patch-doc_refentry_jw.sgml b/textproc/docbook-utils/files/patch-doc_refentry_jw.sgml
new file mode 100644
index 000000000000..dbbc11a22d9b
--- /dev/null
+++ b/textproc/docbook-utils/files/patch-doc_refentry_jw.sgml
@@ -0,0 +1,24 @@
+--- ../docbook-utils-0.6.14.orig/doc/refentry/jw.sgml Mon Oct 21 16:54:35 2002
++++ doc/refentry/jw.sgml Mon May 3 20:15:26 2004
+@@ -371,10 +371,10 @@
+ <para>if the centralized catalog exists, then
+ use it. The centralized catalog is a list of all
+ catalogs that might be necessary that usually
+- resides in <filename>/etc/sgml</filename>. Its
++ resides in <filename>/usr/local/share/sgml</filename>. Its
+ name is provided by the frontend, for example
+ the <filename>docbook</filename> frontend returns
+- <filename>/etc/sgml/sgml-docbook.cat</filename>.</para>
++ <filename>/usr/local/share/sgml/sgml-docbook.cat</filename>.</para>
+ </listitem>
+ <listitem>
+ <para>Otherwise, take all the files
+@@ -583,7 +583,7 @@
+ <variablelist>
+
+ <varlistentry>
+- <term><filename>/etc/sgml/sgml-docbook.cat</filename></term>
++ <term><filename>/usr/local/share/sgml/sgml-docbook.cat</filename></term>
+ <listitem>
+ <para>Centralized SGML open catalog. This file name might
+ vary if another frontend than <filename>docbook</filename>
diff --git a/textproc/docbook-utils/pkg-descr b/textproc/docbook-utils/pkg-descr
new file mode 100644
index 000000000000..b5d1b87886e5
--- /dev/null
+++ b/textproc/docbook-utils/pkg-descr
@@ -0,0 +1,5 @@
+docbook-utils contains scripts for easy conversion from DocBook SGML
+files to other formats (for example, HTML, RTF, and PostScript), and
+for comparing SGML files.
+
+WWW: http://sources.redhat.com/docbook-tools/
diff --git a/textproc/docbook-utils/pkg-plist b/textproc/docbook-utils/pkg-plist
new file mode 100644
index 000000000000..38f698624ce2
--- /dev/null
+++ b/textproc/docbook-utils/pkg-plist
@@ -0,0 +1,28 @@
+bin/docbook2dvi
+bin/docbook2html
+bin/docbook2man
+bin/docbook2pdf
+bin/docbook2ps
+bin/docbook2rtf
+bin/docbook2tex
+bin/docbook2texi
+bin/docbook2txt
+bin/jw
+bin/sgmldiff
+share/sgml/docbook/utils-0.6.14/backends/dvi
+share/sgml/docbook/utils-0.6.14/backends/html
+share/sgml/docbook/utils-0.6.14/backends/man
+share/sgml/docbook/utils-0.6.14/backends/pdf
+share/sgml/docbook/utils-0.6.14/backends/ps
+share/sgml/docbook/utils-0.6.14/backends/rtf
+share/sgml/docbook/utils-0.6.14/backends/tex
+share/sgml/docbook/utils-0.6.14/backends/texi
+share/sgml/docbook/utils-0.6.14/backends/txt
+share/sgml/docbook/utils-0.6.14/frontends/docbook
+share/sgml/docbook/utils-0.6.14/helpers/docbook2man-spec.pl
+share/sgml/docbook/utils-0.6.14/helpers/docbook2texi-spec.pl
+share/sgml/docbook/utils-0.6.14/docbook-utils.dsl
+@dirrm share/sgml/docbook/utils-0.6.14/backends
+@dirrm share/sgml/docbook/utils-0.6.14/frontends
+@dirrm share/sgml/docbook/utils-0.6.14/helpers
+@dirrm share/sgml/docbook/utils-0.6.14