aboutsummaryrefslogtreecommitdiff
path: root/textproc/docbook-xsd/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-11 03:31:08 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-02-11 03:31:08 +0000
commit9374797a8e074427eb240dab91b64819b7f939c1 (patch)
tree4c9fa850bc68ede71edcf91632657fca26a9cc6b /textproc/docbook-xsd/Makefile
parent82affe8f1796f85bc87f38943473b51da0fecd07 (diff)
downloadports-9374797a8e074427eb240dab91b64819b7f939c1.tar.gz
ports-9374797a8e074427eb240dab91b64819b7f939c1.zip
Notes
Diffstat (limited to 'textproc/docbook-xsd/Makefile')
-rw-r--r--textproc/docbook-xsd/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/textproc/docbook-xsd/Makefile b/textproc/docbook-xsd/Makefile
new file mode 100644
index 000000000000..80d8215f9648
--- /dev/null
+++ b/textproc/docbook-xsd/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: docbook-xsd
+# Date created: Feb 9, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= docbook-xsd
+PORTVERSION= 1.0.b1
+CATEGORIES= textproc
+MASTER_SITES= http://www.oasis-open.org/committees/docbook/xmlschema/${PORTVERSION:S/.b/b/}/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/b/}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= DocBook W3C XML Schema
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${DATADIR}
+ @${CP} ${WRKSRC}/*.xsd ${DATADIR}
+ @${FIND} ${DATADIR} -type f | \
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${DATADIR} -type d | ${SORT} -r | \
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+
+.include <bsd.port.mk>