aboutsummaryrefslogtreecommitdiff
path: root/textproc/docbookide.el/Makefile
diff options
context:
space:
mode:
authorYoichi NAKAYAMA <yoichi@FreeBSD.org>2002-07-16 04:24:28 +0000
committerYoichi NAKAYAMA <yoichi@FreeBSD.org>2002-07-16 04:24:28 +0000
commit9a817a236febc3a1ecf8d03c70e105441da547ec (patch)
tree2675cd4cc79cf19123b3b2f1961471fa00ea61d9 /textproc/docbookide.el/Makefile
parentb9caf6addcee18fd3222db97d5420975c8fd40b9 (diff)
downloadports-9a817a236febc3a1ecf8d03c70e105441da547ec.tar.gz
ports-9a817a236febc3a1ecf8d03c70e105441da547ec.zip
Notes
Diffstat (limited to 'textproc/docbookide.el/Makefile')
-rw-r--r--textproc/docbookide.el/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/textproc/docbookide.el/Makefile b/textproc/docbookide.el/Makefile
new file mode 100644
index 000000000000..b26ef5d095ea
--- /dev/null
+++ b/textproc/docbookide.el/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: docbookide
+# Date created: 2 July 2002
+# Whom: Sean Chittenden <sean@chittenden.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= docbookide.el
+PORTVERSION= 0.1
+CATEGORIES= textproc elisp
+MASTER_SITES= http://nwalsh.com/emacs/docbookide/
+DISTNAME= docbookide01
+
+MAINTAINER= sean@chittenden.org
+
+USE_ZIP= yes
+WRKSRC= ${WRKDIR}/docbookide
+NO_BUILD= yes
+
+ELISP_FILES= dbide-abbrev.el dbide-data.el dbide-font.el \
+ dbide-process.el docbookide.el make-regexp.el
+
+EMACS_LISPDIR= ${PREFIX}/share/emacs/site-lisp/docbookide
+XEMACSLISPDIR= ${PREFIX}/lib/xemacs/site-lisp/docbookide
+
+do-install:
+ ${MKDIR} ${EMACS_LISPDIR}
+ ${MKDIR} ${XEMACSLISPDIR}
+.for f in ${ELISP_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${EMACS_LISPDIR}/
+ ${LN} -sf ${EMACS_LISPDIR}/${f} ${XEMACSLISPDIR}/
+.endfor
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>