aboutsummaryrefslogtreecommitdiff
path: root/textproc/doclifter
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-04-01 10:08:02 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-04-01 10:08:02 +0000
commit88cc25d7f323ccff0eba4c858ce2bcfccbc30afb (patch)
tree933f6b0bf352e4e57ce8323dfd1b7135e8239553 /textproc/doclifter
parentde1d4bc508d938fc5d9e3b9d53215d2fa2c333e0 (diff)
downloadports-88cc25d7f323ccff0eba4c858ce2bcfccbc30afb.tar.gz
ports-88cc25d7f323ccff0eba4c858ce2bcfccbc30afb.zip
Notes
Diffstat (limited to 'textproc/doclifter')
-rw-r--r--textproc/doclifter/Makefile30
-rw-r--r--textproc/doclifter/distinfo1
-rw-r--r--textproc/doclifter/pkg-descr11
-rw-r--r--textproc/doclifter/pkg-plist1
4 files changed, 43 insertions, 0 deletions
diff --git a/textproc/doclifter/Makefile b/textproc/doclifter/Makefile
new file mode 100644
index 000000000000..40f198f0e9b2
--- /dev/null
+++ b/textproc/doclifter/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: doclifter
+# Date created: Apr 1, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= doclifter
+PORTVERSION= 1.0.4
+CATEGORIES= textproc
+MASTER_SITES= http://www.catb.org/~esr/doclifter/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Translates documents written in troff macros to DocBook
+
+USE_REINPLACE= yes
+USE_PYTHON= yes
+NO_BUILD= yes
+
+MAN1= doclifter.1
+
+post-patch:
+ @${REINPLACE_CMD} -e "s,python2,${PYTHON_CMD},g" ${WRKSRC}/doclifter
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/doclifter ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/doclifter.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/textproc/doclifter/distinfo b/textproc/doclifter/distinfo
new file mode 100644
index 000000000000..43498a299d2e
--- /dev/null
+++ b/textproc/doclifter/distinfo
@@ -0,0 +1 @@
+MD5 (doclifter-1.0.4.tar.gz) = 18d26400fa7f9b724fc03e528b6911aa
diff --git a/textproc/doclifter/pkg-descr b/textproc/doclifter/pkg-descr
new file mode 100644
index 000000000000..1ac921a000d5
--- /dev/null
+++ b/textproc/doclifter/pkg-descr
@@ -0,0 +1,11 @@
+The doclifter program translates documents written in troff macros to DocBook.
+
+Lifting documents from presentation level to semantic level is hard, and
+a really good job requires human polishing. This tool aims to do everything
+that can be mechanized, and to preserve any troff-level information that might
+have structural implications in XML comments.
+
+This tool does some of the hard parts, but not all. TBL tables are translated
+into DocBook table markup, but EQN and PIC are not translated (yet).
+
+WWW: http://www.catb.org/~esr/doclifter/
diff --git a/textproc/doclifter/pkg-plist b/textproc/doclifter/pkg-plist
new file mode 100644
index 000000000000..cc8941255a75
--- /dev/null
+++ b/textproc/doclifter/pkg-plist
@@ -0,0 +1 @@
+bin/doclifter