aboutsummaryrefslogtreecommitdiff
path: root/textproc/dom4j
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2005-10-18 20:31:22 +0000
committerGreg Lewis <glewis@FreeBSD.org>2005-10-18 20:31:22 +0000
commit14b1ff6bc5311d507e52d76106a5e5247a2982ac (patch)
tree66679ddcfca4bfa178328334eacc817d525dda8f /textproc/dom4j
parenta52cdf4c2a21f41d6f90bb43a3bc9bea3895b4ef (diff)
downloadports-14b1ff6bc5311d507e52d76106a5e5247a2982ac.tar.gz
ports-14b1ff6bc5311d507e52d76106a5e5247a2982ac.zip
Notes
Diffstat (limited to 'textproc/dom4j')
-rw-r--r--textproc/dom4j/Makefile42
-rw-r--r--textproc/dom4j/distinfo2
-rw-r--r--textproc/dom4j/pkg-descr5
3 files changed, 49 insertions, 0 deletions
diff --git a/textproc/dom4j/Makefile b/textproc/dom4j/Makefile
new file mode 100644
index 000000000000..2585586d085c
--- /dev/null
+++ b/textproc/dom4j/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: dom4j
+# Date created: 7 Oct 2005
+# Whom: <glewis@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dom4j
+PORTVERSION= 1.6.1
+CATEGORIES= textproc java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= dom4j
+
+MAINTAINER= glewis@FreeBSD.org
+COMMENT= Open Source XML framework for Java
+
+USE_JAVA= yes
+JAVA_VERSION= 1.2+
+NO_BUILD= yes
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+.endif
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR in ${JAVAJARDIR}..."
+ @cd ${WRKSRC} && \
+ ${INSTALL_DATA} ${PORTNAME}-${PORTVERSION}.jar \
+ ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/LICENSE.txt ${DOCSDIR}
+ @cd ${WRKSRC}/docs && ${FIND} . | \
+ ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > \
+ /dev/null 2>&1
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/dom4j/distinfo b/textproc/dom4j/distinfo
new file mode 100644
index 000000000000..2110937551fc
--- /dev/null
+++ b/textproc/dom4j/distinfo
@@ -0,0 +1,2 @@
+MD5 (dom4j-1.6.1.tar.gz) = 1e7ef6d20939315714de4a8502f27b2d
+SIZE (dom4j-1.6.1.tar.gz) = 9687211
diff --git a/textproc/dom4j/pkg-descr b/textproc/dom4j/pkg-descr
new file mode 100644
index 000000000000..28f0c69eafea
--- /dev/null
+++ b/textproc/dom4j/pkg-descr
@@ -0,0 +1,5 @@
+dom4j is an easy to use, open source library for working with XML, XPath
+and XSLT on the Java platform using the Java Collections Framework and
+with full support for DOM, SAX and JAXP.
+
+WWW: http://www.dom4j.org/