aboutsummaryrefslogtreecommitdiff
path: root/textproc/domc
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-04-10 21:00:01 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-04-10 21:00:01 +0000
commit243d2af21018d0b2097b4144f7982e10d0326ae2 (patch)
tree1474941080f6831ceaba419b066a9fe8a56f9e1e /textproc/domc
parenta6064d1bfaa42e7141eaf150ccaa4d83c233bf8d (diff)
downloadports-243d2af21018d0b2097b4144f7982e10d0326ae2.tar.gz
ports-243d2af21018d0b2097b4144f7982e10d0326ae2.zip
Notes
Diffstat (limited to 'textproc/domc')
-rw-r--r--textproc/domc/Makefile8
-rw-r--r--textproc/domc/files/patch-src_domc.h13
2 files changed, 20 insertions, 1 deletions
diff --git a/textproc/domc/Makefile b/textproc/domc/Makefile
index d395c43abf32..6e4f3fd966c3 100644
--- a/textproc/domc/Makefile
+++ b/textproc/domc/Makefile
@@ -32,4 +32,10 @@ INSTALLS_SHLIB= yes
PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+USE_GCC= 3.4
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/domc/files/patch-src_domc.h b/textproc/domc/files/patch-src_domc.h
new file mode 100644
index 000000000000..83e868594765
--- /dev/null
+++ b/textproc/domc/files/patch-src_domc.h
@@ -0,0 +1,13 @@
+--- src/domc.h.orig Thu Sep 9 23:52:10 2004
++++ src/domc.h Sun Apr 10 22:14:52 2005
+@@ -33,7 +33,9 @@
+ #include <errno.h>
+ #include <time.h>
+
+-#if defined(__sparc__)
++#if defined(__FreeBSD__)
++ #include <inttypes.h>
++#elif defined(__sparc__)
+ #include <sys/inttypes.h>
+ #elif defined(_WIN32)
+ typedef unsigned __int64 uint64_t;