aboutsummaryrefslogtreecommitdiff
path: root/textproc/dtdinst
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-02-24 16:25:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-02-24 16:25:30 +0000
commit159f392ebde62b4f73981e63a3b7a79d26e69774 (patch)
treed558953c7a0b3097002068814ea252a907ef7cae /textproc/dtdinst
parent9baf29f4b1945b63aae0c56214f2f36553229e7c (diff)
downloadports-159f392ebde62b4f73981e63a3b7a79d26e69774.tar.gz
ports-159f392ebde62b4f73981e63a3b7a79d26e69774.zip
Notes
Diffstat (limited to 'textproc/dtdinst')
-rw-r--r--textproc/dtdinst/Makefile22
1 files changed, 8 insertions, 14 deletions
diff --git a/textproc/dtdinst/Makefile b/textproc/dtdinst/Makefile
index 164785495690..c8df7933d2fc 100644
--- a/textproc/dtdinst/Makefile
+++ b/textproc/dtdinst/Makefile
@@ -27,22 +27,16 @@ PLIST_FILES= %%JAVAJARDIR%%/dtdinst.jar share/xsl/dtdinst/dtdinst2rng.xsl
PLIST_DIRS= share/xsl/dtdinst
PLIST_DIRSTRY= share/xsl
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
do-install:
- (cd ${WRKSRC} && ${INSTALL_DATA} *.jar ${JAVAJARDIR})
- @${MKDIR} ${PREFIX}/share/xsl/dtdinst
- (cd ${WRKSRC} && ${INSTALL_DATA} *.xsl ${PREFIX}/share/xsl/dtdinst)
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${JAVAJARDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} *.jar ${STAGEDIR}${JAVAJARDIR})
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/xsl/dtdinst
+ (cd ${WRKSRC} && ${INSTALL_DATA} *.xsl ${STAGEDIR}${PREFIX}/share/xsl/dtdinst)
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in dtdinst.rnc.txt dtdinst.rng index.html teixml.dtd.txt
- (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${DOCSDIR})
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
.endfor
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- (cd ${WRKSRC}/example && ${INSTALL_DATA} * ${EXAMPLESDIR})
-.endif
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ (cd ${WRKSRC}/example && ${INSTALL_DATA} * ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>