aboutsummaryrefslogtreecommitdiff
path: root/textproc/dtdinst
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-05-10 14:34:42 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-05-10 14:34:42 +0000
commit054cd56e4a1ec043184c0ecaf027f3802c2e21fa (patch)
tree8628225274885ffcde412ca64f9ed5b49cafa577 /textproc/dtdinst
parentb16cfcd7e9289d6b502d8150389ce25011743fc2 (diff)
downloadports-054cd56e4a1ec043184c0ecaf027f3802c2e21fa.tar.gz
ports-054cd56e4a1ec043184c0ecaf027f3802c2e21fa.zip
Notes
Diffstat (limited to 'textproc/dtdinst')
-rw-r--r--textproc/dtdinst/Makefile56
-rw-r--r--textproc/dtdinst/distinfo4
-rw-r--r--textproc/dtdinst/pkg-plist10
3 files changed, 35 insertions, 35 deletions
diff --git a/textproc/dtdinst/Makefile b/textproc/dtdinst/Makefile
index fb3d78c9da5d..2695bd5b5409 100644
--- a/textproc/dtdinst/Makefile
+++ b/textproc/dtdinst/Makefile
@@ -1,37 +1,47 @@
-# New ports collection makefile for: dtdinst
-# Date created: 3 February 2002
-# Whom: Kimura Fuyuki <fuyuki@mj.0038.net>
-#
+# Created by: Kimura Fuyuki <fuyuki@mj.0038.net>
# $FreeBSD$
-#
PORTNAME= dtdinst
-PORTVERSION= 2003.06.19
-PORTREVISION= 2
+PORTVERSION= 2009.11.11
CATEGORIES= textproc java
-MASTER_SITES= http://www.thaiopensource.com/download/
-DISTNAME= ${PORTNAME}-20030619
-EXTRACT_SUFX= .zip
+MASTER_SITES= GOOGLE_CODE
+PROJECTHOST= jing-trang
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.//g}
MAINTAINER= ports@FreeBSD.org
COMMENT= Converts DTDs to XML instance, in a specific or RELAX NG format
-USE_ZIP= YES
-USE_JAVA= yes
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/copying.txt
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
NO_BUILD= yes
-WRKSRC= ${WRKDIR}/${DISTNAME}
+
+USE_ZIP= yes
+USE_JAVA= yes
+
+PORTDOCS= *
+PORTEXAMPLES= *
+PLIST_FILES= %%JAVAJARDIR%%/dtdinst.jar share/xsl/dtdinst/dtdinst2rng.xsl
+PLIST_DIRS= share/xsl/dtdinst
+PLIST_DIRSTRY= share/xsl
+
+.include <bsd.port.options.mk>
do-install:
- ${INSTALL_DATA} ${WRKSRC}/*.jar ${JAVAJARDIR}
- ${MKDIR} ${PREFIX}/share/xsl/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/*.xsl ${PREFIX}/share/xsl/${PORTNAME}
-
-post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.html ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/dtdinst.rng ${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} *.jar ${JAVAJARDIR})
+ @${MKDIR} ${PREFIX}/share/xsl/dtdinst
+ (cd ${WRKSRC} && ${INSTALL_DATA} *.xsl ${PREFIX}/share/xsl/dtdinst)
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+.for i in dtdinst.rnc.txt dtdinst.rng index.html teixml.dtd.txt
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${DOCSDIR})
+.endfor
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/example && ${INSTALL_DATA} * ${EXAMPLESDIR})
.endif
.include <bsd.port.mk>
diff --git a/textproc/dtdinst/distinfo b/textproc/dtdinst/distinfo
index 13570ef88b57..dbae903ffdc7 100644
--- a/textproc/dtdinst/distinfo
+++ b/textproc/dtdinst/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dtdinst-20030619.zip) = fdaee0e3efaf14698d88f8c3e077041740e7f725fe936ff2458653a46d112a92
-SIZE (dtdinst-20030619.zip) = 179776
+SHA256 (dtdinst-20091111.zip) = b9387901dee4dce7fbb6cac6d7f7a6ca93c7555034fd394b00d95b7bed394b5b
+SIZE (dtdinst-20091111.zip) = 239791
diff --git a/textproc/dtdinst/pkg-plist b/textproc/dtdinst/pkg-plist
deleted file mode 100644
index d77689f2242c..000000000000
--- a/textproc/dtdinst/pkg-plist
+++ /dev/null
@@ -1,10 +0,0 @@
-%%JAVAJARDIR%%/dtdinst.jar
-share/xsl/dtdinst/dtdinst2rng.xsl
-@dirrm share/xsl/dtdinst
-@dirrmtry share/xsl
-%%PORTDOCS%%%%DOCSDIR%%/copying.txt
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/dtdinst.rng
-%%PORTDOCS%%%%DOCSDIR%%/dtdinst.rnc.txt
-%%PORTDOCS%%%%DOCSDIR%%/teixml.dtd.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%