aboutsummaryrefslogtreecommitdiff
path: root/textproc/ecromedos
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-09 13:08:17 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-07-09 13:08:17 +0000
commit73cc6eb34df3088b9c36ae4b43b4d98883eb966a (patch)
tree2b0764cc38244c288c09fd44112c6d5f17cd7f5f /textproc/ecromedos
parent2feda99d5f5da873dfe2c6fb1f0f6aa957676b68 (diff)
downloadports-73cc6eb34df3088b9c36ae4b43b4d98883eb966a.tar.gz
ports-73cc6eb34df3088b9c36ae4b43b4d98883eb966a.zip
Notes
Diffstat (limited to 'textproc/ecromedos')
-rw-r--r--textproc/ecromedos/Makefile54
-rw-r--r--textproc/ecromedos/distinfo3
-rw-r--r--textproc/ecromedos/files/patch-etc-ecmds.conf38
-rw-r--r--textproc/ecromedos/pkg-descr12
-rw-r--r--textproc/ecromedos/pkg-plist276
5 files changed, 383 insertions, 0 deletions
diff --git a/textproc/ecromedos/Makefile b/textproc/ecromedos/Makefile
new file mode 100644
index 000000000000..12b44b5111c9
--- /dev/null
+++ b/textproc/ecromedos/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: ecromedos
+# Date created: 2006-04-07
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ecromedos
+PORTVERSION= 1.0.1
+CATEGORIES= textproc print www
+MASTER_SITES= http://www.ecromedos.net/files/${PORTVERSION}/
+
+MAINTAINER= nivit@email.it
+COMMENT= A document preparation system that allows concurrent publication
+
+RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
+ latex:${PORTSDIR}/print/teTeX \
+ ${PYTHON_SITELIBDIR}/libxml2.py:${PORTSDIR}/textproc/py-libxml2 \
+ ${PYTHON_SITELIBDIR}/libxslt.py:${PORTSDIR}/textproc/py-libxslt
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2 \
+ xslt.2:${PORTSDIR}/textproc/libxslt
+
+NO_BUILD= yes
+USE_PYTHON= yes
+
+FIND_DIRS= -type d
+FIND_DATA= -type f -not \( -name "*.orig" -or -name "*.bak" \)
+
+LN_OPTS= -sf
+RM_OPTS= -r
+
+ECMDS_CONF= ${WRKSRC}/etc/ecmds.conf
+ECROMEDOC= ${DATADIR}/doc
+ECROMEBIN= ${DATADIR}/bin/${PORTNAME}
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ -e 's|%%DATADIR%%|${DATADIR}|g' ${ECMDS_CONF}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC} && ${FIND} . ${FIND_DIRS} -exec ${MKDIR} ${DATADIR}/{} \;
+ cd ${WRKSRC} && ${FIND} . ${FIND_DATA} -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${PORTNAME} ${ECROMEBIN}
+ ${LN} ${LN_OPTS} ${ECROMEBIN} ${PREFIX}/bin/${PORTNAME}
+ ${LN} ${LN_OPTS} ${ECROMEBIN} ${PREFIX}/bin/ecmds
+.if !defined(NOPORTDOCS)
+ ${MV} ${ECROMEDOC} ${DOCSDIR}
+ ${LN} ${LN_OPTS} ${DOCSDIR} ${ECROMEDOC}
+.else
+ ${RM} ${RM_OPTS} ${ECROMEDOC}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/ecromedos/distinfo b/textproc/ecromedos/distinfo
new file mode 100644
index 000000000000..a5ea487983b9
--- /dev/null
+++ b/textproc/ecromedos/distinfo
@@ -0,0 +1,3 @@
+MD5 (ecromedos-1.0.1.tar.gz) = de71a31a294ca4d960703b9fed650496
+SHA256 (ecromedos-1.0.1.tar.gz) = 2dc388f9306a69072e01a0842fe22aaa4007f9d48d820995f7d014b490d55bcf
+SIZE (ecromedos-1.0.1.tar.gz) = 375691
diff --git a/textproc/ecromedos/files/patch-etc-ecmds.conf b/textproc/ecromedos/files/patch-etc-ecmds.conf
new file mode 100644
index 000000000000..ab20d2038117
--- /dev/null
+++ b/textproc/ecromedos/files/patch-etc-ecmds.conf
@@ -0,0 +1,38 @@
+--- etc/ecmds.conf Mon Apr 24 22:39:42 2006
++++ etc/ecmds.conf.port Tue Apr 25 23:30:03 2006
+@@ -7,7 +7,7 @@
+ #
+ # Base installation directory
+ #
+-base_dir = /opt/ecromedos-1.0.1/
++base_dir = %%DATADIR%%
+
+ #
+ # Library directory
+@@ -37,22 +37,22 @@
+ #
+ # Path to 'latex' executable
+ #
+-latex_bin = /usr/bin/latex
++latex_bin = %%LOCALBASE%%/bin/latex
+
+ #
+ # Path to GNU 'dvipng' executable
+ #
+-dvipng_bin = /usr/bin/dvipng
++dvipng_bin = %%LOCALBASE%%/bin/dvipng
+
+ #
+ # Path to ImageMagick's 'convert' executable
+ #
+-convert_bin = /usr/bin/convert
++convert_bin = %%LOCALBASE%%/bin/convert
+
+ #
+ # Path to ImageMagick's 'identify' executable
+ #
+-identify_bin = /usr/bin/identify
++identify_bin = %%LOCALBASE%%/bin/identify
+
+ #
+ # Density of dots/inch to use when converting vector formats to raster images
diff --git a/textproc/ecromedos/pkg-descr b/textproc/ecromedos/pkg-descr
new file mode 100644
index 000000000000..03a9e6cf5335
--- /dev/null
+++ b/textproc/ecromedos/pkg-descr
@@ -0,0 +1,12 @@
+An integrated solution for XML-based publishing in print and web.
+It is specifically targeted at producing technical documentation
+in the field of computer science.
+
+Documents are written in an XML-based markup language and translated
+to different formats with XSL-transformations. At this time, eCromedos
+supports the target formats XHTML and LATEX. Where LATEX output can be
+further processed into high-quality printable formats by use of the
+TEX typesetting system (http://www.ctan.org).
+
+Author: Tobias Koch <tkoch@ecromedos.net>
+WWW: http://www.ecromedos.net/
diff --git a/textproc/ecromedos/pkg-plist b/textproc/ecromedos/pkg-plist
new file mode 100644
index 000000000000..9dfde4619857
--- /dev/null
+++ b/textproc/ecromedos/pkg-plist
@@ -0,0 +1,276 @@
+@comment $FreeBSD$
+bin/ecmds
+bin/ecromedos
+%%PORTDOCS%%%%DOCSDIR%%/langdef.txt
+%%PORTDOCS%%%%DOCSDIR%%/manual/html/biblio.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/html/chapter1.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/html/chapter2.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/html/chapter3.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/html/chapter4.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/html/chapter5.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/manual/html/m000001.gif
+%%PORTDOCS%%%%DOCSDIR%%/manual/html/next.gif
+%%PORTDOCS%%%%DOCSDIR%%/manual/html/prev.gif
+%%PORTDOCS%%%%DOCSDIR%%/manual/html/style.css
+%%PORTDOCS%%%%DOCSDIR%%/manual/html/toc.gif
+%%PORTDOCS%%%%DOCSDIR%%/manual/pdf/manual.pdf
+%%PORTDOCS%%%%DOCSDIR%%/manual/src/advanced.xml
+%%PORTDOCS%%%%DOCSDIR%%/manual/src/compiling.xml
+%%PORTDOCS%%%%DOCSDIR%%/manual/src/installation.xml
+%%PORTDOCS%%%%DOCSDIR%%/manual/src/introduction.xml
+%%PORTDOCS%%%%DOCSDIR%%/manual/src/manual.xml
+%%PORTDOCS%%%%DOCSDIR%%/manual/src/writing.xml
+%%PORTDOCS%%%%DOCSDIR%%/reference/html/chapter1.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/html/chapter2.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/html/chapter3.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/html/chapter4.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/html/chapter5.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/html/index.html
+%%PORTDOCS%%%%DOCSDIR%%/reference/html/next.gif
+%%PORTDOCS%%%%DOCSDIR%%/reference/html/prev.gif
+%%PORTDOCS%%%%DOCSDIR%%/reference/html/style.css
+%%PORTDOCS%%%%DOCSDIR%%/reference/html/toc.gif
+%%PORTDOCS%%%%DOCSDIR%%/reference/pdf/reference.pdf
+%%PORTDOCS%%%%DOCSDIR%%/reference/src/AtoC.xml
+%%PORTDOCS%%%%DOCSDIR%%/reference/src/DtoL.xml
+%%PORTDOCS%%%%DOCSDIR%%/reference/src/MtoS.xml
+%%PORTDOCS%%%%DOCSDIR%%/reference/src/TtoZ.xml
+%%PORTDOCS%%%%DOCSDIR%%/reference/src/defs.xml
+%%PORTDOCS%%%%DOCSDIR%%/reference/src/reference.xml
+%%DATADIR%%/bin/configreader.py
+%%DATADIR%%/bin/configreader.pyc
+%%DATADIR%%/bin/ecmdsproc.py
+%%DATADIR%%/bin/ecmdsproc.pyc
+%%DATADIR%%/bin/ecromedos
+%%DATADIR%%/bin/error.py
+%%DATADIR%%/bin/error.pyc
+%%DATADIR%%/bin/preprocessor.py
+%%DATADIR%%/bin/preprocessor.pyc
+%%DATADIR%%/bin/validator.py
+%%DATADIR%%/bin/validator.pyc
+%%DATADIR%%/bin/xslprocessor.py
+%%DATADIR%%/bin/xslprocessor.pyc
+%%DATADIR%%/data/arrow_left.svg
+%%DATADIR%%/data/next.gif
+%%DATADIR%%/data/next.png
+%%DATADIR%%/data/prev.gif
+%%DATADIR%%/data/prev.png
+%%DATADIR%%/data/toc.gif
+%%DATADIR%%/data/toc.png
+%%PORTDOCS%%%%DATADIR%%/doc
+%%DATADIR%%/etc/ecmds.conf
+%%DATADIR%%/etc/plugins.conf
+%%DATADIR%%/lib/__init__.py
+%%DATADIR%%/lib/hylight/__init__.py
+%%DATADIR%%/lib/hylight/__init__.pyc
+%%DATADIR%%/lib/hylight/codegenerator.py
+%%DATADIR%%/lib/hylight/codegenerator.pyc
+%%DATADIR%%/lib/hylight/ecmdsgenerator.py
+%%DATADIR%%/lib/hylight/ecmdsgenerator.pyc
+%%DATADIR%%/lib/hylight/error.py
+%%DATADIR%%/lib/hylight/error.pyc
+%%DATADIR%%/lib/hylight/langDefs/__init__.py
+%%DATADIR%%/lib/hylight/langDefs/__init__.pyc
+%%DATADIR%%/lib/hylight/langDefs/abap.py
+%%DATADIR%%/lib/hylight/langDefs/actionscript.py
+%%DATADIR%%/lib/hylight/langDefs/ada95.py
+%%DATADIR%%/lib/hylight/langDefs/agda.py
+%%DATADIR%%/lib/hylight/langDefs/ampl.py
+%%DATADIR%%/lib/hylight/langDefs/amtrix.py
+%%DATADIR%%/lib/hylight/langDefs/apache.py
+%%DATADIR%%/lib/hylight/langDefs/applescript.py
+%%DATADIR%%/lib/hylight/langDefs/arm.py
+%%DATADIR%%/lib/hylight/langDefs/asp.py
+%%DATADIR%%/lib/hylight/langDefs/aspect.py
+%%DATADIR%%/lib/hylight/langDefs/assembler.py
+%%DATADIR%%/lib/hylight/langDefs/avenue.py
+%%DATADIR%%/lib/hylight/langDefs/awk.py
+%%DATADIR%%/lib/hylight/langDefs/bat.py
+%%DATADIR%%/lib/hylight/langDefs/bibtex.py
+%%DATADIR%%/lib/hylight/langDefs/blitzbasic3d.py
+%%DATADIR%%/lib/hylight/langDefs/bmscript.py
+%%DATADIR%%/lib/hylight/langDefs/c.py
+%%DATADIR%%/lib/hylight/langDefs/c.pyc
+%%DATADIR%%/lib/hylight/langDefs/clearbasic.py
+%%DATADIR%%/lib/hylight/langDefs/clipper.py
+%%DATADIR%%/lib/hylight/langDefs/clips.py
+%%DATADIR%%/lib/hylight/langDefs/cobol.py
+%%DATADIR%%/lib/hylight/langDefs/coldfusion.py
+%%DATADIR%%/lib/hylight/langDefs/csharp.py
+%%DATADIR%%/lib/hylight/langDefs/css.py
+%%DATADIR%%/lib/hylight/langDefs/dylan.py
+%%DATADIR%%/lib/hylight/langDefs/eiffel.py
+%%DATADIR%%/lib/hylight/langDefs/erlang.py
+%%DATADIR%%/lib/hylight/langDefs/euphoria.py
+%%DATADIR%%/lib/hylight/langDefs/express.py
+%%DATADIR%%/lib/hylight/langDefs/flx.py
+%%DATADIR%%/lib/hylight/langDefs/fortran77.py
+%%DATADIR%%/lib/hylight/langDefs/fortran90.py
+%%DATADIR%%/lib/hylight/langDefs/frink.py
+%%DATADIR%%/lib/hylight/langDefs/haskell.py
+%%DATADIR%%/lib/hylight/langDefs/hecl.py
+%%DATADIR%%/lib/hylight/langDefs/icon.py
+%%DATADIR%%/lib/hylight/langDefs/idl.py
+%%DATADIR%%/lib/hylight/langDefs/informix.py
+%%DATADIR%%/lib/hylight/langDefs/ini.py
+%%DATADIR%%/lib/hylight/langDefs/inp.py
+%%DATADIR%%/lib/hylight/langDefs/io.py
+%%DATADIR%%/lib/hylight/langDefs/j.py
+%%DATADIR%%/lib/hylight/langDefs/java.py
+%%DATADIR%%/lib/hylight/langDefs/js.py
+%%DATADIR%%/lib/hylight/langDefs/mssql.py
+%%DATADIR%%/lib/hylight/langDefs/perl.py
+%%DATADIR%%/lib/hylight/langDefs/php.py
+%%DATADIR%%/lib/hylight/langDefs/python.py
+%%DATADIR%%/lib/hylight/langDefs/python.pyc
+%%DATADIR%%/lib/hylight/langDefs/sql.py
+%%DATADIR%%/lib/hylight/langDefs/xml.py
+%%DATADIR%%/lib/hylight/langDefs/xml.pyc
+%%DATADIR%%/lib/hylight/langDefs/yacc.py
+%%DATADIR%%/lib/hylight/themes/__init__.py
+%%DATADIR%%/lib/hylight/themes/__init__.pyc
+%%DATADIR%%/lib/hylight/themes/acid.py
+%%DATADIR%%/lib/hylight/themes/acid.pyc
+%%DATADIR%%/lib/hylight/themes/berries-dark.py
+%%DATADIR%%/lib/hylight/themes/berries-dark.pyc
+%%DATADIR%%/lib/hylight/themes/berries-light.py
+%%DATADIR%%/lib/hylight/themes/berries-light.pyc
+%%DATADIR%%/lib/hylight/themes/bipolar.py
+%%DATADIR%%/lib/hylight/themes/bipolar.pyc
+%%DATADIR%%/lib/hylight/themes/blacknblue.py
+%%DATADIR%%/lib/hylight/themes/bright.py
+%%DATADIR%%/lib/hylight/themes/contrast.py
+%%DATADIR%%/lib/hylight/themes/darkblue.py
+%%DATADIR%%/lib/hylight/themes/darkness.py
+%%DATADIR%%/lib/hylight/themes/desert.py
+%%DATADIR%%/lib/hylight/themes/dull.py
+%%DATADIR%%/lib/hylight/themes/easter.py
+%%DATADIR%%/lib/hylight/themes/easter.pyc
+%%DATADIR%%/lib/hylight/themes/emacs.py
+%%DATADIR%%/lib/hylight/themes/emacs.pyc
+%%DATADIR%%/lib/hylight/themes/golden.py
+%%DATADIR%%/lib/hylight/themes/golden.pyc
+%%DATADIR%%/lib/hylight/themes/greenlcd.py
+%%DATADIR%%/lib/hylight/themes/ide-anjuta.py
+%%DATADIR%%/lib/hylight/themes/ide-anjuta.pyc
+%%DATADIR%%/lib/hylight/themes/ide-codewarrior.py
+%%DATADIR%%/lib/hylight/themes/ide-codewarrior.pyc
+%%DATADIR%%/lib/hylight/themes/ide-devcpp.py
+%%DATADIR%%/lib/hylight/themes/ide-devcpp.pyc
+%%DATADIR%%/lib/hylight/themes/ide-eclipse.py
+%%DATADIR%%/lib/hylight/themes/ide-eclipse.pyc
+%%DATADIR%%/lib/hylight/themes/ide-kdev.py
+%%DATADIR%%/lib/hylight/themes/ide-msvcpp.py
+%%DATADIR%%/lib/hylight/themes/ide-msvcpp.pyc
+%%DATADIR%%/lib/hylight/themes/kwrite.py
+%%DATADIR%%/lib/hylight/themes/matlab.py
+%%DATADIR%%/lib/hylight/themes/navy.py
+%%DATADIR%%/lib/hylight/themes/navy.pyc
+%%DATADIR%%/lib/hylight/themes/nedit.py
+%%DATADIR%%/lib/hylight/themes/nedit.pyc
+%%DATADIR%%/lib/hylight/themes/neon.py
+%%DATADIR%%/lib/hylight/themes/neon.pyc
+%%DATADIR%%/lib/hylight/themes/night.py
+%%DATADIR%%/lib/hylight/themes/pablo.py
+%%DATADIR%%/lib/hylight/themes/pablo.pyc
+%%DATADIR%%/lib/hylight/themes/peachpuff.py
+%%DATADIR%%/lib/hylight/themes/peachpuff.pyc
+%%DATADIR%%/lib/hylight/themes/print.py
+%%DATADIR%%/lib/hylight/themes/print.pyc
+%%DATADIR%%/lib/hylight/themes/rand01.py
+%%DATADIR%%/lib/hylight/themes/rand01.pyc
+%%DATADIR%%/lib/hylight/themes/the.py
+%%DATADIR%%/lib/hylight/themes/the.pyc
+%%DATADIR%%/lib/hylight/themes/typical.py
+%%DATADIR%%/lib/hylight/themes/typical.pyc
+%%DATADIR%%/lib/hylight/themes/vampire.py
+%%DATADIR%%/lib/hylight/themes/vampire.pyc
+%%DATADIR%%/lib/hylight/themes/vim-dark.py
+%%DATADIR%%/lib/hylight/themes/vim.py
+%%DATADIR%%/lib/hylight/themes/whatis.py
+%%DATADIR%%/lib/hylight/themes/whitengrey.py
+%%DATADIR%%/lib/hylight/themes/zellner.py
+%%DATADIR%%/lib/hylight/themes/zellner.pyc
+%%DATADIR%%/plugins/data.py
+%%DATADIR%%/plugins/data.pyc
+%%DATADIR%%/plugins/final.py
+%%DATADIR%%/plugins/final.pyc
+%%DATADIR%%/plugins/highlight.py
+%%DATADIR%%/plugins/highlight.pyc
+%%DATADIR%%/plugins/math.py
+%%DATADIR%%/plugins/math.pyc
+%%DATADIR%%/plugins/picture.py
+%%DATADIR%%/plugins/picture.pyc
+%%DATADIR%%/plugins/strip.py
+%%DATADIR%%/plugins/strip.pyc
+%%DATADIR%%/plugins/text.py
+%%DATADIR%%/plugins/text.pyc
+%%DATADIR%%/plugins/verbatim.py
+%%DATADIR%%/plugins/verbatim.pyc
+%%DATADIR%%/transform/DTD/article.dtd
+%%DATADIR%%/transform/DTD/book.dtd
+%%DATADIR%%/transform/DTD/report.dtd
+%%DATADIR%%/transform/i18n/english.xml
+%%DATADIR%%/transform/i18n/german.xml
+%%DATADIR%%/transform/i18n/i18n.xml
+%%DATADIR%%/transform/i18n/i18n.xsl
+%%DATADIR%%/transform/i18n/spanish.xml
+%%DATADIR%%/transform/latex/annotation.xsl
+%%DATADIR%%/transform/latex/biblio.xsl
+%%DATADIR%%/transform/latex/color.xsl
+%%DATADIR%%/transform/latex/counter.xsl
+%%DATADIR%%/transform/latex/ecmds.xsl
+%%DATADIR%%/transform/latex/entities.xml
+%%DATADIR%%/transform/latex/entities.xsl
+%%DATADIR%%/transform/latex/equation.xsl
+%%DATADIR%%/transform/latex/figure.xsl
+%%DATADIR%%/transform/latex/latex.xsl
+%%DATADIR%%/transform/latex/list.xsl
+%%DATADIR%%/transform/latex/listing.xsl
+%%DATADIR%%/transform/latex/section.xsl
+%%DATADIR%%/transform/latex/table.xsl
+%%DATADIR%%/transform/latex/text.xsl
+%%DATADIR%%/transform/latex/toc.xsl
+%%DATADIR%%/transform/latex/utility.xsl
+%%DATADIR%%/transform/xhtml/annotation.xsl
+%%DATADIR%%/transform/xhtml/biblio.xsl
+%%DATADIR%%/transform/xhtml/color.xsl
+%%DATADIR%%/transform/xhtml/counter.xsl
+%%DATADIR%%/transform/xhtml/ecmds.xsl
+%%DATADIR%%/transform/xhtml/entities.xml
+%%DATADIR%%/transform/xhtml/entities.xsl
+%%DATADIR%%/transform/xhtml/equation.xsl
+%%DATADIR%%/transform/xhtml/figure.xsl
+%%DATADIR%%/transform/xhtml/list.xsl
+%%DATADIR%%/transform/xhtml/listing.xsl
+%%DATADIR%%/transform/xhtml/section.xsl
+%%DATADIR%%/transform/xhtml/table.xsl
+%%DATADIR%%/transform/xhtml/text.xsl
+%%DATADIR%%/transform/xhtml/toc.xsl
+%%DATADIR%%/transform/xhtml/utility.xsl
+%%DATADIR%%/transform/xhtml/xhtml.xsl
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual/src
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/manual
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/reference/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/reference/pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/reference/src
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/reference
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/bin
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%/etc
+@dirrm %%DATADIR%%/lib/hylight/langDefs
+@dirrm %%DATADIR%%/lib/hylight/themes
+@dirrm %%DATADIR%%/lib/hylight
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%/spool
+@dirrm %%DATADIR%%/transform/DTD
+@dirrm %%DATADIR%%/transform/i18n
+@dirrm %%DATADIR%%/transform/latex
+@dirrm %%DATADIR%%/transform/xhtml
+@dirrm %%DATADIR%%/transform
+@dirrm %%DATADIR%%