aboutsummaryrefslogtreecommitdiff
path: root/textproc/elasticsearch-plugin-head/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2015-01-08 11:35:31 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2015-01-08 11:35:31 +0000
commita507bb58616963ad803f07ef14f50fc434b3931a (patch)
tree9ba112c97c4488bfeeea47abf1c93dc1c258974d /textproc/elasticsearch-plugin-head/Makefile
parent809a68913c7ef34604ede277f3e43028e35550f9 (diff)
Notes
Diffstat (limited to 'textproc/elasticsearch-plugin-head/Makefile')
-rw-r--r--textproc/elasticsearch-plugin-head/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/elasticsearch-plugin-head/Makefile b/textproc/elasticsearch-plugin-head/Makefile
new file mode 100644
index 000000000000..35ddae109b28
--- /dev/null
+++ b/textproc/elasticsearch-plugin-head/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= head
+PORTVERSION= 2014.11.16
+CATEGORIES= textproc
+PKGNAMEPREFIX= elasticsearch-plugin-
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= ElasticSearch Head Plugin
+
+LICENSE= APACHE20
+
+RUN_DEPENDS:= elasticsearch>=0.90.9:${PORTSDIR}/textproc/elasticsearch
+
+USE_GITHUB= yes
+GH_ACCOUNT= mobz
+GH_PROJECT= elasticsearch-head
+GH_COMMIT= 3706e79
+GH_TAGNAME= ${GH_COMMIT}
+
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins/head/_site
+ cd ${WRKSRC} && ${COPYTREE_SHARE} \* ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins/head/_site
+
+.include <bsd.port.mk>