aboutsummaryrefslogtreecommitdiff
path: root/textproc/elasticsearch2-plugin-marvel
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2016-03-10 16:40:46 +0000
committerDan Langille <dvl@FreeBSD.org>2016-03-10 16:40:46 +0000
commit506a4bbae7ebe4c4b28b644fbac78393e295492c (patch)
tree4ea1319c25bf61f8c91a780656162605df01bdca /textproc/elasticsearch2-plugin-marvel
parent4e84a1c4aafac84a5c1e55852aec1eb3042dfd1a (diff)
downloadports-506a4bbae7ebe4c4b28b644fbac78393e295492c.tar.gz
ports-506a4bbae7ebe4c4b28b644fbac78393e295492c.zip
Notes
Diffstat (limited to 'textproc/elasticsearch2-plugin-marvel')
-rw-r--r--textproc/elasticsearch2-plugin-marvel/Makefile46
-rw-r--r--textproc/elasticsearch2-plugin-marvel/distinfo4
-rw-r--r--textproc/elasticsearch2-plugin-marvel/pkg-descr4
-rw-r--r--textproc/elasticsearch2-plugin-marvel/pkg-plist10
4 files changed, 64 insertions, 0 deletions
diff --git a/textproc/elasticsearch2-plugin-marvel/Makefile b/textproc/elasticsearch2-plugin-marvel/Makefile
new file mode 100644
index 000000000000..0f4084d0e01e
--- /dev/null
+++ b/textproc/elasticsearch2-plugin-marvel/Makefile
@@ -0,0 +1,46 @@
+# Created by: Tom Judge <tj@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= marvel
+PORTVERSION= 2.1.0
+CATEGORIES= textproc perl5
+MASTER_SITES= http://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/license/${PORTVERSION}/:source1 \
+ http://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/marvel-agent/${PORTVERSION}/:source2
+PKGNAMEPREFIX= elasticsearch2-plugin-
+DISTFILES= license-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}${EXTRACT_SUFX}:source1 \
+ marvel-agent-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}${EXTRACT_SUFX}:source2
+
+MAINTAINER= dvl@FreeBSD.org
+COMMENT= ElasticSearch Marvel Monitoring Plugin
+
+LICENSE= COMMERCIAL
+LICENSE_NAME= Free for development; license required for production use
+LICENSE_TEXT= License available from Elasticsearch for production use.
+LICENSE_TEXT+= See http://www.elasticsearch.com/marvel/ for more details.
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell no-auto-accept
+
+RUN_DEPENDS:= elasticsearch2>2.0.0:${PORTSDIR}/textproc/elasticsearch2
+
+NO_BUILD= yes
+LEGAL_TEXT= ${LICENSE_NAME_COMMERCIAL}
+PLIST_SUB= VERSION=${PORTVERSION}
+
+USES+= zip
+
+ZIP_FILES= license \
+ marvel-agent
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+.for file in ${ZIP_FILES}
+ ( cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} -d ${file}-${PORTVERSION} \
+ ${_DISTDIR}/${file}-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}${EXTRACT_SUFX} )
+.endfor
+
+do-install:
+.for file in ${ZIP_FILES}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins/${file}
+ @cd ${WRKDIR}/${file}-${PORTVERSION} && ${COPYTREE_SHARE} . ${STAGEDIR}${PREFIX}/lib/elasticsearch/plugins/${file}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/textproc/elasticsearch2-plugin-marvel/distinfo b/textproc/elasticsearch2-plugin-marvel/distinfo
new file mode 100644
index 000000000000..3a9bf75e0bb1
--- /dev/null
+++ b/textproc/elasticsearch2-plugin-marvel/distinfo
@@ -0,0 +1,4 @@
+SHA256 (license-2.1.0.zip) = 7705f011c1027be520143f834031f79f15e3c378924f7a05a934e413c31937af
+SIZE (license-2.1.0.zip) = 102034
+SHA256 (marvel-agent-2.1.0.zip) = f9d118c67255d762b5692813dad3fa098bb16cc465dbf857898a794a43732caa
+SIZE (marvel-agent-2.1.0.zip) = 153231
diff --git a/textproc/elasticsearch2-plugin-marvel/pkg-descr b/textproc/elasticsearch2-plugin-marvel/pkg-descr
new file mode 100644
index 000000000000..fbcd5bdad85a
--- /dev/null
+++ b/textproc/elasticsearch2-plugin-marvel/pkg-descr
@@ -0,0 +1,4 @@
+Marvel is an Elasticsearch management tool. This tool is free for
+development use but requires a license to be used in production.
+
+WWW: http://www.elasticsearch.org/overview/marvel/download/
diff --git a/textproc/elasticsearch2-plugin-marvel/pkg-plist b/textproc/elasticsearch2-plugin-marvel/pkg-plist
new file mode 100644
index 000000000000..9b549b9d001d
--- /dev/null
+++ b/textproc/elasticsearch2-plugin-marvel/pkg-plist
@@ -0,0 +1,10 @@
+lib/elasticsearch/plugins/license/LICENSE.txt
+lib/elasticsearch/plugins/license/NOTICE.txt
+lib/elasticsearch/plugins/license/license-%%VERSION%%.jar
+lib/elasticsearch/plugins/license/license-core-%%VERSION%%.jar
+lib/elasticsearch/plugins/license/license-plugin-api-%%VERSION%%.jar
+lib/elasticsearch/plugins/license/plugin-descriptor.properties
+lib/elasticsearch/plugins/marvel-agent/LICENSE.txt
+lib/elasticsearch/plugins/marvel-agent/NOTICE.txt
+lib/elasticsearch/plugins/marvel-agent/marvel-agent-%%VERSION%%.jar
+lib/elasticsearch/plugins/marvel-agent/plugin-descriptor.properties