aboutsummaryrefslogtreecommitdiff
path: root/textproc/elasticsearch
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-12-07 09:49:03 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-12-07 09:49:03 +0000
commitf228d61ba1bc7fc57c43433dc9c2abb9c78d64e3 (patch)
treeea37f59df50234198d74b18801e5fbc605b719a0 /textproc/elasticsearch
parent79aafb2cb5ba9337af8414b74db5361f341b2a55 (diff)
downloadports-f228d61ba1bc7fc57c43433dc9c2abb9c78d64e3.tar.gz
ports-f228d61ba1bc7fc57c43433dc9c2abb9c78d64e3.zip
Notes
Diffstat (limited to 'textproc/elasticsearch')
-rw-r--r--textproc/elasticsearch/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/textproc/elasticsearch/Makefile b/textproc/elasticsearch/Makefile
index 3b83a5b166f9..6cd227873821 100644
--- a/textproc/elasticsearch/Makefile
+++ b/textproc/elasticsearch/Makefile
@@ -3,7 +3,7 @@
PORTNAME= elasticsearch
PORTVERSION= 1.4.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc java devel
MASTER_SITES= http://download.elasticsearch.org/${PORTNAME}/${PORTNAME}/ \
http://mirrors.rit.edu/zi/
@@ -63,6 +63,24 @@ GROUPS= ${SEARCHGROUP}
ELASTIC_DBDIR= /var/db/elasticsearch
ELASTIC_LOGDIR= /var/log/elasticsearch
+.if ${OPSYS} == FreeBSD
+. if ${OSVERSION} >= 1000000
+PLATFORM_VER= 1
+. elif ${OSVERSION} >= 900000
+PLATFORM_VER= 9
+. elif ${OSVERSION} >= 800000
+PLATFORM_VER= 8
+. elif ${OSVERSION} >= 700000
+PLATFORM_VER= 7
+. elif ${OSVERSION} >= 600000
+PLATFORM_VER= 6
+. else
+BROKEN= Unsupported FreeBSD version
+. endif
+.else
+BROKEN= ${OPSYS} platform is not supported
+.endif
+
SIGAR_LIBNAME= libsigar-${ARCH:S,i386,x86,}-freebsd-${PLATFORM_VER}.so
SUB_LIST= SEARCHUSER=${SEARCHUSER} \