aboutsummaryrefslogtreecommitdiff
path: root/textproc/eruby/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-07-12 14:36:01 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-07-12 14:36:01 +0000
commit08a5a0f3a78edd96f0c18da6e4b3a11aa9442b5c (patch)
treec19781c26da05df5cf3714ac83312acb098c1dae /textproc/eruby/Makefile
parent22d024b8ce80ab67236549abbb79ad03b3ac1956 (diff)
downloadports-08a5a0f3a78edd96f0c18da6e4b3a11aa9442b5c.tar.gz
ports-08a5a0f3a78edd96f0c18da6e4b3a11aa9442b5c.zip
Notes
Diffstat (limited to 'textproc/eruby/Makefile')
-rw-r--r--textproc/eruby/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/textproc/eruby/Makefile b/textproc/eruby/Makefile
index 49d55fbdb02d..3ca15a5084d7 100644
--- a/textproc/eruby/Makefile
+++ b/textproc/eruby/Makefile
@@ -7,8 +7,10 @@
PORTNAME= eruby
PORTVERSION= 1.0.5
+PORTREVISION= 1
CATEGORIES= textproc www ruby
MASTER_SITES= http://www.modruby.net/archive/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DIST_SUBDIR= ruby
MAINTAINER= dinoex@FreeBSD.org
@@ -16,8 +18,6 @@ COMMENT= Interprets Ruby code embedded in a text file like PHP/ePerl/ASP/JSP
USE_RUBY= yes
-BROKEN= does not compile
-
CONFIGURE_ARGS= --enable-shared --with-charset="${DEFAULT_CHARSET}"
INSTALL_TARGET= site-install
USE_LDCONFIG= yes
@@ -51,4 +51,15 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_PTHREADS)
+.if ${RUBY_VERSION} == 1.8.7.160
+# ruby18 -r rbconfig -e "p Config::CONFIG['LIBS']" should output:
+# "-lcrypt -lm -rpath=/usr/lib:/usr/local/lib -pthread"
+# but 1.8.7.160 missing pthread
+CONFIGURE_ENV+= EXTRA_LDFLAGS="${EXTRA_LDFLAGS} -pthread"
+.endif
+.endif
+
+.include <bsd.port.post.mk>