aboutsummaryrefslogtreecommitdiff
path: root/textproc/exempi
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2008-07-08 20:31:10 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2008-07-08 20:31:10 +0000
commitd0bdbbab6aba917a905c2feb4aaecb9d886cdf3d (patch)
tree17cc1d6bb7b410c973f49d16734b88b91c8980fe /textproc/exempi
parentf0a161a88232186fd331fd78017da299219969b4 (diff)
downloadports-d0bdbbab6aba917a905c2feb4aaecb9d886cdf3d.tar.gz
ports-d0bdbbab6aba917a905c2feb4aaecb9d886cdf3d.zip
Notes
Diffstat (limited to 'textproc/exempi')
-rw-r--r--textproc/exempi/Makefile7
-rw-r--r--textproc/exempi/distinfo6
-rw-r--r--textproc/exempi/files/patch-source_XMPFiles_FormatSupport_EndianUtils.hpp22
-rw-r--r--textproc/exempi/files/patch-source_XMPFiles_FormatSupport_Reconcile_Impl.cpp20
4 files changed, 18 insertions, 37 deletions
diff --git a/textproc/exempi/Makefile b/textproc/exempi/Makefile
index b71435688511..1a7f1365ecf3 100644
--- a/textproc/exempi/Makefile
+++ b/textproc/exempi/Makefile
@@ -3,10 +3,11 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/textproc/exempi/Makefile,v 1.1 2008/02/26 18:50:26 ahze Exp $
+# $MCom: ports/textproc/exempi/Makefile,v 1.1 2008/02/26 18:50:26 ahze Exp $
+#
PORTNAME= exempi
-PORTVERSION= 1.99.9
+PORTVERSION= 2.0.1
CATEGORIES= textproc
MASTER_SITES= http://libopenraw.freedesktop.org/download/
@@ -16,7 +17,7 @@ COMMENT= A port of Adobe XMP SDK to work on UNIX
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
USE_AUTOTOOLS= libtool:15
-USE_GNOME= ltverhack gnomehack
+USE_GNOME= ltverhack gnomehack gnometarget
CONFIGURE_ARGS= --enable-unittest=no
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib" \
LIBS="-liconv"
diff --git a/textproc/exempi/distinfo b/textproc/exempi/distinfo
index 045db78a114b..13cacda59974 100644
--- a/textproc/exempi/distinfo
+++ b/textproc/exempi/distinfo
@@ -1,3 +1,3 @@
-MD5 (exempi-1.99.9.tar.gz) = 8fb6c6230a4862b8c82b4b76be6ffb1e
-SHA256 (exempi-1.99.9.tar.gz) = 10104ff8405604b32583fb8c8731c038525aeacf6c4a44f2845649964a3c9a7b
-SIZE (exempi-1.99.9.tar.gz) = 3063146
+MD5 (exempi-2.0.1.tar.gz) = 8d72412c8a1e0330c4fa57da2d0ef96e
+SHA256 (exempi-2.0.1.tar.gz) = a3447b6901634391b52695c653e870462a9b02ac120464c26fd469a5affebde5
+SIZE (exempi-2.0.1.tar.gz) = 3065914
diff --git a/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_EndianUtils.hpp b/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_EndianUtils.hpp
index 658138633b92..340740e1224c 100644
--- a/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_EndianUtils.hpp
+++ b/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_EndianUtils.hpp
@@ -1,11 +1,11 @@
---- source/XMPFiles/FormatSupport/EndianUtils.hpp.orig 2008-02-26 11:51:10.000000000 -0500
-+++ source/XMPFiles/FormatSupport/EndianUtils.hpp 2008-02-26 11:51:17.000000000 -0500
-@@ -38,7 +38,7 @@
- #endif
- #endif
- #elif XMP_UNIXBuild
--#include <endian.h>
-+#include <machine/endian.h>
- #if BYTE_ORDER == BIG_ENDIAN
- #define kBigEndianHost 1
- #elif BYTE_ORDER == LITTLE_ENDIAN
+--- source/XMPFiles/FormatSupport/EndianUtils.hpp.orig 2008-07-08 15:22:01.000000000 -0500
++++ source/XMPFiles/FormatSupport/EndianUtils.hpp 2008-07-08 15:22:35.000000000 -0500
+@@ -57,7 +57,7 @@
+ # define kBigEndianHost 1
+ # endif
+ # else
+-# include <endian.h>
++# include <machine/endian.h>
+ # if BYTE_ORDER == BIG_ENDIAN
+ # define kBigEndianHost 1
+ # elif BYTE_ORDER == LITTLE_ENDIAN
diff --git a/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_Reconcile_Impl.cpp b/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_Reconcile_Impl.cpp
deleted file mode 100644
index 90e3f7c221e5..000000000000
--- a/textproc/exempi/files/patch-source_XMPFiles_FormatSupport_Reconcile_Impl.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- source/XMPFiles/FormatSupport/Reconcile_Impl.cpp.orig 2008-02-26 11:56:56.000000000 -0500
-+++ source/XMPFiles/FormatSupport/Reconcile_Impl.cpp 2008-02-26 12:04:09.000000000 -0500
-@@ -249,7 +249,7 @@
-
- iconv_t cd = iconv_open( "ISO8859-1", "UTF-8" );
-
-- char * in = (char *)utf8Ptr;
-+ const char * in = (char *)utf8Ptr;
- size_t inLen = utf8Len;
- size_t outLen = utf8Len * 4;
- char * buf = (char *)calloc( outLen, 1 );
-@@ -406,7 +406,7 @@
-
- iconv_t cd = iconv_open( "UTF-8", "ISO8859-1" );
-
-- char * in = (char *)_latin1Ptr;
-+ const char * in = (char *)_latin1Ptr;
- size_t inLen = latin1Len;
- size_t outLen = latin1Len * 4;
- char * buf = (char *)calloc( outLen, 1 );