aboutsummaryrefslogtreecommitdiff
path: root/textproc/exmpp/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2010-08-26 13:20:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2010-08-26 13:20:17 +0000
commitd1e1053b93864dbf8ff7c5a48559be879caa5384 (patch)
treef5f8b2f2419971a7d5ebf3bfc003ac887f756e89 /textproc/exmpp/Makefile
parentc34278e7e799380f58074974781f74151096adfe (diff)
Notes
Diffstat (limited to 'textproc/exmpp/Makefile')
-rw-r--r--textproc/exmpp/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/textproc/exmpp/Makefile b/textproc/exmpp/Makefile
new file mode 100644
index 000000000000..29954f1c1a63
--- /dev/null
+++ b/textproc/exmpp/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: exmpp
+# Date created: 26 May 2010
+# Whom: Maxim Ignatenko
+#
+# $FreeBSD$
+#
+
+PORTNAME= exmpp
+PORTVERSION= 0.9.3
+CATEGORIES= textproc net-im
+MASTER_SITES= http://download.process-one.net/${PORTNAME}/
+
+MAINTAINER= gelraen.ua@gmail.com
+COMMENT= Fast and scalable library for XMPP written in Erlang/OTP
+
+BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
+RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2 \
+ xml2:${PORTSDIR}/textproc/libxml2
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --enable-static=yes \
+ --enable-shared=yes \
+ --with-erlang=${LOCALBASE} \
+ --with-expat=${LOCALBASE} \
+ --with-openssl=/usr \
+ --disable-debug \
+ --disable-warnings \
+ --disable-examples
+GNU_CONFIGURE_PREFIX= "${PREFIX}/lib/erlang/lib"
+
+.if defined(NOPORTDOCS)
+CONFIGURE_ARGS+= --disable-documentation
+.else
+CONFIGURE_ARGS+= --enable-documentation
+.endif
+
+post-configure:
+ ${MAKE} clean -C ${WRKSRC}
+
+.include <bsd.port.mk>