aboutsummaryrefslogtreecommitdiff
path: root/textproc/exslt/Makefile
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-07-09 12:34:11 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-07-09 12:34:11 +0000
commit5c1b9bab3211e231e2e0396eb4ad21a93e768448 (patch)
tree16f635d75d44283314ebd9b410181fb2512b18ea /textproc/exslt/Makefile
parent71e7d2029a95e74b53231975c8e27c57a327b304 (diff)
downloadports-5c1b9bab3211e231e2e0396eb4ad21a93e768448.tar.gz
ports-5c1b9bab3211e231e2e0396eb4ad21a93e768448.zip
Notes
Diffstat (limited to 'textproc/exslt/Makefile')
-rw-r--r--textproc/exslt/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/textproc/exslt/Makefile b/textproc/exslt/Makefile
new file mode 100644
index 000000000000..57a817f8a191
--- /dev/null
+++ b/textproc/exslt/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: exslt
+# Date created: 2004-07-08
+# Whom: Herve Quiroz <herve.quiroz@esil.univ-mrs.fr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= exslt
+PORTVERSION= 2003.10.24
+CATEGORIES= textproc
+MASTER_SITES= http://www.exslt.org/
+DISTNAME= all-${PORTNAME}
+DIST_SUBDIR= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= herve.quiroz@esil.univ-mrs.fr
+COMMENT= Community initiative extensions to XSLT
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+DATAFILES= base.css date dyn exsl func howto.html index.html math random regexp set str
+
+do-install:
+ @${ECHO_MSG} ">> Installing stylesheets and documentation in ${DATADIR}"
+ @${MKDIR} ${DATADIR}
+ @cd ${WRKSRC} && \
+ ${FIND} ${DATAFILES} -type d -exec ${MKDIR} "${DATADIR}/{}" \; && \
+ ${FIND} ${DATAFILES} ! -type d -exec ${INSTALL_DATA} "{}" "${DATADIR}/{}" \;
+
+post-install:
+ @${FIND} -s ${DATAFILES:S/^/${DATADIR}\//} ! -type d 2>/dev/null | \
+ ${SED} -ne 's,^${PREFIX}/,,p' >> ${TMPPLIST}
+ @${FIND} -s -d ${DATAFILES:S/^/${DATADIR}\//} -type d 2>/dev/null | \
+ ${SED} -ne 's,^${PREFIX}/,@dirrm ,p' >> ${TMPPLIST}
+ @${ECHO_CMD} '@dirrm ${DATADIR:S,^${PREFIX}/,,}' >> ${TMPPLIST}
+
+.include <bsd.port.mk>