aboutsummaryrefslogtreecommitdiff
path: root/textproc/fldiff/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-01-15 13:40:28 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-01-15 13:40:28 +0000
commitc4c14fd1564a7a3bd0ae1cd2fb6050b662c936f8 (patch)
tree98f96307b5a32cecd5d4e2104c22673c560b9789 /textproc/fldiff/Makefile
parent56b2cbf1c5abcce2be96f0aa252e4df4d8d99dd2 (diff)
downloadports-c4c14fd1564a7a3bd0ae1cd2fb6050b662c936f8.tar.gz
ports-c4c14fd1564a7a3bd0ae1cd2fb6050b662c936f8.zip
Notes
Diffstat (limited to 'textproc/fldiff/Makefile')
-rw-r--r--textproc/fldiff/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/textproc/fldiff/Makefile b/textproc/fldiff/Makefile
index c0f29e2a50e2..a0ad3acfba31 100644
--- a/textproc/fldiff/Makefile
+++ b/textproc/fldiff/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fldiff
-# Date created: 13 Sep 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= fldiff
PORTVERSION= 1.1
@@ -18,7 +14,7 @@ COMMENT= A graphical diff program using FLTK
LICENSE= GPLv2
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+LIB_DEPENDS= fltk:${PORTSDIR}/x11-toolkits/fltk
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
@@ -28,6 +24,10 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAN1= fldiff.1
PORTDOCS= index.html fldiff.jpg
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|@OPTIM@||' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|=Development|=Application;Development;|' \
@@ -40,7 +40,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/fldiff.desktop ${PREFIX}/share/applications
${MKDIR} ${PREFIX}/share/pixmaps
${INSTALL_DATA} ${WRKSRC}/fldiff.png ${PREFIX}/share/pixmaps
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif