aboutsummaryrefslogtreecommitdiff
path: root/textproc/fldiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-09-08 09:05:45 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-09-08 09:05:45 +0000
commit626d660bc350beb66e683449983a63b64f39d53e (patch)
treefb75851cd5ecc10cc8ea7abf600b92ed43c1aabb /textproc/fldiff
parentecaa793d7a08ba5fa83bbb85c12cb606030b5d04 (diff)
downloadports-626d660bc350beb66e683449983a63b64f39d53e.tar.gz
ports-626d660bc350beb66e683449983a63b64f39d53e.zip
Notes
Diffstat (limited to 'textproc/fldiff')
-rw-r--r--textproc/fldiff/Makefile6
-rw-r--r--textproc/fldiff/files/patch-DiffWindow.cxx17
2 files changed, 20 insertions, 3 deletions
diff --git a/textproc/fldiff/Makefile b/textproc/fldiff/Makefile
index 6dce95a53475..8eade12a7d74 100644
--- a/textproc/fldiff/Makefile
+++ b/textproc/fldiff/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fldiff
PORTVERSION= 1.1
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= textproc
MASTER_SITES= http://www.easysw.com/~mike/fldiff/ \
CRITICAL
@@ -16,6 +16,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-source
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A graphical diff program using FLTK
+LICENSE= GPLv2
+
LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
GNU_CONFIGURE= yes
@@ -23,8 +25,6 @@ MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-LICENSE= GPLv2
-
MAN1= fldiff.1
PORTDOCS= index.html fldiff.jpg
diff --git a/textproc/fldiff/files/patch-DiffWindow.cxx b/textproc/fldiff/files/patch-DiffWindow.cxx
new file mode 100644
index 000000000000..db526c0b7cd9
--- /dev/null
+++ b/textproc/fldiff/files/patch-DiffWindow.cxx
@@ -0,0 +1,17 @@
+--- ./DiffWindow.cxx.orig 2006-11-13 19:54:02.000000000 +0100
++++ ./DiffWindow.cxx 2011-09-08 10:20:08.000000000 +0200
+@@ -1126,11 +1126,11 @@
+ DiffWindow::save_prefs()
+ {
+ // Save the window prefs for the next run...
+- prefs_.set("color", color());
+- prefs_.set("selection_color", selection_color());
++ prefs_.set("color", static_cast<int>(color()));
++ prefs_.set("selection_color", static_cast<int>(selection_color()));
+ prefs_.set("showlinenum", showlinenum());
+ prefs_.set("tabwidth", tabwidth());
+- prefs_.set("textcolor", textcolor());
++ prefs_.set("textcolor", static_cast<int>(textcolor()));
+ prefs_.set("textsize", textsize());
+ prefs_.set("ignoreblanks", ignoreblanks());
+ }